cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

335
Views
0
Helpful
0
Replies
Beginner

Aironet not native VLAN for management

Greetings,

I have outdated AIR-BR1310 with broken configuration. This is not about fixing it, but mostly about understanding why it works like it works.

 

BR1310 is connected via trunk interface. Native VLAN have nothing, VLAN 26 is for wireless and VLAN 20 is for management. Configuration will follow.

 

After some experiments I had learned the following:

1. There is no routing (even default gateway) if BVI1 have no IP address.

2. There is no way to have routing on other BVI interface.

3. IP works if FastEthernet0.20 have IP address (but without routing).

4. There is no way to remove bridge-group1 from FastEthernet0, so there is no way to disconnect native VLAN with BVI1.

 

I conclude that only native VLAN (which arrive to FastEthernet 0 and hard-attached to BVI1) can be the management one, so I can ping or tftp via router. 

 

Is there a proper configuration to have management working over not-native VLAN?

 

interface Dot11Radio0
no ip address
no ip route-cache
!
encryption vlan 26 mode ciphers aes-ccm tkip

bridge-group 1

bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled

!

interface Dot11Radio0.26
encapsulation dot1Q 26
no ip route-cache
no snmp trap link-status
bridge-group 26

bridge-group 26 subscriber-loop-control
bridge-group 26 block-unknown-source
no bridge-group 26 source-learning
no bridge-group 26 unicast-flooding
bridge-group 26 spanning-disabled

!

interface FastEthernet0
no ip address
no ip route-cache
l2-filter bridge-group-acl
bridge-group 1
no bridge-group 1 source-learning
bridge-group 1 spanning-disabled

!

interface FastEthernet0.20
encapsulation dot1Q 20
ip address 172.20.20.21 255.255.255.0
no ip route-cache
no snmp trap link-status
bridge-group 20
no bridge-group 20 source-learning
bridge-group 20 spanning-disabled

!

interface FastEthernet0.26
encapsulation dot1Q 26
no ip route-cache
no snmp trap link-status
bridge-group 26
no bridge-group 26 source-learning

!

interface BVI1
no ip address
no ip route-cache

!

ip default-gateway 172.20.20.254

Sincerely yours.
CreatePlease to create content
Content for Community-Ad

August's Community Spotlight Awards