cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
5219
Views
0
Helpful
19
Replies

Cisco 3802 Can't discover WLC

We have recently purchased 3802 APs for the first time, having always used 3702s. 

I cannot get any of these 3802s to join a WLC. The usual discovery method is via the CAPWAP DNS entry (CISCO-CAPWAP-CONTROLLER.localdomain) and this is working fine for our 3702s so I know its set up right. 

But even when deployed into the same VLAN, alongside 3702s the 3802s never seem to get to the DNS lookup. 

I've connected a console cable to one of the APs and following boot up and getting an IP it just repeats the following. It never gets as far as trying to join a WLC and I don't understand why.

[*08/30/2016 16:08:53.1291] CAPWAP State: Init

[*08/30/2016 16:08:53.1292] CAPWAP State: Discovery

[*08/30/2016 16:08:53.1293] Did not get log server settings from DHCP.
[*08/30/2016 16:09:02.6320] CAPWAP State: Discovery
[*08/30/2016 16:09:02.6321] Did not get log server settings from DHCP.
[*08/30/2016 16:09:12.1348] CAPWAP State: Discovery
[*08/30/2016 16:09:12.1349] Did not get log server settings from DHCP.
[*08/30/2016 16:09:21.6375] CAPWAP State: Discovery
[*08/30/2016 16:09:21.6376] Did not get log server settings from DHCP.
It simply repeats that for about 10 minutes then reboots and does it all again.
Whereas a 3702 joins without issue. 
What am I missing? 
19 REPLIES 19
VIP Mentor

It could be this bug, try the

It could be this bug, try the given work around and upgrade WLC code if you are running with an affected code.

CAPWAP DNS discovery not picking domain-name string
CSCuz15475
Description
Symptom:
1800/2800/3800 AP models can't discover controller through DNS process

Conditions:
During CAPWAP discovery process, DNS requests are sent out to resolve WLC IPs. These are usually resolved based on domain-name, dns-server received during DHCP process. This doesn't seem to be picked up correctly now.


Workaround:
Use DHCP option 43 or local broadcast discovery
Details
Last Modified:
Aug 29,2016
Status:
Fixed
Severity:
1 Catastrophic
Product:
(1)
Cisco Aironet 1850 Series Access Points
Support Cases:
28
Known Affected Releases:
(3)
8.2(110.0)
8.3(15.101)
8.3(15.80)
Known Fixed Releases:
(6)
8.2(110.5)
8.2(111.8)
8.2(121.0)
8.3(15.135)
8.3(15.136)
8.3(15.152)

HTH

Rasika

*** Pls rate all useful responses ***

Hi Rasika

Hi Rasika

We are running 8.2.121.0 on the WLC.

The 8802's are running 8.2.20.16 running image out of the box. 

We've run debug capwap client event on a broken 3802 and a working 3702.

The 3802 says this - Could Not resolve CISCO-CAPWAP-CONTROLLER..

The 3702 says this - Translating "CISCO-CAPWAP-CONTROLLER.ourdomain.com"...domain server (***.**.**.***) [OK]

So the 3802s don't seem to be picking up our local domain name and therefore not translating the DNS entry properly.

I can confirm that the issue

I can confirm that the issue is with the 8.2.20.16 mini IOS (or whatever it is called)

My problems where on the 3800 series ---- lots and lots of them :-/

/Thomas

Highlighted
Beginner

We've used option 43 for

We've used option 43 for years and it really helps the AP come up quickly since it doesn't reply on DNS to reach the controller.

VIP Mentor

Re: We've used option 43 for

Can you provide the output of these commands:

sh sysinfo from WLC (Just need to find out the country code configured on WLC )

sh version from AP

 

Also paste the complete bootup process logs from AP console.

 

Regards

Dont forget to rate helpful posts

Beginner

Re: We've used option 43 for

I dont have  the output of commands as today I am not at work. But I have the output for 3702I and 2802I.

I will look forward for your response.

VIP Mentor

Re: We've used option 43 for

Which county code configured on WLC ?

Beginner

Re: We've used option 43 for

Netherlands

Beginner

Re: We've used option 43 for

The string on WLC is 

  • option-43 5A1D;B2;K4;I172.20.14.17;J80
  • I have attached output of boot process and sh version command.

Still the AP is not able to join the controller.

Beginner

Re: It could be this bug, try the

We use option 43 and still we are facing this. Any recommendations

[*06/23/2016 01:51:36.5597] DOT11_DRV[0]: set_channel Channel set to 1
[*06/23/2016 01:51:37.1543] DOT11_DRV[0]: set_channel Channel set to 1
[*06/23/2016 01:51:38.3366] DOT11_DRV[1]: set_channel Channel set to 36
[*06/23/2016 01:51:38.9426] DOT11_DRV[1]: set_channel Channel set to 36
[*06/23/2016 01:51:39.0543] WTP IP Address = 192.168.5.26
[*06/23/2016 01:51:39.7227] DOT11_DRV[0]: set_channel Channel set to 1
[*06/23/2016 01:51:40.3733] DOT11_DRV[0]: set_channel Channel set to 1
[*06/23/2016 01:51:41.5612] DOT11_DRV[1]: set_channel Channel set to 36
[*06/23/2016 01:51:42.2427] DOT11_DRV[1]: set_channel Channel set to 36
[*06/23/2016 01:51:42.3595] CAPWAP State: Discov[06/23/2016 01:51:42.4000] device capwap0 entered promiscuous mode
ery
[*06/23/2016 01:51:42.3597] Did not get log[06/23/2016 01:51:42.5200] device capwap1 entered promiscuous mode
server settings from DHCP.
[*06/23/2016 01:51:42.3615] CAPWAP State: Init
[*06/23/2016 01:51:42.3617] CAPWAP State: Discovery
[*06/23/2016 01:51:51.7930] CAPWAP State: Discovery
[*06/23/2016 01:51:51.7931] Did not get log server settings from DHCP.
[*06/23/2016 01:52:01.2958] CAPWAP State: Discovery
[*06/23/2016 01:52:01.2959] Did not get log server settings from DHCP.
[*06/23/2016 01:52:10.7985] CAPWAP State: Discovery
[*06/23/2016 01:52:10.7986] Did not get log server settings from DHCP.
[*06/23/2016 01:52:20.3012] CAPWAP State: Discovery
[*06/23/2016 01:52:20.3013] Did not get log server settings from DHCP.
[*06/23/2016 01:52:29.8040] CAPWAP State: Discovery
[*06/23/2016 01:52:29.8042] Did not get log server settings from DHCP.
[*06/23/2016 01:52:39.3068] CAPWAP State: Discovery
[*06/23/2016 01:52:39.3069] Did not get log server settings from DHCP.
[*06/23/2016 01:52:48.8095] CAPWAP State: Discovery
[*06/23/2016 01:52:48.8096] Did not get log server settings from DHCP.
[*06/23/2016 01:52:58.3123] CAPWAP State: Discovery
[*06/23/2016 01:52:58.3124] Did not get log server settings from DHCP.
[*06/23/2016 01:53:07.8150] CAPWAP State: Discovery
[*06/23/2016 01:53:07.8151] Did not get log server settings from DHCP.
[*06/23/2016 01:53:17.3178] CAPWAP State: Discovery
[*06/23/2016 01:53:17.3179] Did not get log server settings from DHCP.
[*06/23/2016 01:53:26.8205] CAPWAP State: Discovery
[*06/23/2016 01:53:26.8206] Did not get log server settings from DHCP.
[*06/23/2016 01:53:36.3232] CAPWAP State: Discovery
[*06/23/2016 01:53:36.3233] Did not get log server settings from DHCP.
[*06/23/2016 01:53:45.8260] CAPWAP State: Discovery
[*06/23/2016 01:53:45.8261] Did not get log server settings from DHCP.
[*06/23/2016 01:53:55.3287] CAPWAP State: Discovery
[*06/23/2016 01:53:55.3288] Did not get log server settings from DHCP.
[*06/23/2016 01:54:04.8314] CAPWAP State: Discovery
[*06/23/2016 01:54:04.8315] Did not get log server settings from DHCP.
[*06/23/2016 01:54:14.3343] CAPWAP State: Discovery
[*06/23/2016 01:54:14.3344] Did not get log server settings from DHCP.
[*06/23/2016 01:54:23.8370] CAPWAP State: Discovery
[*06/23/2016 01:54:23.8371] Did not get log server settings from DHCP.
[*06/23/2016 01:54:33.3397] CAPWAP State: Discovery
[*06/23/2016 01:54:33.3398] Did not get log server settings from DHCP.
[*06/23/2016 01:54:42.8424] CAPWAP State: Discovery
[*06/23/2016 01:54:42.8425] Did not get log server settings from DHCP.
[*06/23/2016 01:54:52.3452] CAPWAP State: Discovery
[*06/23/2016 01:54:52.3453] Did not get log server settings from DHCP.
[*06/23/2016 01:55:01.8479] CAPWAP State: Discovery
[*06/23/2016 01:55:01.8480] Did not get log server settings from DHCP.
[*06/23/2016 01:55:11.3506] CAPWAP State: Discovery
[*06/23/2016 01:55:11.3507] Did not get log server settings from DHCP.
[*06/23/2016 01:55:20.8533] CAPWAP State: Discovery
[*06/23/2016 01:55:20.8534] Did not get log server settings from DHCP.
[*06/23/2016 01:55:30.3561] CAPWAP State: Discovery

VIP Mentor

Re: It could be this bug, try the

can you put AP and WLC in same subnet and try again.

 

If still fails then please paste the complete bootup process logs from 3702 AP console.

 

Regards

Dont forget to arte helpful posts

Beginner

Re: It could be this bug, try the

Could you elaborate why does the AP and WLC needs to be in the same subnet? PnP should work irrespective of it. It works for 3702, but not for 2802i.

Do you think option 43 string should be in hex?

 

Beginner

Re: It could be this bug, try the

Additionally,  Option 43 is used if the APs reside in a different subnet.

VIP Mentor

Re: It could be this bug, try the

We need to use option 43 is AP and WLC in diff subnet and yes it should be in HEX format.

Example:
IP of WLC: 145.18.6.152

option 43 hex F10491120698

 

Regards

Dont forget to rate helpful posts

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards