cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
370
Views
0
Helpful
3
Replies
Highlighted
Frequent Contributor

DHCP issue with Wirless 1811W Router

Hi Everyone,

I am setting up 1811w router for accessing internet.

DHCP is configured on it but it is not providing IP to laptop connected on port fa6.

Here is config of router

dot11 ssid internet

vlan 98

authentication open

authentication key-management wpa

guest-mode

wpa-psk ascii 0 010907150A59111C390C

!

ip source-route

!

!

!

ip dhcp pool WIRELESS

   import all

   network 192.168.98.0 255.255.255.0

   default-router 192.168.98.1

   dns-server 4.2.2.2

   lease 3

!

!

ip cef

no ipv6 cef

!

multilink bundle-name authenticated

!

!

!

vtp mode transparent

!

!

!

archive

log config

  hidekeys

!

!

vlan 98

!

bridge irb

!

!

!

interface Dot11Radio0

no ip address

!

encryption vlan 98 mode ciphers tkip

!

ssid internet

!

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0

54.0

station-role root

no cdp enable

!

interface Dot11Radio0.1

!

interface Dot11Radio0.98

encapsulation dot1Q 98

no cdp enable

bridge-group 98

bridge-group 98 subscriber-loop-control

bridge-group 98 spanning-disabled

bridge-group 98 block-unknown-source

no bridge-group 98 source-learning

no bridge-group 98 unicast-flooding

!

interface Dot11Radio1

no ip address

shutdown

speed basic-6.0 9.0 basic-12.0 18.0 basic-24.0 36.0 48.0 54.0

station-role root

!

interface FastEthernet0

ip address dhcp

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

interface FastEthernet1

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet2

!

interface FastEthernet3

!

interface FastEthernet4

!

interface FastEthernet5

!

interface FastEthernet6

switchport access vlan 98

!

interface FastEthernet7

!

interface FastEthernet8

!

interface FastEthernet9

!

interface Vlan1

no ip address

shutdown

!

interface Vlan98

no ip address

!

interface Async1

no ip address

encapsulation slip

!

interface BVI98

ip address 192.168.98.1 255.255.255.0

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1452

!

ip forward-protocol nd

no ip http server

no ip http secure-server

!

!

!

!

!

!

!

!

!

control-plane

!

bridge 98 protocol ieee

bridge 98 route ip

!

line con 0

line 1

modem InOut

stopbits 1

speed 115200

flowcontrol hardware

line aux 0

line vty 0 4

login

!

end

thanks

mahesh

Everyone's tags (4)
3 REPLIES 3
Highlighted

Re: DHCP issue with Wirless 1811W Router

You new to add bridge-group 98 under the VLAN 98 interface.

Steve

Sent from Cisco Technical Support iPhone App

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
Highlighted
Frequent Contributor

DHCP issue with Wirless 1811W Router

Hi Steve,

Thanks for reply.

I did that but then int vlan 98 went up down.

also still laptop not getting dhcp.

thanks

mahesh

Highlighted
Frequent Contributor

DHCP issue with Wirless 1811W Router

hi steve,

One thing to add is that without int vlan 98

bridge-group 98 command wi fi laptops are able to get the IP from dhcp but wired pc does not.

thanks

mahesh

CreatePlease to create content
Content for Community-Ad

Cisco COVID-19 Survey