cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2853
Views
5
Helpful
4
Replies
Highlighted
Enthusiast

Enabling LAG on WLC 5508 with two Nexus 7K switches connected in VPC

Dear Experts,

I have a WLC 5508 configured in HA(box-to-box). As of now I have both the primary and standby WLC's port number 1 being connected on to the 1st Nexus 7K, however in order to avail redundancy, I would want to enable lag and have the ports numbered 2 from primary and standby WLC to the second Nexus 7K switch. 
From what I have seen from documents, it appears to be a valid configuration however little skeptical if I would run into any issues while enabling the LAG against two different uplink switches configured in VPC. Please suggest do's and dont's while proceeding with this scenario. 

As always, appreciate the valuable responses. 

Thanks,

4 REPLIES 4
Highlighted
VIP Mentor

check these threads , it may help;

https://supportforums.cisco.com/discussion/12919111/connecting-5520s-wlc-nexus-7706s

https://supportforums.cisco.com/discussion/10784436/how-connect-wlc-5508-2-switches-redundancy

Regards

Dont forget to rate helpful posts

Highlighted

Hi All, 

Still no clues :(

Please find topology that I am trying out in attachment and below as my configuration. 

N7K-F248XP-25E --Core 1
interface po10
description ***Connected to WLC primary & standby***
switchport
switchport mode trunk
switchport trunk native vlan 56 (56 is the management vlan of wlc)
vpc 10

conf t
interface ethernet 4/11
description ***Connected to standby***
switchport
switchport mode trunk
channel-group 10 mode on
no shut


conf t
interface ethernet 4/12
description ****Connected to primary***
switchport
switchport mode trunk
channel-group 10 mode on
no shut

interface Vlan56
no ip redirects
ip address 172.20.56.2/24
hsrp version 2
hsrp 56
authentication md5 key-chain hsrp
preempt
priority 110 forwarding-threshold lower 1 upper 110
ip 172.20.56.1
ip dhcp relay address 172.20.50.4
ip dhcp relay address 172.20.50.5
ip dhcp relay address 172.20.50.6
description Wless-WLC-Mgmt
no shutdown

**************************************************************************************

N7K-F248XP-25E --Core 2

interface po10
description ***Connected to WLC primary & standby***
switchport
switchport mode trunk
switchport trunk native vlan 56 (56 is the management vlan of wlc)
vpc 10

conf t
interface ethernet 4/11
description ***Connected to standby***
switchport
switchport mode trunk
channel-group 10 mode on
no shut


conf t
interface ethernet 4/12
description ****Connected to primary***
switchport
switchport mode trunk
channel-group 10 mode on
no shut

interface Vlan56
no ip redirects
ip address 172.20.56.3/24
hsrp version 2
hsrp 56
authentication md5 key-chain hsrp
preempt
priority 120 forwarding-threshold lower 1 upper 120
ip 172.20.56.1
ip dhcp relay address 172.20.50.4
ip dhcp relay address 172.20.50.5
ip dhcp relay address 172.20.50.6
description Wless-WLC-Mgmt
no shutdown

Highlighted

Hello Folks,

Finally got it going by assistance from Cisco TAC. Sharing for the reference of others. 

Per Cisco TAC:

A WLC configured in LAG has to be connected only to one upstream core and not across two cores. Even though the nexii are configured in vPC, still the WLC has to be connected to a single upstream core itseems. 

Primary WLC connected to 1st upstream core and the secondary WLC connected to 2nd upstream core. 

Please find below as the configuration from primary and secondary nexii.

primary nexus: 

conf t
interface ethernet 4/11
description ***Connected to primary***
switchport
switchport mode trunk
channel-group 10 mode on
no shut


conf t
interface ethernet 4/12
description ****Connected to primary***
switchport
switchport mode trunk
channel-group 10 mode on
no shut

Secondary nexus:

conf t
interface ethernet 4/11
description ***Connected to standby***
switchport
switchport mode trunk
channel-group 11 mode on
no shut


conf t
interface ethernet 4/12
description ****Connected to standby***
switchport
switchport mode trunk
channel-group 11 mode on
no shut

Highlighted

This was very helpful especially the picture. Does this solution include support of AP SSO (Stateful switch over) between active and standby Controllers?