cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
572
Views
0
Helpful
3
Replies
Highlighted

Error upgrading AIR-CT2504: "Failure while validating the signature!"

Hi All. This is is to ask if you had this issue in order to help me with your experience.

I was trying to upgrade CT2504 from 8.2.151.0 to 8.3.150.0 but when the copy is finished, either TFTP o SFTP, by CLI or GUI, fails and ends with this message: "Failure while validating the signature!".

I´ve checked the files (MD5 checksum) and all are OK. 

FUS is 1.9.

I tested going from 8.2.150.0 to 8.2.170.o successfully, but, again, from 8.2.170.0 I cannot go to 8.3.150.0.

 

Plese help me with this issue.

Regards

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Hi All. Thes issue is solved.

 

I go to the other suggested Cisco IOS: 8.5.140.0

Upgrade from 8.2.170.0 to 8.5.140.0 was successfull.

 

Thank a lot for your help.

 

Jorge

Note: upgrade from 8.2.170.0 to 8.3.x doesn´t work.

View solution in original post

3 REPLIES 3
Highlighted
Hall of Fame Community Legend

Upgrade to 8.2.16X.X first. Don't go straight to 8.3.X.X.
Highlighted

HI Leo.

Thanks for your time.

Yes, I tested going from 8.2.150.0 to 8.2.170.0 successfully.

But, new upgrade from 8.2.170.0 to 8.3.150.0 goes into "Failure while validating the signature!".

 

After that, I tried upgrading from 8.2.170.0 to 8.3.143.0 with the same results.

In the Controller´s traps I have this: "Fail to upgrade wlc, versión before upgrade: 8.2.170.0, versión after upgade: 8.2.170.0, fail reason: file check fail."

 

I´ve checked MD5 checksum, and it is OK.

 

Regards.

Jorge

Highlighted

Hi All. Thes issue is solved.

 

I go to the other suggested Cisco IOS: 8.5.140.0

Upgrade from 8.2.170.0 to 8.5.140.0 was successfull.

 

Thank a lot for your help.

 

Jorge

Note: upgrade from 8.2.170.0 to 8.3.x doesn´t work.

View solution in original post