cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Cisco announces new innovations in SD-WAN, ISRs, SD-WAN Services, and Catalyst 9000 Series switches


57
Views
0
Helpful
9
Replies
Highlighted
Beginner

Flexconnect Local Switching mode + local DHCP for several WLANs

Hi,

In Flexconnect Local Switching mode, I can get an IP adress only for a WLAN mapped to the native vlan.

I may have a bad configuration but after spending a lot of time, I'd like your point of view.

 

Here's my lab. On a branch site:
- A FlexConnect LWAP  is connected on a switch (port Fa1/0/47)

- Two DHCP scopes are configured on the switch (for Guest and Prod)
- The van id 6 is used both for admin and production. The vlan id 7 is the Guest vlan
- Local Switching enabled.  AP Flex Mapping:   WLAN Guest -> vlan 7  ,  WLAN Prod -> vlan 6
Test.jpg

The LWAP can join the WLC.

 

- On the switch port, the line "switchport access vlan 6" is ncessary. Otherwise, the AP can't join the WLC.
Never seen that before ?

 

- Connection to SSID PROD  ->  the client gets an ip (172.16.2.x) (DHCP Pool Prod). Perfect.
- Connection to SSID Guest ->  nothing. No IP delivered. I've checked agin. The WLAN-VLAN mapping on the AP is correct.

Do you have any idea ??

 

Thanks

 

Herve

9 REPLIES
Beginner

Re: Flexconnect Local Switching mode + local DHCP for several WLANs

Hi, remove from the AP port configuration "switchport access vlan 6"

 

Are you using vlan 1 as native in the rest of your configuration? If so change the trunk native to vlan 1, you need to tag the vlans  that your access point is using on this trunk port (assuming here you are using SVI's for the gateways) .

Beginner

Re: Flexconnect Local Switching mode + local DHCP for several WLANs

On the port,
interface FastEthernet1/0/47
description AP
switchport access vlan 6
switchport trunk encapsulation dot1q
switchport trunk native vlan 6
switchport trunk allowed vlan 6,7
switchport mode trunk

Re: Flexconnect Local Switching mode + local DHCP for several WLANs

Hi @herve.leon

interface FastEthernet1/0/47
description AP
switchport access vlan 6 <----- You don´t need this. You allowed the vlan 6 on trunk port
switchport trunk encapsulation dot1q
switchport trunk native vlan 6
switchport trunk allowed vlan 6,7
switchport mode trunk
Beginner

Re: Flexconnect Local Switching mode + local DHCP for several WLANs

Hi Daniel,
If I don't mention "switchport access vlan 6", the access point doesn't join the wireless controller on the HQ Site.
On CiscoLive, the session presentation BRKEWN-2016 (Branch Office Wireless Design) has this configuration as example.
https://ciscolive.cisco.com/on-demand-library/?search=BRKEWN-2016#/

Re: Flexconnect Local Switching mode + local DHCP for several WLANs

@herve.leon

 

Must be, when you specify native vlan 6 it's similar to access port, when you write native vlan 6 your APs must get an address from vlan 6. Please chek this Link and review the section "Configuring the Switch at the Remote Site"

 

Espero que la información haya sido útil y si no tienes más preguntas recuerda cerrar el topic, seleccionando la respuesta como "Respuesta correcta"

**Please rate the answer if this information was useful***

**Por favor si la información fue util marca esta respuesta como correcta**

*Tu reconocimiento nos alienta a seguir participando en los foros *

 

Re: Flexconnect Local Switching mode + local DHCP for several WLANs

Hi @herve.leon

This could be a silly replay but are you sure that VLAN 7 exist un all your switches?

Now, yuo can try by cli

 

config wlan flexconnect local-switching <wlan_id> enable
config flexconnect group GUEST vlan enable
config flexconnect group GUEST vlan native <(7)> <---- Only if you have mgmt vlan
config flexconnect group <group_name> wlan-vlan wlan <id_wlan> add vlan <vlan_user (7)> <--- Only if you have mgmt vlan and user vlan
config flexconnect group GUEST wlan-vlan <wlan_id> add vlan <vlan user (7)>

 

**Please rate the answer if this information was useful***

**Por favor si la información fue util marca esta respuesta como correcta**

*Tu reconocimiento nos alienta a seguir participando en los foros *

VIP Advisor

Re: Flexconnect Local Switching mode + local DHCP for several WLANs

Hi

 Change the port to trunk on both AP and switch. 

 

 

-If I helped you somehow, please, rate it as useful.-

 

 

Beginner

Re: Flexconnect Local Switching mode + local DHCP for several WLANs

Change the port to trunk on the AP ?? I've never read that a Lightweight Access Point needs to be configured like this.

Re: Flexconnect Local Switching mode + local DHCP for several WLANs

Hi @herve.leon

 

@Flavio Miranda is right, If you're using Flexconnect the port on the switch must be configured as trunk port.

 

 

CreatePlease to create content
Blog-Cisco Community Designated VIP Dinner CLEUR2019