cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
49243
Views
65
Helpful
34
Replies
Highlighted
Beginner

Google ChromeCast with WLAN Controller 2504

I assume that I am not the first person to run in to this and know I won't be the last person but I can't seem to get a Google ChromeCast to work on a WLAN that I set up. The WLAN Consists of an AIR-CT2504-K9 Controller and two AIR-LAP1024N-A-K9 Access Points.

I have 2 different SSIDs one private and one public, they are going through their own VLAN and don't have any issues with any other clients accessing the Internet or other resources on the networks. I verified that P2P is "Disabled" in the Public SSID which is the one we are trying to use.

When I go through the Setup Process the ChromeCast was able to join the Public Network the very first time but was not able to be seen by a client. Since then I did a factory reset the ChromeCast and tried many times to join both the Public and Private Networks with no luck.

I don't have any special security set up on the Public Network other than a Pre-Shared Key which I am positive I am imputting in properly. The ChromeCast just hangs when trying to join the network.

With this in mind I took the ChromeCast to another location with a simple, single access point WLAN Setup and was able to get it to join the network and be seen on the network without any issues.

Just as an FYI - The way that this process works is as follows: When you power up the ChromeCast it sets itself up as a Wireless Device with its own unique SSID. When you set it up your device (laptop in this case) connects to that network so you can configure it. This is where you will set up the new Wireless Network it will join with the credentials you provided. Once your submitted it your device will connect back to the network it was on originally and try to connect to the ChromeCast. As I said the ChoromeCast for whatever reason is not fully connecting to / joining the network and isn't found by the setup app and fails.

Any thoughts / suggestions would be greatly appreciated.

34 REPLIES 34
Highlighted

Thanks for the suggestions.  I just increased the User Idle and ARP timeouts from 5 minutes to 2 hours.  Figure it can't hurt, although it's unlikely to be the problem.  

No MAB right now, and I haven't configured a multicast RP or IGMP snooping yet on my switches.  That's likely to be my next step, but I'm pretty much learning this on the fly, and would like to avoid that level of complexity if at all possible.

I'll be onsite later this week and will collect a debug when I'm testing.  

Highlighted
Beginner

I just wanted to add a little info. Sorry if this is a repost. I could not find no bridge-group 1 port-protected or anything of that nature. I DID have multicast disabled though. Once enabled with Enable IGMP Snooping disabled everything came up. 

 

Thank you all. Been beating my head against the wall on this one!

Highlighted
Beginner

Hello all, for months i have struggled with casting in a WLC 2504 (ver 8.1.111.0) network environment. I have read through these white-papers multiple times and implemented all the suggested solutions but was still unable to cast or even find the Chromecast - if i reset the Chromecast i was able to sometimes connect but then it would disconnect as soon as the device restarts and no one else was able to see it.

 

If you have followed the white-papers in detail and is still having issues, rest assured that this overlooked step will solve your problem! The missing bit of information which i found out later while troubleshooting is that, the "AP Multicast Mode" Multicast address was still set to the default "0.0.0.0", this MUST be changed to "224.0.0.251" which is ICANN's universal multicast address. This can be found under:

 

CONTROLLER->GENERAL->AP Multicast Mode->Multicast.

 

I truly hope that this will help someone who is struggling. 

 

---

Hillel Academy - Tech Team

Highlighted

So I am using an anchor controller, for guest, and have a separate SSID setup for the chromecast devices, do I need to enable the mDNS on both the foreign controller and the anchor? or can I just set it up on the anchor?
Highlighted
Beginner

I had the same issue, after modifying the WLAN setting by enabling WPA and WPA2 and also enabling FlexConnect Local Switching, issue was resolved.