cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Cisco Community Designated VIP Class of 2020

1662
Views
0
Helpful
6
Replies
Beginner

How to forward DHCP requests through 1140N AP

We have an 1140N AP connected to a switch and our "network partner" controls the router and will hand out DHCP and do the NAT for this WLAN.  How can I configure the AP to forward DCHP requests through.

I have WPA2 PSK (TKIP) setup and the client is able to authenticate however we fail to get an address.  In this case the Ethernet interface was left alone so it has the default config and it gets a DHCP address fine.  How can I configure this AP to enable the rest of the WiFI clients to get an IP?

Everyone's tags (6)
1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Master

Re: How to forward DHCP requests through 1140N AP

You need to have the ip helpers on the layer 3 switch/router for vlan 10.  If you don't have control over the equipment, then you need to remove vlan 10 and use the vlan that your wired devices are connecting to.

Thanks,

Scott

Help out other by using the rating system and marking answered questions as "Answered"

-Scott
*** Please rate helpful posts ***

View solution in original post

6 REPLIES 6
Hall of Fame Master

Re: How to forward DHCP requests through 1140N AP

The ap will forward dhcp broadcast by default. You just need to make sure you have an IP helper on the vlan the users are being placed on.

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
Beginner

Re: How to forward DHCP requests through 1140N AP

Mr. Fella:

Giving it a try right now.  I'll let you know how it goes. 

Thanks for the info. 

Joshua

Hall of Fame Master

Re: How to forward DHCP requests through 1140N AP

Keep us posted....

Thanks,

Scott

Help out other by using the rating system and marking answered questions as "Answered"

-Scott
*** Please rate helpful posts ***
Beginner

Re: How to forward DHCP requests through 1140N AP

Here is my cleaned config.  I put helpers everywhere and still can't an IP. 

I don't have control over the switch or router that this will plug into nor the setup.  The switchport it will plug into has a VLAN designated for Guest Wireless access.  I suspect that I need to redo the config without VLAN10 involved correct?

Current configuration : 4880 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname [removed]

!

enable secret [removed]

!

no aaa new-model

!

!

dot11 syslog

!

dot11 ssid {removed]

   vlan 10

   authentication open

   authentication key-management wpa version 2

   guest-mode

   wpa-psk ascii 7 [removed]

!

!

crypto pki trustpoint TP-self-signed-1278736388

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-1278736388

revocation-check none

rsakeypair TP-self-signed-1278736388

!

!

crypto pki certificate chain TP-self-signed-1278736388

certificate self-signed 01

  3082024D 308201B6 A0030201 02020101 300D0609 2A864886 F70D0101 04050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 31323738 37333633 3838301E 170D3032 30333035 32323138

  33335A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 32373837

  33363338 3830819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  8100BDA9 327F8A3C CFB3C216 F23AA107 CEEE007D CFC2A89C 9064A4F2 66A07EB7

  EB7F3602 74B505D1 9A374875 1DC71A58 607632F3 2A41250B 6BB79B68 D5C1E00D

  B7AA55EB 4E36668B 9BF92E94 C2B0699D A009902A D7A802D1 DCF699F2 99F20B0B

  D5BAB32F 3F8749B2 6C641CF2 6BC7FE8C 3078876C DAC97CFD 69BA42E5 98F81B37

  70830203 010001A3 75307330 0F060355 1D130101 FF040530 030101FF 30200603

  551D1104 19301782 1561702E 736F732D 61642E73 74617465 2E6E762E 7573301F

  0603551D 23041830 1680141A 78042A2D A7149DAC E90E1EAF 6496AB47 DF674630

  1D060355 1D0E0416 04141A78 042A2DA7 149DACE9 0E1EAF64 96AB47DF 6746300D

  06092A86 4886F70D 01010405 00038181 00B38305 C973DD31 F23C1B17 78181DF9

  A5A8A409 FDBAEF54 DF94DB89 815954EA 45322B5B BDB32C6A F0353228 ADD4A398

  CC249C49 A4C9C66D 08712AC7 7C5D12D5 C412933C 9E2893C3 4A432577 2FCA9A67

  2F89FF79 8FA0DECD 88CBB2C1 A5DA778A 80839D51 1883EEE7 A8754EC9 283E25E0

  7D91F064 AC633286 81232031 0BEF403E C1

  quit

username [removed] privilege 15 password [removed]

!

!

bridge irb

!

!

interface Dot11Radio0

no ip address

ip helper-address 10.135.14.1

no ip route-cache

!

encryption vlan 10 mode ciphers tkip

!

ssid [removed]

!

antenna gain 0

speed  basic-1.0 basic-2.0 basic-5.5 basic-11.0 basic-6.0 basic-9.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0 m0. m1. m2. m3. m4. m5. m6. m7. m8. m9. m10. m11. m12. m13. m14. m15.

station-role root

bridge-group 1

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio0.10

encapsulation dot1Q 10

ip helper-address 10.135.14.1

no ip route-cache

bridge-group 10

bridge-group 10 subscriber-loop-control

bridge-group 10 block-unknown-source

no bridge-group 10 source-learning

no bridge-group 10 unicast-flooding

bridge-group 10 spanning-disabled

!

interface Dot11Radio1

no ip address

ip helper-address 10.135.14.1

no ip route-cache

!

encryption vlan 10 mode ciphers tkip

!

ssid [removed]

!

antenna gain 0

dfs band 3 block

speed  basic-6.0 basic-9.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0 m0. m1. m2. m3. m4. m5. m6. m7. m8. m9. m10. m11. m12. m13. m14. m15.

channel dfs

station-role root

bridge-group 1

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio1.10

encapsulation dot1Q 10

ip helper-address 10.135.14.1

no ip route-cache

bridge-group 10

bridge-group 10 subscriber-loop-control

bridge-group 10 block-unknown-source

no bridge-group 10 source-learning

no bridge-group 10 unicast-flooding

bridge-group 10 spanning-disabled

!

interface GigabitEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

no keepalive

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface GigabitEthernet0.10

encapsulation dot1Q 10

no ip route-cache

bridge-group 10

no bridge-group 10 source-learning

bridge-group 10 spanning-disabled

!

interface BVI1

ip address dhcp client-id GigabitEthernet0

ip helper-address 10.135.14.1

no ip route-cache

!

ip http server

ip http authentication local

no ip http secure-server

ip http help-path

http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

bridge 1 route ip

!

!

banner motd ^C

Access to this device is restricted to authorized users. Unauthorized access is a violation of state and federal, civil and criminal laws (e.g., NRS 205.4765). Evidence of unauthorized access will be provided to law enforcement personnel.

^C

!

line con 0

password [removed]

login local

line vty 0 4

password [removed]

login local

!

end

Current configuration : 4880 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname [removed]

!

enable secret [removed]

!

no aaa new-model

!

!

dot11 syslog

!

dot11 ssid {removed]

   vlan 10

   authentication open

   authentication key-management wpa version 2

   guest-mode

   wpa-psk ascii 7 [removed]

!

!

crypto pki trustpoint TP-self-signed-1278736388

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-1278736388

revocation-check none

rsakeypair TP-self-signed-1278736388

!

!

crypto pki certificate chain TP-self-signed-1278736388

certificate self-signed 01

  3082024D 308201B6 A0030201 02020101 300D0609 2A864886 F70D0101 04050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 31323738 37333633 3838301E 170D3032 30333035 32323138

  33335A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 32373837

  33363338 3830819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  8100BDA9 327F8A3C CFB3C216 F23AA107 CEEE007D CFC2A89C 9064A4F2 66A07EB7

  EB7F3602 74B505D1 9A374875 1DC71A58 607632F3 2A41250B 6BB79B68 D5C1E00D

  B7AA55EB 4E36668B 9BF92E94 C2B0699D A009902A D7A802D1 DCF699F2 99F20B0B

  D5BAB32F 3F8749B2 6C641CF2 6BC7FE8C 3078876C DAC97CFD 69BA42E5 98F81B37

  70830203 010001A3 75307330 0F060355 1D130101 FF040530 030101FF 30200603

  551D1104 19301782 1561702E 736F732D 61642E73 74617465 2E6E762E 7573301F

  0603551D 23041830 1680141A 78042A2D A7149DAC E90E1EAF 6496AB47 DF674630

  1D060355 1D0E0416 04141A78 042A2DA7 149DACE9 0E1EAF64 96AB47DF 6746300D

  06092A86 4886F70D 01010405 00038181 00B38305 C973DD31 F23C1B17 78181DF9

  A5A8A409 FDBAEF54 DF94DB89 815954EA 45322B5B BDB32C6A F0353228 ADD4A398

  CC249C49 A4C9C66D 08712AC7 7C5D12D5 C412933C 9E2893C3 4A432577 2FCA9A67

  2F89FF79 8FA0DECD 88CBB2C1 A5DA778A 80839D51 1883EEE7 A8754EC9 283E25E0

  7D91F064 AC633286 81232031 0BEF403E C1

  quit

username [removed] privilege 15 password [removed]

!

!

bridge irb

!

!

interface Dot11Radio0

no ip address

ip helper-address 10.135.14.1

no ip route-cache

!

encryption vlan 10 mode ciphers tkip

!

ssid [removed]

!

antenna gain 0

speed  basic-1.0 basic-2.0 basic-5.5 basic-11.0 basic-6.0 basic-9.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0 m0. m1. m2. m3. m4. m5. m6. m7. m8. m9. m10. m11. m12. m13. m14. m15.

station-role root

bridge-group 1

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio0.10

encapsulation dot1Q 10

ip helper-address 10.135.14.1

no ip route-cache

bridge-group 10

bridge-group 10 subscriber-loop-control

bridge-group 10 block-unknown-source

no bridge-group 10 source-learning

no bridge-group 10 unicast-flooding

bridge-group 10 spanning-disabled

!

interface Dot11Radio1

no ip address

ip helper-address 10.135.14.1

no ip route-cache

!

encryption vlan 10 mode ciphers tkip

!

ssid [removed]

!

antenna gain 0

dfs band 3 block

speed  basic-6.0 basic-9.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0 m0. m1. m2. m3. m4. m5. m6. m7. m8. m9. m10. m11. m12. m13. m14. m15.

channel dfs

station-role root

bridge-group 1

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio1.10

encapsulation dot1Q 10

ip helper-address 10.135.14.1

no ip route-cache

bridge-group 10

bridge-group 10 subscriber-loop-control

bridge-group 10 block-unknown-source

no bridge-group 10 source-learning

no bridge-group 10 unicast-flooding

bridge-group 10 spanning-disabled

!

interface GigabitEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

no keepalive

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface GigabitEthernet0.10

encapsulation dot1Q 10

no ip route-cache

bridge-group 10

no bridge-group 10 source-learning

bridge-group 10 spanning-disabled

!

interface BVI1

ip address dhcp client-id GigabitEthernet0

ip helper-address 10.135.14.1

no ip route-cache

!

ip http server

ip http authentication local

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

bridge 1 route ip

!

!

banner motd ^C

Access to this device is restricted to authorized users. Unauthorized access is a violation of state and federal, civil and criminal laws (e.g., NRS 205.4765). Evidence of unauthorized access will be provided to law enforcement personnel.

^C

!

line con 0

password [removed]

login local

line vty 0 4

password [removed]

login local

!

end

Hall of Fame Master

Re: How to forward DHCP requests through 1140N AP

You need to have the ip helpers on the layer 3 switch/router for vlan 10.  If you don't have control over the equipment, then you need to remove vlan 10 and use the vlan that your wired devices are connecting to.

Thanks,

Scott

Help out other by using the rating system and marking answered questions as "Answered"

-Scott
*** Please rate helpful posts ***

View solution in original post

Highlighted
Beginner

Re: How to forward DHCP requests through 1140N AP

Thank you very much sir!  That did the trick.  To be sure I blew out the config and started fresh.  I now see that in the Guide it pointed out that the keyword vlan was "optional" but I didn't recognize the optional part.  Makes perfect sense so thank you for clearing things up!

CreatePlease to create content
Content for Community-Ad

August's Community Spotlight Awards