cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
4802
Views
25
Helpful
15
Replies
Highlighted
Beginner

IOS of the Integrated wireless AP in a Cisco 881W

Hi Guys,



I wonder if anyone can point to a document or maybey dont mind explaing to me how to upgrade

the IOS of the Integrated wireless AP in a Cisco 881W using TFTP server please (I do have software)

Router side is not an issue it is the integrated AP that gives me headache




Many thanks

J

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Community Legend

Re: IOS of the Integrated wireless AP in a Cisco 881W

Can you Telnet/SSH into the AP?  If you can then do this:

1.  Copy the AP IOS from your TFTP to your router;

2.  From the router, enter this configuration command:  tftp flash:IOS.tar

3.  Session into your AP and issue this command "archive download-sw tftp://Router IP Address/IOS.tar".

NOTE:  There are few more methods I can think of but this, by far, is the simplest and easiest way.  

View solution in original post

15 REPLIES 15
Hall of Fame Community Legend

Re: IOS of the Integrated wireless AP in a Cisco 881W

Can you Telnet/SSH into the AP?  If you can then do this:

1.  Copy the AP IOS from your TFTP to your router;

2.  From the router, enter this configuration command:  tftp flash:IOS.tar

3.  Session into your AP and issue this command "archive download-sw tftp://Router IP Address/IOS.tar".

NOTE:  There are few more methods I can think of but this, by far, is the simplest and easiest way.  

View solution in original post

Beginner

Re: IOS of the Integrated wireless AP in a Cisco 881W

Thank you for your reply leolaohoo

I am new to this stuff so can I be more specific with regards to the the steps so to copy anything to AP whether it is from TFTP or router do I need to have my Gigabit interface in trunk mode and assign BVI an IP ? And also when you session into AP and issue ''archive download-sw tftp://Router IP Address/IOS.tar"  is my router becoming and TFTP automatically?

I know it you must be laughing these must really stupid questions but I am learning.

Many thanks

J

Hall of Fame Community Legend

Re: IOS of the Integrated wireless AP in a Cisco 881W

AP whether it is from TFTP or router do I need to have my Gigabit interface in trunk mode and assign BVI an IP ?

That is correct.  Make sure your AP management interface, BV1, is able to ping your router's management interface (which should be in the same subnet).

And also when you session into AP and issue ''archive download-sw tftp://Router IP Address/IOS.tar"  is my router becoming and TFTP automatically?

No.  Your router becomes a TFTP server only after you enter the command "tftp-server flash:IOS.tar".

I know it you must be laughing these must really stupid questions but I am learning.

Not laughing.  Don't even think your questions are remotely close to being classified as "stupid" or "dumb".  I always believe that the only "stupid" questions are the ones you DON'T ASK.

NOTE:  I do hope you have this command in your router:  service-module wlan-ap 0 bootimage autonomous

Rising star

Re: IOS of the Integrated wireless AP in a Cisco 881W

Hello John,

As per your query i can suggest you the following solution-

Performing the Upgrade

To upgrade to Unified software, follow these steps:

Step 1 Issue the service-module wlan-ap 0 bootimage unified command to change the access point boot image to the Unified upgrade image, which is also known as a recovery image.

Router# conf terminal

Router(config)# service-module wlan-ap 0 bootimage unified

Router(config)# end

Step 2 Issue the service-module wlan-ap 0 reload command to perform a graceful shutdown and reboot the access point and complete the upgrade process. Session into the access point and monitor the upgrade process.

For more information please refer the link-

http://www.cisco.com/en/US/docs/routers/access/1900/software/configuration/guide/wlan.html#wp1055017

Hope this will help you.

Hall of Fame Community Legend

IOS of the Integrated wireless AP in a Cisco 881W

Router(config)# service-module wlan-ap 0 bootimage unified

Hi Abhishek,

That's not going to work.  The proceedure you've posted is to automatically load the controller-based IOS.  I believe John's issue is HOW TO UPGRADE the IOS. 

Beginner

Re: IOS of the Integrated wireless AP in a Cisco 881W

Hello Abhishek thank you for your post,

Yes,leolaohoo is absolutely right, I am trying to upgrade my buggy IOS (keeps rebooting) on internal AP on 881w.

Leolaohoo, appreciate your prompt response hopefully on weekend I will be able to perform the upgrade to the latest IOS and see if that would resolve the issue.

Can I trouble you shoould I ,,hit the wall'' ?

Many Thanks

J

Hall of Fame Community Legend

IOS of the Integrated wireless AP in a Cisco 881W

Can I trouble you shoould I ,,hit the wall

Sure.  That's what we're all here for. 

Beginner

Re: IOS of the Integrated wireless AP in a Cisco 881W

Hello leolaohoo,

I coudnt wait till weekend so had a go at it tonight and...nothing happens,

I mean I can not ping my BVI interface from my router and vice versa.

As far as I my knowledge and my config goes I can say that it should work

and really don't want to think that the unit itself is faulty,

Therefore can I kindly ask you to have a look at my both configs (attached), at this point all I

am concerned about is BVI talking to router side,

Thank you your help greatly appreciated.

j

Hall of Fame Community Legend

Re: IOS of the Integrated wireless AP in a Cisco 881W

Ok.  I see some stuff here.

1.  Where is your VLAN instance for VLAN 10 and VLAN 20?

2.  Create a third VLAN, make this your management interface VLAN.  So you assign your router into this subnet.  You also assign your AP's BVI1 interface into this subnet.

3.  The link between your AP and your router is a trunk, that's good.  But assign the management VLAN as the NATIVE VLAN.

4.  Your WLAN-AP0 interface, instead of assigning an IP address, use this:  ip  unnumbered

5.  Your dialier interface, don't know what part of the world you are in, but consider adding this:  ip mtu 1460.  You can optionally add this:  ip tcp adjust-mss 1420

6.  Wireless radio interface:  Add these to both radios:  no dot11 extension aironet

Try that.

Beginner

Re: IOS of the Integrated wireless AP in a Cisco 881W

Hello leolaohoo and thank you for sticking around,

So here it is

1.  Where is your VLAN instance for VLAN 10 and VLAN 20? -  not sure if I understand this I thought that you create a VLAN assin it an IP, Default gateway , assint subinterface or interface, mode and you should be good to go ?

2.  Create a third VLAN, make this your management interface VLAN.  So you assign your router into this subnet.  You also assign your AP's BVI1 interface into this subnet.

!

interface vlan11

description management vlan

ip address 10.96.0.1 255.224.0.0

ip nat inside

ip virtual-reassembly in

!

interface vlan11

description management vlan

ip address 10.96.0.1 255.224.0.0

ip nat inside

ip virtual-reassembly in

interface GigabitEthernet0.11

encapsulation dot1Q 11 native

no ip route-cache

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

no shut

exit

interface BVI1

ip address 10.96.0.2 255.224.0.0

no ip route-cache

ip Default-gateway 10.96.0.1

3.  The link between your AP and your router is a trunk, that's good.  But assign the management VLAN as the NATIVE VLAN. 

interface GigabitEthernet0.11

encapsulation dot1Q 11 native

no ip route-cache

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

no shut

exit

4.  Your WLAN-AP0 interface, instead of assigning an IP address, use this:  ip  unnumbered

interface wlan-ap0

description Embedded Service module interface to manage the embedded AP

ip unnumbered vlan 11

5.  Your dialier interface, don't know what part of the world you are in, but consider adding this:  ip mtu 1460.  You can optionally add this:  ip tcp adjust-mss 1420

I am in london so have added ip mtu 1460

6.  Wireless radio interface:  Add these to both radios:  no dot11 extension aironet

Not sure if I need the below 0.11 interface ?

interface Dot11Radio0.11

encapsulation dot1Q 11 native

no ip route-cache

bridge-group 11

bridge-group 11 subscriber-loop-control

bridge-group 11 block-unknown-source

no bridge-group 11 source-learning

no bridge-group 11 unicast-flooding

bridge-group 11 spanning-disabled

exit

interface Dot11Radio0.10

no dot11 extension aironet

encapsulation dot1Q 10

no ip route-cache

bridge-group 10

bridge-group 10 subscriber-loop-control

bridge-group 10 block-unknown-source

no bridge-group 10 source-learning

no bridge-group 10 unicast-flooding

bridge-group 10 spanning-disabled

exit

interface Dot11Radio0.20

no dot11 extension aironet

encapsulation dot1Q 20

no ip route-cache

bridge-group 20

bridge-group 20 block-unknown-source

no bridge-group 20 source-learning

no bridge-group 20 unicast-flooding

bridge-group 20 spanning-disabled

exit

The bottom line here I am getting more and more confused and still cant ping from BVI and to it. it looks like everything that I learned about VLANS and switching between them I no longer understand or at least I am now thinking of installing this a router and buy a separate wireless device.

Thank you for your time

J



Hall of Fame Community Legend

Re: IOS of the Integrated wireless AP in a Cisco 881W

Ok, just want to tell you the following:

1.  880 can support up to eight (8) VLANs.

2.  The AP for the 880W is an 801  so it only has ONE radio, 802.11 b/g.  It won't do 802.11n and you can't replace the antennas.

3.  There are some details  in "< >" that you need to fill in yourself.

4.  880 routers WAN speed is rated for 25.60 Mbps.  The value, 25.60 Mbps, is expressed in half duplex and without any encryption.  Half the value of 25.60 and you'll get a theoretical speed express in either FULL duplex or with encryption.  Take the value 25.60 and factor this by four (4) and you'll get a theoretical limit expressed in FULL duplex AND with FULL encryption.

5.  Lastly, the configs were checked by Cisco engineer Surendra.  So it's good.   Thanks Surendra!

Hope this helps.

Beginner

Re: IOS of the Integrated wireless AP in a Cisco 881W

Hello leolaohoo,

Want to say a BIG thank you for the config, also thank you Surendra!

All is working, my problem was lack of knowldge and your configuration showed what I was missing.

Also want to point one thing that I find quite strange when I performed erase of NVRAM config and rebooted the device

it asked me if I want to perform initial configuration  to which I said ''no''. Then when I did ''show run'' I could see some

of my previous config which did not get deleted (i.e. all of my VLANS were still there),just thinking that this also

could have being part of my problem when applying  configuration on top of old one and thinking router is blank.

Anyhow that's how you learn,

Thank  you Again.

J

Hall of Fame Community Legend

IOS of the Integrated wireless AP in a Cisco 881W

I did ''show run'' I could see some of my previous config which did not get deleted (i.e. all of my VLANS were still there),just thinking that this also

When you cleared the old configuration with the "wr erase" command, this command doesn't erase the VLAN.DAT file.  So you, optionally, have to issue the commnd "del [/force] [/recursive] flash:vlan.dat".

Glad to see the configuration helped. 

Hall of Fame Community Legend

IOS of the Integrated wireless AP in a Cisco 881W

And now, since the AP can now ping the router, if you need to upgrade the IOS of the AP, you can do alot of things.

Instead of copy the AP IOS into the router, you just leave it on the PC, enable TFTP on the PC and just issue the command "archive download-sw [OPTIONS] tftp:///IOS.tar".

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards