cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
290
Views
0
Helpful
6
Replies
Beginner

Joining CISCO AP 1041N to a WLC 2500 Series

Hello,

I have a problem joining 10 CISCO AP's 1041N to a WLC 2500 Series.

I have the following network architecture,

A Windows Server 2012 R2 (DC, DHCP and DNS Server) connected to CISCO 2960-X Series (This switch is connected to 2 other switches, same model), the 10 AP's and the WLC are connected to the same Switch, as I have 3 NIC's on the Server I am using one for Internet from the Firewall and the three others are teamed together and connected to the Switch.

I tried the following methods:

- I used the Option 43 on the DHCP Server: Not Working

- I added 2 DNS Entries (cisco-capwap-controller.mydomain and cisco-lwapp-controller.mydomain) : not working

- UDP Ports for CAPWAP and LPWAP are enabled on the Windows Firewall : not working

My WLC is set in Master Controller Mode, I can see all the AP's in the DHCP Server with their IP's affected by the server and the WLC as well, and they can ping on each other.

In addition, on the WLC, I have one interface (management) with VLAN ID 0, the Server have (Default VLAN) no ID affected, the Switch have VLAN ID 1 (Default), and I tried to change all of them to the same VLAN ID 1 (Server, Switch, WLC) in that case the server is not able to communicate with all of them and DHCP is not working.

Thank you for your help.

 

Everyone's tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Beginner

Oh, your APs are in

Oh, your APs are in autonomous mode, thats why they cannot join to the WLC. You have to convert them to lightweight! Here is a good guide - http://mrncciew.com/2012/10/20/lightweight-to-autonomous-conversion/

View solution in original post

6 REPLIES 6
Highlighted
Beginner

Try to configure the IP

Try to configure the IP address of the WLC static on the APs: capwap ap controller ip address x.x.x.x

Do you have enaugh AP licenses on the controller ?

Highlighted
Beginner

Thanks for the answer, I have

Thanks for the answer, I have enough licenses for the WLC (10 in total)

I tried the command and I got the following message

ap#capwap ap controller ip address  192.168.1.7
    ^
% Invalid input detected at '^' marker.
ap#
Highlighted
Beginner

Oh, your APs are in

Oh, your APs are in autonomous mode, thats why they cannot join to the WLC. You have to convert them to lightweight! Here is a good guide - http://mrncciew.com/2012/10/20/lightweight-to-autonomous-conversion/

View solution in original post

Highlighted
Beginner

Everything is up and running,

Everything is up and running, I installed the image on the AP's and they are able now to join the controller using Option 43.

Thank you for your help.

Highlighted
Beginner

Maybe this could help,

Maybe this could help,

ap#show config
Using 1410 out of 32768 bytes
!
! Last configuration change at 01:51:07 +0100 Mon Mar 1 1993
! NVRAM config last updated at 16:13:39 +0100 Tue Mar 8 2016
! NVRAM config last updated at 16:13:39 +0100 Tue Mar 8 2016
version 15.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname ap
!
!
logging rate-limit console 9
enable secret 5 $1$y5QZ$DZktb35zppTUCcDq4fCNM1
!
no aaa new-model
clock timezone +0100 1 0
no ip routing
no ip cef
!
!
!
dot11 syslog
!        
crypto pki token default removal timeout 0
!        
!        
username Cisco password 7 096F471A1A0A
!        
!        
bridge irb
!        
!        
!        
interface Dot11Radio0
 no ip address
 no ip route-cache
 shutdown
 antenna gain 0
 station-role root
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
!        
interface GigabitEthernet0
 no ip address
 no ip route-cache
 duplex auto
 speed auto
 no keepalive
 bridge-group 1
 bridge-group 1 spanning-disabled
 no bridge-group 1 source-learning
!        
interface BVI1
 ip address dhcp client-id GigabitEthernet0
 no ip route-cache
!        
ip forward-protocol nd
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
!        
bridge 1 route ip
!        
!        
!        
line con 0
line vty 0 4
 login local
 transport input all
!        
end

My WLC have the IP 192.168.1.7

The AP's have the range starting from 192.168.1.8 to 192.168.1.17

Highlighted
VIP Mentor

Paste the information:

Paste the information:

sh version from AP

sh sysinfo from WLC

Also paste the logs from cisco AP console .

Regards

Dont forget to rate helpful posts

CreatePlease to create content
Content for Community-Ad

August's Community Spotlight Awards