cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

2126
Views
0
Helpful
8
Replies
Highlighted

LAP1252 to AP1252 update and ping problem

Hi the list !

Since i've replaced the Lightened Access Point IOS (12.4) to the Autonomous Access Point IOS (12.4) i'm not able to ping anymore the ethernet interface.

My computer is directly connected to the AP-1252, the link is up and IP properly configured. AP-1252 is 10.0.0.1/16 and computer is 10.0.0.2/16.

ping from computer to AP-1252 => timeout

ping from AP-1252 to computer => % Unrecognized host or address, or protocol not running.

any idea ?

I use the default IOS configuration except ip address settings and ip http server (not secured), note that i'm not able to access the web configuration interface too...

Kind regards,

Amaury

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Rising star

Re: LAP1252 to AP1252 update and ping problem

Hi Amaury,

The ip address should be on the bvi interface and not on gig interface. Try reconfiguring ap as below
!
interface GigabitEthernet0
no ip address 10.0.0.1 255.255.0.0
!
interface bvi1
ip address 10.0.0.1 255.255.0.0

Else with your as is configuration you need to have a dhcp running on the laptop which corresponds to ip subnet 10.0.0.x network the bvi interface would pick an ip address from this dhcp scope. AP would respond to ping only when it have a valid ip on the management interface that is bvi1 interface

Hope that helps

Regards

Najaf


Sent from Cisco Technical Support iPhone App

View solution in original post

8 REPLIES 8
Rising star

LAP1252 to AP1252 update and ping problem

Hi Amaury,

Could you please provide the AP full configuration and "show ip int brief" output?

Regards

Najaf

LAP1252 to AP1252 update and ping problem

Hi Najaf, thanx for answer

ap#show running-config

Current configuration : 1411 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname ap

!

enable secret 5 $1$QcCw$ThfcKVWDZh1GNxFQfhjDy.

!

no aaa new-model

!

dot11 syslog

!

username Cisco password 7 032752180500

!

bridge irb

!

interface Dot11Radio0

no ip address

no ip route-cache

shutdown

antenna gain 0

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio1

no ip address

no ip route-cache

shutdown

antenna gain 0

no dfs band block

channel dfs

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface GigabitEthernet0

ip address 10.0.0.1 255.255.0.0

ip information-reply

no ip route-cache

duplex auto

speed auto

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface BVI1

ip address dhcp client-id GigabitEthernet0

no ip route-cache

!

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

bridge 1 route ip

!

line con 0

line vty 0 4

login local

!

end

ap#show ip interface brief

Interface                  IP-Address      OK? Method Status                Protocol

BVI1                       unassigned      YES DHCP   down                  down

Dot11Radio0                unassigned      YES NVRAM  administratively down down

Dot11Radio1                unassigned      YES NVRAM  administratively down down

GigabitEthernet0           10.0.0.1        YES NVRAM  up                    down

regards,

Amaury

Rising star

Re: LAP1252 to AP1252 update and ping problem

Hi Amaury,

The ip address should be on the bvi interface and not on gig interface. Try reconfiguring ap as below
!
interface GigabitEthernet0
no ip address 10.0.0.1 255.255.0.0
!
interface bvi1
ip address 10.0.0.1 255.255.0.0

Else with your as is configuration you need to have a dhcp running on the laptop which corresponds to ip subnet 10.0.0.x network the bvi interface would pick an ip address from this dhcp scope. AP would respond to ping only when it have a valid ip on the management interface that is bvi1 interface

Hope that helps

Regards

Najaf


Sent from Cisco Technical Support iPhone App

View solution in original post

Re: LAP1252 to AP1252 update and ping problem

Thank you Najaf,

Things going better but i'm still not able to ping my AP or access to its web interface configuration.

Now when i ping the AP i'm getting the following on console with debug ip icmp on :

ap#debug ip icmp

ICMP packet debugging is on

ap#

*Mar  1 01:26:51.447: ICMP: echo reply sent, src 10.0.0.1, dst 10.0.0.2

*Mar  1 01:26:58.343: ICMP: dst (10.0.0.1) port unreachable sent to 10.0.0.2

*Mar  1 01:27:01.087: ICMP: dst (10.0.0.1) port unreachable sent to 10.0.0.2

I get request timeout on computer.

and following while pinging from AP :

ap#ping 10.0.0.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

ap#show ip interface brief

Interface                  IP-Address      OK? Method Status                Protocol

BVI1                       10.0.0.1        YES NVRAM  up                    up

Dot11Radio0                unassigned      YES NVRAM  administratively down down

Dot11Radio1                unassigned      YES NVRAM  administratively down down

GigabitEthernet0           unassigned      YES NVRAM  up                    up

SAMPLE FROM RUNNING CONFIG

!

interface GigabitEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface BVI1

ip address 10.0.0.1 255.255.0.0

no ip route-cache

!

hope this helps,

Regards,

Amaury

Rising star

Re: LAP1252 to AP1252 update and ping problem

Hi Amaury,

Couple of things to check here.

1) Are you using a cross over cable or straight cable to connect between AP and Laptop?

2) Disable any firewall (including windows firewall) or antivirus on the laptop and try pinging between two.

Also get the output of "show arp" from AP

Regards

Najaf

LAP1252 to AP1252 update and ping problem

Hi Najaf,

i'm using a 4 pairs straight cable since mi laptop interface is gigabit and autosense, the link is up

i don't use any firewall (windows FW disabled too) or antivirus

the arp table follows :

ap#show arp

Protocol  Address          Age (min)  Hardware Addr   Type   Interface

Internet  10.0.0.2                0   0011.2587.7a69  ARPA   BVI1

Internet  10.0.0.1                -   001d.4591.41ac  ARPA   BVI1

strange facts...

cheers,

Amaury

Re: LAP1252 to AP1252 update and ping problem

OK !! everything running good !!!

I've changed my 4 pairs straight cable against a 2 pairs straight cable

strange but working fine !

thank you very much for help

kind regards,

Amaury

Re: LAP1252 to AP1252 update and ping problem

Everythng OK, see upper message.

Thank you very much for help, the right way whas the BVI interface as you said..

Regards,

Amaury

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards