cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
476
Views
0
Helpful
11
Replies
Highlighted
Beginner

Wifi 6 - Cisco C9120AXE - Speed does not exceed 300mbit, why?

Hi to all,

 

I purchase C9120AXE-E that i converted to C9120AXE-EWC-E.

I use it with 4 Antennas (AIR-ANT2535SDW-R).

 

I setup it and make test speed with my smartphone (Samsung Galaxy S10+)

I notice Wifi6 logo on my phone after connected to AP.

I make speedtest but i don't exceed 300mbit for a unknow reason.

 

With wifi 6 I should be able to reach the limit of my internet bandwidth, i.e. 980mbit/s...

Are there any particular settings to implement?

 

Show conf result below

C9120AXE-1#show conf
Using 7433 out of 2097152 bytes
!
! Last configuration change at 17:42:16 UTC Sun Aug 30 2020 by ELRTL55
! NVRAM config last updated at 17:42:23 UTC Sun Aug 30 2020 by ELRTL55
!
version 17.3
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
service call-home
no platform punt-keepalive disable-kernel-core
no platform punt-keepalive settings
platform console serial
!
hostname C9120AXE-1
!
boot-start-marker
boot-end-marker
!
aaa new-model
!
aaa attribute list wlan_lobby_access

!
aaa session-id common
no fips authorization-key
!
ip name-server xxx.67.xxx.xxx xxx.67.xxx.xxx
ip domain timeout 1
login on-success log
!
flow exporter default-flow-exporter
 destination local wlc
!
flow monitor default-flow-monitor
 exporter default-flow-exporter
 record wireless avc basic
!
parameter-map type webauth global
 type webauth
 intercept-https-enable
!
access-session mac-move deny
password encryption aes
!
crypto pki trustpoint TP-self-signed-xxxxxxxxxxxxxx
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-xxxxxxxxxxxxxx
 revocation-check none
 rsakeypair TP-self-signed-xxxxxxxxxxxxx
!
crypto pki trustpoint SLA-TrustPoint
 enrollment terminal
 revocation-check crl
!
crypto pki certificate chain TP-self-signed-xxxxxxxxxxxxxxxxx
 certificate self-signed 01 nvram:IOS-Self-Sig#1.cer
crypto pki certificate chain SLA-TrustPoint
 certificate ca 01 nvram:CiscoLicensi#1CA.cer
!
crypto pki certificate pool
 cabundle nvram:ios_core.p7b
!
service-template webauth-global-inactive
 inactivity-timer 3600
service-template DEFAULT_LINKSEC_POLICY_MUST_SECURE
 linksec policy must-secure
service-template DEFAULT_LINKSEC_POLICY_SHOULD_SECURE
 linksec policy should-secure
service-template DEFAULT_CRITICAL_VOICE_TEMPLATE
 voice vlan
service-template DEFAULT_CRITICAL_DATA_TEMPLATE
memory free low-watermark processor 12998
!
license udi pid C9800-AP sn FGL24XXXXXXXX
device classifier
username XXXXXXXXX privilege 15 password 6 XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
!
redundancy
 mode sso
!
interface GigabitEthernet0
 mac-address 0000.5eXX.XXXX
 ip dhcp client client-id GigabitEthernet0
 ip dhcp client broadcast-flag clear
 ip address dhcp
 no negotiation auto
!
ip http server
ip http authentication local
ip http secure-server
ip forward-protocol nd
ip tftp blocksize 8192
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0 250
ip dns server
!
control-plane
!
banner exec ^C
########################################################################################################
#                                                                                                      #
#      Welcome to the Cisco Catalyst 9800-AP Embedded Wireless Controller command line interface.      #
#                                                                                                      #
# Please see command reference guide for the complete list of supported commands for this release:     #
# https://www.cisco.com/c/en/us/td/docs/wireless/embedded_wireless_controller_configuration_guide.html #
#                                                                                                      #
########################################################################################################
^C
!
line con 0
 exec-timeout 0 0
 stopbits 1
line vty 0 4
 length 0
 transport input ssh
line vty 5 15
 transport input ssh
!
call-home
 ! If contact email address in call-home is configured as sch-smart-licensing@cisco.com
 ! the email address configured in Cisco Smart License Portal will be used as contact email address to send SCH notifications.
 contact-email-addr sch-smart-licensing@cisco.com
 profile "CiscoTAC-1"
  active
  destination transport-method http
ntp server 2.ciscome.pool.ntp.org
ntp server 0.ciscome.pool.ntp.org
ntp server 1.ciscome.pool.ntp.org
!
!
!
!
!
wireless aaa policy default-aaa-policy
wireless cts-sxp profile default-sxp-profile
wireless management interface GigabitEthernet0
wireless profile airtime-fairness default-atf-policy 0
wireless profile flex default-flex-profile
 description "default flex profile"
wireless profile image-download default
 description "default image download profile"
wireless profile mesh default-mesh-profile
 description "default mesh profile"
wireless profile policy "EXX X"
 no central association
 no central dhcp
 no central switching
 http-tlv-caching
 session-timeout 86400
 no shutdown
wireless profile policy "EXX XX"
 no central association
 no central dhcp
 no central switching
 http-tlv-caching
 session-timeout 86400
 no shutdown
wireless profile policy default-policy-profile
 no central association
 no central switching
 description "default policy profile"
 dhcp-tlv-caching
 http-tlv-caching
 ipv4 flow monitor default-flow-monitor input
 ipv4 flow monitor default-flow-monitor output
 no shutdown
wireless tag site default-site-tag
 description "default site tag"
 no local-site
wireless tag policy default-policy-tag
 description "default policy-tag"
 wlan "ELR +" policy "EXX X"
 wlan "ELR AIR ++" policy "EXX XX"
wireless tag rf default-rf-tag
 description "default RF tag"
wireless country FR
wlan "ELR +" 1 "EXX X"
 security ft
 security wpa psk set-key ascii 8 XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
 no security wpa akm dot1x
 security wpa akm psk
 security wpa akm sae
 security wpa wpa3
 security pmf optional
 no shutdown
ap dot11 24ghz rf-profile Low_Client_Density_rf_24gh
 coverage data rssi threshold -90
 coverage level 2
 coverage voice rssi threshold -90
 description "pre configured Low Client Density rfprofile for 2.4gh radio"
 high-density rx-sop threshold low
 tx-power v1 threshold -65
 no shutdown
ap dot11 24ghz rf-profile High_Client_Density_rf_24gh
 description "pre configured High Client Density rfprofile for 2.4gh radio"
 high-density rx-sop threshold medium
 rate RATE_11M disable
 rate RATE_12M mandatory
 rate RATE_1M disable
 rate RATE_2M disable
 rate RATE_5_5M disable
 rate RATE_6M disable
 tx-power min 7
 no shutdown
ap dot11 24ghz rf-profile Typical_Client_Density_rf_24gh
 description "pre configured Typical Client Density rfprofile for 2.4gh radio"
 rate RATE_11M disable
 rate RATE_12M mandatory
 rate RATE_1M disable
 rate RATE_2M disable
 rate RATE_5_5M disable
 rate RATE_6M disable
 no shutdown
ap dot11 5ghz rf-profile Low_Client_Density_rf_5gh
 coverage data rssi threshold -90
 coverage level 2
 coverage voice rssi threshold -90
 description "pre configured Low Client Density rfprofile for 5gh radio"
 high-density rx-sop threshold low
 tx-power v1 threshold -60
 no shutdown
ap dot11 5ghz rf-profile High_Client_Density_rf_5gh
 description "pre configured High Client Density rfprofile for 5gh radio"
 high-density rx-sop threshold medium
 rate RATE_6M disable
 rate RATE_9M disable
 tx-power min 7
 tx-power v1 threshold -65
 no shutdown
ap dot11 5ghz rf-profile Typical_Client_Density_rf_5gh
 description "pre configured Typical Density rfprofile for 5gh radio"
 no shutdown
ap tag-source-priority 2 source filter
ap tag-source-priority 3 source ap
ap profile default-ap-profile
 description "default ap profile"
 mgmtuser username XXXXXXXX password 8 XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
trapflags ap crash
trapflags ap noradiocards
trapflags ap register
end

 

Thank you for your help in advance.

11 REPLIES 11
Highlighted
VIP Mentor

Pls provide below output. Also what is your internet link bandwidth ?

c9800#show wireless client mac-address <wifi_client_macaddr> detail | in Rate|Signal

 

HTH

Rasika

 

Highlighted

Hi,

My Internet bandwidth is true gigabyte (around 960mbits/s)

Command result is :

Current Rate : m11 ss1
Supported Rates : 9.0,18.0,36.0,48.0,54.0
Radio Signal Strength Indicator : -27 dBm
Signal to Noise Ratio : 58 dB

Highlighted

Doesn’t matter what your internet speed is because wireless is only half duplex. So don’t think you will achieve line rate. Here is a link so you can review what the rates you are seeing and how that translate to speed.

https://www.rfwireless-world.com/Terminology/802.11ax-MCS-Rates-Table.html
-Scott
*** Please rate helpful posts ***
Highlighted

Hi,

 

I'm sorry but I don't understand your answer.
How should I interpret the link you give me?

 

Best Regards.

Highlighted

Thank you for the output. As per that your client is connecting MCS11 with 1 Spatial Stream. Since Samsung S10+ capable of 80MHz (assuming your AP configured for 80MHz channel width), the maximum data rate it can get is 600Mbps (see below). There is a difference in data rates shown in this table & throughput value when you do a speed test, typically it is due to overhead (control & management overhead of WiFi, half-duplex nature, other overhead in frame headers/preambles). So throughput is much less than data rates. So if you are getting 300Mbps with MCS11, SS1, that is not a bad result.

http://mcsindex.com/ 

ax-mcs11.png

However, the client supports 2SS & hence max data rate it can give is 1.2Gbps (look at MCS 11 and 2SS values against 80MHz). Keep the below page for reference for client capabilities

https://clients.mikealbano.com/ 

 

Then the question is why not client use 2SS with this AP and it could be the various reason, client may decide to go to 1SS to preserve battery, etc. Even if you get 2SS connection, I would think you will get 500-600Mbps in speed test

 

HTH

Rasika

*** Pls rate all useful responses ***

 

Highlighted

Hello,

 

Thank you for this very interesting answer which brings me to other questions.

I managed to get a 600/700mbit throughput by creating an 80Mhz RF profile that I assigned to 5Ghz, I just forced 80Mhz instead of Best.

 

Am I to understand that it is necessary to create specific profiles instead of leaving the option on Global for the 5Ghz and 2.4Ghz bands?

 

According to this table, would it be necessary and possible to force devices to use MCS 11 at 80Mhz in order to have the best throughput in all circumstances?

 

If this is the case, could you advise me in setting up a 5Ghz and 2.4Ghz RF profile please?

You will find below the screens detailing the different possibilities.

 

RF.png

 

Thank you in advance for your help.

 

Highlighted

You have to take a step back and look at your overall install. First, the negotiation between ap and device determines the rate. Variables like utilization, noise and errors for example will cause the ap and device to negotiate at lower rates. You can’t change that or force that. 80mhz in a high density deployment will cause a lot of channel overlap and probably cause more user experience issues. Tweaking an environment requires someone onsite to gather data to see what works and doesn’t work. Many only go up to 40mhz channel width because of neighboring wireless and the density of their deployments. Stability should be preferred over speed and then you will come to a middle ground that works. Data rates and other settings is dependent on your environment which will differ from everyone else’s. Keep in mind that client devices makes the final decision, wireless user half duplex so the more devices on the same channel (not just that ap, but all aps on that channel(s)), will share the medium. This can reduce overall performance dramatically if configured incorrectly.
-Scott
*** Please rate helpful posts ***
Highlighted

@Rasika Nayanajith 

I specify that I use two APs and that they serve about 4 to 6 customers maximum.
They are recent S10+ phones, recent Galaxy Tab S6 tablets and one or two workstations also recent Dell 5490 and Lenovo X380.

 

@Scott Fella 

I don't need a high-density deployment because there are 4 to 6 device connected.

I don't have any other APs in the environment, so I think I can go tease max throughput with a consistent throughput/stability ratio.

Highlighted

Okay... well if it’s that small, then you are fine. You have to also look at neighboring AP’s that don’t belong to you. Just find the best clear channels that you can bond 80mhz channels.
-Scott
*** Please rate helpful posts ***
Highlighted

Hi,

I will need your advice to know exactly what parameters to select in the different screens below to get the best performance for 5Ghz and 2.4Ghz please?

 

RF.png

 

Many Thanks.

Highlighted

Well.. try to disable all data rates below 36mbps, set 36mbps as mandatory and the above rates as supported. Then set your channel width to 80mhz.
-Scott
*** Please rate helpful posts ***
Content for Community-Ad