Showing results for 
Search instead for 
Did you mean: 

Community Helping Community

Recovery of missing 8540/5520 Manufacturing Installed Certificates

Cisco Employee
Hall of Fame Master

Thanks for posting Jeff!



* replied to wrong person


I ran into this today.  I followed your document but I could not login with the username and password created in step 2.  I found another document that had two potential default passwords for the CIMC login.  I used 'password' to login to the CIMC.  It then prompted me to change it after successfully logging in.



I followed the instructions in the PDF and am not able to get the workaround to work.

After completing the steps, rebooting and looking, the 5520s are still missing the MICs.

>show certificate all

--------------- Verification Certificates ---------------

-------------- Identification Certificates --------------


Interesting find. I did this to both 5520s. After looking at what is the standby 5520 it did not have the Hypervisor box checked. I checked it, rebooted, and now have certificates galore on my 5520s.

So even if you do it appears to be done on both, double check as I did and if one of the two in the HA pair is missing the Hypervisor checkbox you won't have certificates listed in the CLI.


Nice find on this. I had the same issue and the fix worked for me as well. Just so other people don't have to hunt it down, the default username/password to access that UI is admin/password

Cisco Employee

thanks guys, i just ran into the same behavior with a customer myself.

not sure if something changed between firmware versions

i'll update the document

Cisco Employee

thanks again guys for the heads up about the default CIMC credentials.  Updated the PDF to reflect.


Hi, and thank you Jeffrey for the document.

Here is a short story how this went on my controller. It did not quite follow Jeffrey's instructions.

First I did not manage to access the controller with https. After the image failed to write to the flash because of signature failure many times with http, tftp and ftp I started to find bugs and found this Discussion.

In my controller's imm the "Host Accessible" was first in state "not-Connected". I anyway enabled the check box and clicked save. Web browser lost the connection. I checked the certificates. Every certificate that was previously in some state was lost. I shut down completely the controller - took the power cord even away, powered the system and started the procedure from the cli again - "imm restart". When I went to IMM again and clicked the save button the not-Connected changed to connected and after "system reset" the certificates was fully functional.


Just wondering if this problem was encountered from an out of box 5520 or during a code upgrade?  Could this also be related to cimc firmware upgrade?  Thanks in advance.

CreatePlease to create content
Content for Community-Ad

August's Community Spotlight Awards