Showing results for 
Search instead for 
Did you mean: 

ERROR!!! Command is disabled






ERROR!!! Command is disabled




LWAPP 1130 is no longer associated with the controller.  Tried command "clear lwapp private-config" and cleared the config.  Now when trying to issue the lwapp commands to set the ip and other configuration, getting "ERROR!!! Command is disabled".


Is this means the static configuration is locked? How to "unlock" it?




You'll need to hold down the "Mode" button during startup for a few seconds (Until the light turns amber) which will get AP out of the controller mode and should allow to set the controller IP and so forth.


That said, if the AP is on the same subnet as the controller, you wouldn't need to set the IP address on the AP.  That's supposed to be one of the benefits of using LWAPP APs. 


Question - why the command may be locked?


Answer - The LAP was previously registered to a WLC, but the username/password was not changed from the default


Solution - Once your LAP successfully registers with the WLC, the static LWAPP configuration commands (discussed in the previous section) are locked out and are no longer accessible. In order to re-enable the commands, you must have set the username and password while the LAP was joined to the previous controller.


When the LAP is registered to a controller, use this controller CLI command to set the AP's username and password:


config ap username <username> password <password> <ALL | AP Name>





Is there no way of forcing a LWAP to it's default 'out of the box' state without requiring the WLC, do you know?




If the LWAPP AP did have the username and password changed while the LAP was joined to the controller then this is available via the AP's console connection.


Here is one method;- Manually Resetting the Access Point to Defaults


You can manually reset your access point to default settings using this EXEC mode CLI command:



Note This command requires the controller configured Enable password to enter the CLI EXEC mode.



clear lwapp private-config




When tried resetting the device (1242AG) by holding down the mode button. It shows:


button pressed for 20 seconds

process_config_recovery: set IP address and config to default

process_config_recovery: image recovery


Upon restarting though I still get the ERROR!!! when attempting to set the lwapp private-config. I also note that a 'show lwapp private-config' indicates that there is still a default gateway set. Again, I cannot 'clear' that due to the ERROR!!!




Put that AP on the same subnet as the controller, and try to join it. You'll be able to reset it to factory configs then. 


Steps of Recovery - Cisco 1240AG AP



•     Cisco IOS WAP image (c1240-k9-w7-mx.124-10.b.JA)

•     Cisco LWAPP recovery image (c1240-rcvk9w8-tar.123-7JX.tar)

•     Cisco LWAPP upgrade tool

•     TFTP Server

•     Local PSU (not POE)


Local PSU is required - process doesn't appear to work with Ethernet connected as boot doesn't stop.


Power up WAP holding MODE button until LED turns Purple (approx 20 secs)


Console should go through boot banners, notice no Ethernet and dump to ap: prompt.


ap: IP_ADDR=a.a.a.a

ap: NETMASK=m.m.m.m


ap: tftp_init


(message confirming tftp available should come back)


Plug in Ethernet on correct vlan to see WLAN controller (i.e. a.a.a.x).


ap: ether_init


Via your friendly local tftp server boot off a full IP image, in this case I extracted from the full .tar file and placed it on tftp server…


ap: boot tftp://x.x.x.x/c1240-k9-w7-mx.124-10.b.JA


AP should boot to ap> prompt and initialise. It may well generate r0.core and r1.core dump files as radio firmware not available.


Once settled:


ap> en               (password in our case was the default) ap# conf t

ap(config)# int bvi1

ap(config-if)# ip address a.a.a.a m.m.m.m

ap(config-if)# line vty 0 4

ap(config-line)# login local

ap(config-line)# exit

ap(config)# username test password aptest

ap(config)# exit


Once this is done the AP should be alive on the network and you should be able to ping and telnet to it and logon. Enable secret will still be the default password.


Now you need to put the logon details in an ip.txt file for the Cisco WLAN recovery tool, we used the recovery tool's own tftp server and didn't enter WLC details.


Click Start and Cisco tool should contact the AP, telnet in, modify the config and download the recovery image and a basic config. Once done it will reboot the AP and it will go into lwapp discovery mode.




To get the radio up you'll actually have to untar the full package (c1240-k9w7-tar.124-10b.JA.tar) as this has the firmware for the wireless:


AP: tar -xtract tftp://x.x.x.x/c1240-k9w7-tar.124-10b.JA.tar flash:/


The workaround we had was specifically to get it back to a 'configurable' state so that we could use the upgrade tool to convert it to a clean LAP. There is no need or capacity to use wireless for this process - it's all done over Ethernet - so we did not load the radio firmware (hence the r0.core and r1.core dumps).


Steps - If the recovery image is still on the AP


First, check the flash:


Directory of flash:/


    2  -rwx         279  May 09 2008 11:52:20 +00:00  env_vars

    4  -rwx        6168  May 09 2008 11:52:20 +00:00  private-multiple-fs

    6  drwx         256  May 09 2008 11:49:05 +00:00  c1240-k9w8-mx.124-3g.JA2

    5  drwx         128  Mar 01 2002 00:03:43 +00:00  c1240-rcvk9w8-mx


15998976 bytes total (10716672 bytes free)


Then delete the LWAPP image:

lap_1242_1#delete /r /f flash:/c1240-k9w8-mx.124-3g.JA2


Thirdly reload the AP:



We will get a clear AP.


"Command is disabled" may be due to the following reason


1.  You are running an old LWAPP (full) image:

2.  You are running an LWAP (full) image;


Here's how you fix it:


1.  Do a "dir" on your AP and you should see two sub-directories.  One is the subdirectory of the full LWAP image and the other has the "rcv" or lite LWAPP image.


2.  Delete the  subdirectory of the full LWAP image (command:  delete /f /r flash:/c1130-k9w8-mx.124-3g.JA2);

3.  Reboot your AP.


This document was generated from the following discussion: ERROR!!! Command is disabled.