Showing results for 
Search instead for 
Did you mean: 

User receives the error message "SNMP operation to Device failed" when trying to modify the access point configuration in the WCS


Core Issue

Any Cisco Access Point (AP) parameter that is set through the Wireless Control System (WCS), returns a Simple Network Management Protocol (SNMP) exception. Controller-based configuration changes are possible through the WCS. However, no AP-related changes can be made. Even with full editing capabilities directly from the controller, users cannot locate bsnAPxxxx.

The user receives the same error if the template contains parameters that are incompatible with other configuration settings on the controller.


This problem is tracked in Cisco bug ID CSCsc86727. Additionally, Cisco bug IDs CSCsd07119 and CSCsc99816 lead to the same error message.

This issue was first found in WCS version 3.2(33), and was first fixed in version 3.2(116.21).

As a workaround for the issue, reboot the controller and walk (read) the AP MIB table once before any other changes are made. Issue the refresh config command on all controllers that have settable APs. After that, the AP parameters can be set.

Another symptom can be that when you apply a template to a controller, it results in  an SNMP operation to device failed message with no additional explanation. This issue is tracked in Cisco bug ID CSCsd07119. As a workaround, determine which template parameters are causing the problem, then use the controller-UI directly on the controller to make the same configuration change. Controller-UI returns a specific error message that indicates the problem. Then, either correct the template being applied, or modify the controller settings so that the template can be applied without errors.

As per Cisco bug ID CSCsc99816 that leads to the same error message, the error occurs when you try to add a dynamic interface with the VLAN ID as 0 (untagged) if the link aggregation (LAG) is enabled on the controller. You can only add one dynamic interface with the VLAN ID as 0. If you try to add more than one dynamic interface with the VLAN ID as untagged, then you receive an error on the controller. Although there is no specific workaround, the desired behavior is to warn in the WCS that this operation is not allowed.

In order to upgrade the WCS, refer to Cisco Wireless Control System Downloads.

Problem Type

Error message


Access point

Wireless Control System

Content for Community-Ad

This widget could not be displayed.