cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
52044
Views
24
Helpful
28
Replies
Highlighted
Beginner

Cisco 2112 Wireless LAN Controller and Apple TV Airplay

Hi All,

I am having a trouble with using iTunes, iPhones and iPads on our Wireless LAN. We have the 2112 WLC and 10 1142N WAPs. If I do a network scan, I can see the Apple TV and see that port 5353 is open, which is Apple's Bonjour service.  However, if I try to play music/video in iTunes, or on an iPhone/iPad, I do not see the Airplay icon.  If I plug into the LAN, the Airplay icon appears immediately. I have created an allow all rule in the ACL but still no dice.  Any help would be greatly appreciated.

Thx

Benmar

This Solution has been added in the following document

https://supportforums.cisco.com/docs/DOC-21728

28 REPLIES 28
Highlighted

Hi Scott,

maybe the mistake is, that our Computers are in 255.255.255.0 and the Multicast Group Adress is

224.0.0.251 ?

Do I have to change everything?

Highlighted

That shouldn't matter multicast address is going to be different from what your clients use... as long as on the siwtch side, you configure ip multicast-routing and ip pim sparse-dense-mode (or sparse or just dense) you should be fine.  Here is another link that might help you from a member.  I have it working at a couple clients now and at my lab.  I just made sure to enable global multicast on the wlc.

https://supportforums.cisco.com/message/3519224#3519224

http://www.thehelpdesk.co.nz/2012/01/how-to-use-apple-tv-with-cisco-877w.html

-Scott
*** Please rate helpful posts ***
Highlighted

Hi there. I have a similar problem.

in controller, general AP Multicast mode i have set to multicast and 239.0.0.0

in controller multicast i have enabled globle multicast mode and igmp snooping

IP of Apple TV 192.168.55.151

IP of iPhone 4S 192.168.55.14

When i use Lan scan on my iPhone i can see the Apple TV but no bonjour services found.

Quick port scan shows ports 49152 and 62078 open on the apple tv.

Airplay is enabled on the Apple TV and the iPhone works on a different wireless network to a different Apple TV.

The wired network is a single nonrouter VLAN in a cisco 3750, but cant see the bonjour even if the apple TV is also wireless.

Any thouhgts? Thanks in advance.

Highlighted

You enable multicast on your switch?

https://supportforums.cisco.com/message/3519224#3519224

-Scott
*** Please rate helpful posts ***
Highlighted

Ah, interesting. The 3750 doesn't do any routing for this VLAN, so i haven't assigned it an IP address.

Didn't think i would have to enable multicast for it.

Is it possible to enable multicast purely on one vlan on a 3750?

The other vlans are doing routing and i don't really want multicast on them.

Thanks

Highlighted

Well you need to enable multicast routing on the layer 3 and then you can define the vlan interface and set that to

ip pim sparse-dense-mode or ip pim sparse-mode but then you will have to specify an RP.

-Scott
*** Please rate helpful posts ***
Highlighted

Thanks. Have been following the cisco document at:-

http://www.cisco.com/en/US/products/hw/switches/ps5023/products_configuration_example09186a008076c6e0.shtml

but in my vlan (55) when i do ip pim dense-mode it errors at pim:(

Also when i do no ip multicast-routing distributed I ge the same invalid input at '^' marker message.

We have ipbase software on our 3750s so looks like we can't enable multicast routing, am i right?

Highlighted

piggy back Scott,

When you issue ip multicast routing it is a global command. So all. Alb would be able to route multicast traffic if you pim enable them.

Steve

Sent from Cisco Technical Support iPhone App

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
Highlighted

Just an update.

The Apple TV is plugged into a linksys switch on vlan 55, the controller is plugged into the 3750's and the access points for the controller are plugged into the 3750's via a POE switch.

Both the Access point POE switch and the controller are plugged into trunk ports with all vlans piped to them as the wireless has multiple SSID's on different VLANs.

the 3750's have an ipbase software image.

Is there any way i can get this to work?

Highlighted

I am just on the same problem, but with WLC4400.

Apple Airplay needs multicast, so I configured following:

network multicast global enable
config network multicast mode unicast
config network multicast igmp snooping enable
config network multicast igmp timeout 60

So I should not need multicast between controller an access points because of "multicast mode unicast".

Up to now I don't know if it works.

Highlighted

Hi, I read something about that.

So I think Apple's bonjour protocol needs multicast. You have to enable it on the controller.

On the controller you can configure multicast support in 2 ways:

1. multicast in unicast mode: multicast packets between controller and access point delivered via unicast. So in your wired infrastucture multicast is not needed. Unfortunately so I think this mode is not supported on WLC 2112. Please double check this for your own.

2. multicast in multicast mode: wired infrastucture must support multicast. Multicast packets (bonjour protocol) between controller and access point are delivered via multicast. So for multicast in multicast mode you have to configure a multicast address, a LWAPP/CAPWAPP Multicast address. That address should be a 239.x.x.x, via this infrastructure bonjour multicast packets (224.0.0.251) are delivered.

One exception, multicast over guest anchor is not supported, i any way. That's my problem in my infrastructure I mentioned in this thread.

Sent from Cisco Technical Support iPad App

Highlighted

Hi thanks for the reply.

I have been speaking to Cisco about this problem and it appears that we either need to enable multicast ont eh 3750's by purchasing a license upgrade and allowing the 3750's to do the routing for the 55 VLAN, or move the controller management interface and the management interfaces of the AP's intot he 55 VLAN as apraently the controller will only multicast on the VLAN that the management interface is on

The 55 VLAN is a segmented public access VLAN so we don't want to put the management interfaces on it or allow routing to the rest of the network on it, so looks like we are stuck!

So it looks like we are going to purchage some very cheap Wireless AP's for the 55 VLAN to get this working.

Shame really.

Highlighted
Frequent Contributor
Frequent Contributor

Hi Scott,

I do not know if you already have this information but I moved to production the Apple TV service using mDNS on version WLC 5508 7.6 and it did not worked because I have an ASA in the middle. So I basically had to open ports: tcp5000, tcp7000 & 7001, tcp7100, udp7010, udp7011, tcp/udp49152-65535 based on the link:  http://community.arubanetworks.com/t5/Unified-Wired-Wireless-Access/apple-macbook-airplay-appletv-firewall-port-findings/td-p/55048 and it worked.

Now I am facing another issue, the mirroring is extremely slow. I mean, when I click in the IPAD the mirroring icon, I am switched immediately to the Apple TV based on the data displayed on the screen connected to this device. But, when I select any icon in the IPAD main screen, it takes from 15-20 seconds to display the information in the Apple TV screen. Have you worked with the QoS part on the WLC for Apple TV? thanks

 

 

Highlighted
Frequent Contributor

I just want to update every one I was having a similar issue on the 5508 and I had the multicast IP setup as 239.255.255.10, once I changed it to 239.0.0.0 Air Play icon re appeared.  I'm just curious now though how come it didn't work with the (AP Multicast Mode) 239.255.255.10 IP?

However under "Controller --> Mobility Management and Multicast Messaging --> Local Group Multicast IP Address" I left 10.255.255.210.

Content for Community-Ad