cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

237
Views
5
Helpful
4
Replies
Beginner

WGB diassociate right after associate

Hi guys.


I'm configuring non root wireless bridge @ cisco 881w as wireless client to non cisco accesspoint (openWRT)
I put following configuration to c881w:

+++++++++++++++++

!
! Last configuration change at 02:14:04 UTC Mon Mar 1 1993 by sam
version 15.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname gate-cottage-ap
!
!
logging rate-limit console 9
!
aaa new-model
!
!
aaa authentication login default local
aaa authorization exec default local
!
!
!
aaa session-id common
no ip cef
!
!
!
!
dot11 syslog
dot11 vlan-name WBR-UPLINK vlan 1
!
dot11 ssid a81m-guest
vlan WBR-UPLINK
authentication open
authentication key-management wpa version 2
mbssid guest-mode
wpa-psk ascii 0 yyyyyyyyyyyyy
!
!
bridge irb
!
!
!
interface Dot11Radio0
no ip address
no ip route-cache
ip tcp adjust-mss 1360
!
encryption vlan WBR-UPLINK mode ciphers aes-ccm
!
ssid a81m-guest
!
antenna gain 0
speed basic-1.0 2.0 5.5 11.0 6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0 m0. m1. m2. m3. m4. m8. m9. m10. m11. m12. m13. m14. m15.
power client 20
packet retries 24 drop-packet
station-role non-root bridge
beacon period 101
beacon dtim-period 1
world-mode dot11d country-code US outdoor
infrastructure-client
!
interface Dot11Radio0.1
encapsulation dot1Q 1 native
no ip route-cache
bridge-group 1
bridge-group 1 spanning-disabled
!
interface GigabitEthernet0
description -= downlink to the router =-
no ip address
no ip route-cache
!
interface GigabitEthernet0.1
encapsulation dot1Q 1 native
no ip route-cache
bridge-group 1
bridge-group 1 spanning-disabled
!
interface BVI1
no ip address
no ip route-cache

!
ip forward-protocol nd
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
!
!
!
bridge 1 route ip
!
!
!
line con 0
logging synchronous
no activation-character
line vty 0 4
transport input all
!
end
+++++++++++++++++

wheneever i shut& no shut dot0 interface I see following:

*Mar 1 02:15:39.815: %LINK-5-CHANGED: Interface Dot11Radio0, changed state to administratively down
*Mar 1 02:15:43.887: %LINK-5-CHANGED: Interface Dot11Radio0, changed state to reset
*Mar 1 02:15:55.195: %DOT11-4-CANT_ASSOC: Interface Dot11Radio0, cannot associate: No Response


at openwrt access point I see following in log:

May 21 14:17:52 ap.sk1.net hostapd: wlan0-11: STA 00:07:7d:ae:3b:90 IEEE 802.11: authenticated
May 21 14:17:52 ap.sk1.net hostapd: wlan0-11: STA 00:07:7d:ae:3b:90 IEEE 802.11: associated (aid 1)
May 21 14:18:01 ap.sk1.net hostapd: wlan0-11: STA 00:07:7d:ae:3b:90 IEEE 802.11: deauthenticated due to local deauth request

where:
00:07:7d:ae:3b:90 is MAC of c881w dot0.1 interface

could somebody explain why and who is iniating deauthention process? is "deauthenticated due to local deauth request" mean opwnwrt access point begins deauth process?

Thank you.

 

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
VIP Mentor

Re: WGB diassociate right after associate

Hi

You have configured it as Non-Root-Bridge which will not work.

 

It has to be Work Group Bridge (WGB), change station role to WGB. use universal  keyword with client device MAC

WGB(config)#int d0

WGB(config-if)#station-role workgroup-bridge universal <client_mac_addr>

 

HTH

Rasika

*** Pls rate all useful responses ***

4 REPLIES 4
VIP Mentor

Re: WGB diassociate right after associate

Hi

You have configured it as Non-Root-Bridge which will not work.

 

It has to be Work Group Bridge (WGB), change station role to WGB. use universal  keyword with client device MAC

WGB(config)#int d0

WGB(config-if)#station-role workgroup-bridge universal <client_mac_addr>

 

HTH

Rasika

*** Pls rate all useful responses ***

Beginner

Re: WGB diassociate right after associate

Thank you very much Rasika!

I have successfully joined foreign access point from 881w router:

+++++++++

*Mar 1 00:00:28.315: %LINK-6-UPDOWN: Interface Dot11Radio0, changed state to up
*Mar 1 00:00:28.319: %DOT11-4-UPLINK_ESTABLISHED: Interface Dot11Radio0, Associated To AP c24a.0040.9f36 [None WPAv2 PSK]
*Mar 1 00:00:29.315: %LINEPROTO-5-UPDOWN: Line protocol on Interface Dot11Radio0, changed state to up
gate-ap(config-subif)#

+++++++++

one outstanding thing I didn't find where foreign access point providing DHCP service assigned IP address to cisco router? bote ap module interface bvi1 configured for DHCP and router module interface vlan1 configured for DHCP as well don't have IP assigned to them. if it possible could you show configuration if you have similar one. maybe I just misunderstanding conception...

 

Thank you.

VIP Mentor

Re: WGB diassociate right after associate

Good to see you able to associated your router as WGB to your AP.

If you connect a normal wireless device (laptop/phone) to that AP, do you get IP addresses for those client ? 

 

I do not have exact hardware to test, in general you will find some WGB related posts on my blog which may helps you to understand concept more

https://mrncciew.com//?s=WGB

 

Rasika

HTH

**** Pls rate all useful responses ***

Beginner

Re: WGB diassociate right after associate

yes I can associate & authenticate to a81m-guest SSID from my windows 7 computer. ipconfig /all output bellow.

+++++++++++++++++

Wireless LAN adapter Wi-Fi:

Connection-specific DNS Suffix . : sе1.туе
Description . . . . . . . . . . . : Qualcomm Atheros AR9485 Wireless Network Adapter
Physical Address. . . . . . . . . : 14-CC-20-2D-E4-49
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IPv4 Address. . . . . . . . . . . : 192.168.173.132(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.254.0
Lease Obtained. . . . . . . . . . : Monday, May 27, 2019 6:07:44 PM
Lease Expires . . . . . . . . . . : Tuesday, May 28, 2019 6:07:44 AM
Default Gateway . . . . . . . . . : 192.168.173.254
DHCP Server . . . . . . . . . . . : 192.168.173.254
DNS Servers . . . . . . . . . . . : 192.168.172.9 192.168.172.27
+++++++++++++++++

I'm assuming cisco 881w get address from pool 192.168.172.0/23

could you take a look at attached configs and point me at possible misconfiguration? (configurations attached)

I took a look at your site https://mrncciew.com/ but unfortunately didn't find any configs related to my scenario.

Could you help me Rasika? I successfully configured a lot of cisco 877w using same scenario but never do it at 880W it looks like 881 completely different  from 877W

 

Thank you in advance.

 

 

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards