Showing results for 
Search instead for 
Did you mean: 

WAP321 - Failed Firmware Upgrade


I recently purchased a third WAP321 access point and have found that I cannot upgrade its firmware (currently to the latest (  I've followed the same procedure from the same browser using the same firmware image (.tar file) as I used successfully for the other two, however this new AP always presents the message: "Firmware upgrade has failed. Please ensure that valid entries were specified in the required fields."  Any ideas as to what's going on?  Here's the system info from the new AP:


PID VID:    WAP321-A-K9 V01
Serial Number:    SER190400VF
Base MAC Address:    58:F3:9C:63:2B:98
Firmware Version:
Firmware MD5 Checksum:    ff3a59299d1b0cdfa46da5997fb00166
Host Name:    wap632b98
System Uptime:    0 days, 0 hours, 35 minutes
System Time:    Thu May 21 2015 16:13:12 PDT
Power Source:    PoE


Interestingly, the firmware checksum for doesn't match what is listed for the firmware image on the downloads page.  (While the other two WAPs that have been upgraded to show the same firmware checksum as is listed on the downloads page for that image.)


Thanks in advance.

2 Replies 2

Brian Ng



Best thing to do right now would be to re-download the firmware and try a different web browser. I have seen where the web browser will keep showing that error and fixed it with a different web browser. Also, try another computer if it still fails. I hope that helps.

Hi Brian,

Thanks for your reply.


I tried the upgrade again from Firefox in a Windows XP virtual machine (original system was Safari on OSX).  The first attempt to upgrade directly failed, though instead of getting the "Firmware upgrade has failed." message, Firefox reported that the server had timed out.  For the second attempt I tried upgrading to the image I downloaded from the website (that appears to have a different checksum).  On this attempt, the firmware upload succeeded and I got to the page with the orange progress bar that I presume is just waiting for the actual upgrade process to complete on the device.   After some time I got a pop-up about the device being unresponsive, and now I can't seem to access it at all...


Any other suggestions, or is this an RMA?

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers