Showing results for 
Search instead for 
Did you mean: 

2504 WLC and Windows 2008 NPS Radius Authentication


Hey has anyone had any luck configuing their wireless controller for radius authentication using Windows 2008 R2 Network Policy Server? Are there certain Cisco attributes that have to be specified in the policy? I can seem to get it to work. I have LDAP working successfully just not radius.


6 Replies 6


Nevermind I found the issue.

Hello. I have some issues while trying to configure NPS with WLC. Could you kind please share screenshot of NPS wifi security policy, please.

I followed this guide, really simple and it worked for me on my 2504 WLC.


I have question about the WLC 2504 and authentication with NPS server ? I successfully configured Policy on NPS server for the WLC management login: I configured an AD user that can login to the WLC with admin right but my question is about how to use the same NPS server to give access the same users member of the another AD group to authenticate on the Wifi with web authentication page configured on one of our Wlan ?

If I put the management login policy first on NPS this user (X) can gain access as WLC admin to manage the controller, but he cannot gain access on the web page login to gain access on the  Wifi, because the first policy that is (management login) match. And if I put the web authentication policy first he can gain access to Wifi because this policy match but he cannot gain access to the WLC management.

The question is how to differentiate both policies on the same NPS server ? if it possible ?


Thanks for your help

Anytime you face issues while authenticating wireless users with NPS, check the event viewer logs on it. It will surely take you in the right direction. In case you have any issues analysing the same, post it here.

Let me know in case you still have any issues.

Jatin Katyal
- Do rate helpful posts -


I upgraded the ios to 15.2(2)JB for Cisco 1260 and the AP worked fine and the users connected and no connections were dropped, the problem after a couple of minutes I couldn’t connect to the AP using the web browser and when I tried to ping the AP address it timeout, tried to reboot and nothing changed I couldn’t log onto it using the web browser and users where now failing to authenticate, I tried  to log on using the console cable and all setting were still in place changed the AP's ip address, soon after that I was able to ping the new configured ip address and I was able to connect using the web interface and users were able to connect, when I updated the AP's ip address on the radius server, I started to have problems I wasn’t able to connect to the AP using the web interface and also couldn’t ping it, reboot AP and still couldn’t log on to it and users failed to connect as they were getting authentication failures.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers