cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3172
Views
5
Helpful
11
Replies

AireOS AP joining an IOS-XE controller

russell.splain
Beginner
Beginner

Hello All,

May I ask if anyone has experience with, or knowledge about the following?

We just obtained our first Catalyst 9800-L controller, and have it setup in a Lab environment.
We have many 'system management features working well on it, such as Licensing, GUI, SSH, Tacacs, AireOS 3504 config converted and applied, and upgraded IOS-XE firmware to 16.12.2s code.

Issue: I can't seem to find documentation around the AP Join process pertaining to an IOS-XE controller.
Issue: We have spare 3702i Lab AP's to work with, which contain AireOS 8.5.151.0 code. These are unable to join an IOS-XE wlc.

Packet-captures taken on the 9800-L show 'Malformed Packet: CAPWAP-CONTROL' when these AP's try to join the 9800-L.

Q: May I ask what documentation exists, or what the process will be for making a (supported) AireOS AP ready to 'join' an IOS-XE controller?

Q: Is there IOS-XE code to download for the AireOS AP?

Q: Must the AP be converted from AireOS to IOS-XE before we can attempt to join the 9800-L?

I need process and documentation, so that my company can move forward with planning eventual transition from AireOS to IOS-XE. Thank you!

1 Accepted Solution

Accepted Solutions

You posted in the correct forum. I was just stating the relationship of the mobility which repeated to the code the AireOS and ap has to be on.
-Scott
*** Please rate helpful posts ***

View solution in original post

11 Replies 11

Scott Fella
Hall of Fame Guru Hall of Fame Guru
Hall of Fame Guru
I have the same setup but with a 5520. I have 8.10 running and I moved the AP’s, different models, from the 5520 to the 9800-L with no issues. Upgrade your 3504, because I believe that is the issue. AireOS requires 8.8 I believe for mobility between AireOS and IOS-XE. That should fix the issue you are seeing.
-Scott
*** Please rate helpful posts ***

Thank you for your replies Scott,

 

If I understand your first reply, if I am able to get the firmware on my Lab 3702i access point upgraded from 8.5.151.0 to 8.8.111.0 or greater, I may be able to have this AirOS-based AP join an IOS-XE based controller. (9800-L).

 

Ok, I'll try that, thanks.

The second post leads me to wonder if I may have posted to the wrong group here, as my issues have nothing to with inter-controller 'mobility' issues.  There is no foreign-anchor architecture, and no WLC-to-WLC interaction of any kind.  Rather, I'm trying to join an (AireOS  8.5.151.0  3702i  AP),  to an (IOS-XE 16.12.2s 9800-L WLC).   If solving that problem requires getting AireOS 8.8.x or greater on the 3702i AP, that sounds like a plan. 

 

Q:  Can I assume that IOS-XE code for an AP only exists for the newer Catalyst 9k AP's?

Q:  Can I assume that it is not possible to convert the OS of an AireOS AP to IOS-XE?

 

I'll search again, but all references I can find don't make it clear what OS type (AireOS or IOS-XE) and OS version number a Wave-1 AP needs to have, in order to directly CAPWAP 'join' a 9800-L wlc.  I'll get 8.8-or-greater-code on a Lab 3504, upgrade the AP firmware, then disconnect the AP from the 3504 and try to join the (8.8.111.x  3702i AP) to the 9800-L. (the 9800-L is brand-new to us, and there's much "figuring-out" to do.   Thanks Scott! -R

You posted in the correct forum. I was just stating the relationship of the mobility which repeated to the code the AireOS and ap has to be on.
-Scott
*** Please rate helpful posts ***

Thank you Scott!  Let you know how it goes...

Sounds good. That worked work me so it should work for you.
-Scott
*** Please rate helpful posts ***

Worked Perfectly Scott! Thanks. Upon joining, the 9800 further upgraded the 3702i to 16.12.2.132 code. You made my day bud! -Russ

Well glad that worked for you!
-Scott
*** Please rate helpful posts ***

TanurajSaha25120
Beginner
Beginner

Hello Russell and Scott,

I am experiencing the same issue. I am trying to join the Access Point (2802i) with the Catalyst 9800 WLC. But AP is not joining with the WLC. From WLC packet capture I have also got the same message.

      'Capwap Control Discovery Rejected- Malformed packet'

 

From Access Point, I' ve got the below message

[*05/25/2020 22:48:42.8387] CAPWAP State: Discovery
[*05/25/2020 22:48:42.8420] Discovery Request sent to 10.10.205.31, discovery type STATIC_CONFIG(1)
[*05/25/2020 22:48:42.8449] Discovery Request sent to 10.10.205.31, discovery type STATIC_CONFIG(1)
[*05/25/2020 22:48:42.8478] Discovery Request sent to 255.255.255.255, discovery type UNKNOWN(0)

 

It keeps rebooting for the several times but can't join the WLC. For your information, The current IOS of WLC is 16.12.1 and Running / Primary boot image of AP is 8.5.140.0. It still does not work.

Please provide me the suggestion to solve this issue.

 

 

 

abdulhmalik
Beginner
Beginner

We have to move AireOS APs from a 5520 to an IOS-XE based 9800-CL. From the docs, it seems like the minimum image required on the AireOS APs is 8.5.164.0 . The issue is that we have 8.5.135.0 on the AIreOS WLC but cannot go past that version due to legacy APs (1602s) . Is there a workaround for this? 

1602 is supported in 8.5.164.0

Release Notes for Cisco Wireless Controllers and Lightweight Access Points, Cisco Wireless Release 8.5.164.216 and 8.5.164.0 - Cisco

Definitely 1602 wont be report to any cisco 9800 WLC's.

If you want to build mobility tunnels between 9800 and AireOS WLC then you need the WLC to run IRCM capable image. This image will work on Air 3504,5508,5520,8510,8540 WLC's. vWLC, 3504, WISM doesnt support IRCM.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers