cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1085
Views
0
Helpful
22
Replies
g.ghir
Beginner

Airplay suddenly not working on WLC2504

Hi All,

I have the following setup:

Cisco WLC2504 with 6 APs

Cisco Small Business Switch

We have airplay working with any apple device that could connect to the network on a particular SSID, all of a sudden this has stopped working.  The only change as far as I know is that we originally had 2 Apple TVs hardwired to the network and now we have introduced 3 more but wirelessly.

I have checked and ensured that the following is still correct (as I believe it should be for this to work):

WLC2504 Multicast Setup.PNG

Happy to provide any more information needed, many thanks in advance.

22 REPLIES 22
Sandeep Choudhary
VIP Mentor

HI Ghir,

Please check:

Under | interfaces |

Do you have an mDNS profile selected?

Also, 239.0.0.0 may be the network address for the network.  Try 239.0.0.11 or something other than 0 for the last octet.

Under the WLAN Advanced tab, do you have mDNS snooping enabled along with the desired profile?

also check this document:

https://supportforums.cisco.com/docs/DOC-21728

https://supportforums.cisco.com/thread/2145539

Regards

Hi Sandeep,

First of all thanks for getting involved, I have checked and found that the mDNS Profile was not selected, changed this now and applied it.  Unfortunately, I am working remotely so will get a user to check it and see if it works. 

On another note, when refering to the 239.0.0.0 or .11 comment, where do you mean?  On the page that I have shown via the screenshot?

Many thanks,

HI Ghir,

Thats is related to Multicast address:

Global Multicast and set a multicast adddress

It is recommended that the address be on the private range (239.0.0.0-239.255.255.255, which does not include 239.0.0.x and 239.128.0.x.). It is also important that the multicast IP address be set to a different value on each WLC. You do not want a WLC that speaks to its access points to reach the APs of another WLC.

I think this is ok in your WLC.

Regards

Adding to Sandeeps reply.

When I do multicast on the WLC, I use the WLC address as the mutlicast address.

if the mgmt is 10.128.230.5 my multicast for that WLC is 239.128.230.5.  that way when I do a show ip mroute on the L3/mrouter I can easily correlate the address to the WLC.

HTH,
Steve

------------------------------------------------------------------------------------------------
Please remember to rate useful posts, and mark questions as answered

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered

Thanks Steve,

I have followed this methodology too .  Good advice.

Hi Sandeep and Steve,

I have checked and no joy!  Scratching my head on what to do next.  Can include a config if that helps

I have added the output from the mDNS page which shows all the Airplay ATVs on my network.  The WLC can see them but not iPad/iPhones on the wireless network can.

Is it possible that something has been added to the network that is blocking Airplay/Bonjour Protocol?

Many thanks,

George

config mdns service query enable AirPrint

config mdns service create AirPrint _ipp._tcp.local. query enable

config mdns service query enable AppleTV

config mdns service create AppleTV _airplay._tcp.local. query enable

config mdns service query enable HP_Photosmart_Printer_1

config mdns service create HP_Photosmart_Printer_1 _universal._sub._ipp._tcp.local. query enable

config mdns service query enable HP_Photosmart_Printer_2

config mdns service create HP_Photosmart_Printer_2 _cups._sub._ipp._tcp.local. query enable

config mdns service query enable Printer

config mdns service create Printer _printer._tcp.local. query enable

config mdns profile service add default-mdns-profile AirPrint

config mdns profile service add default-mdns-profile AppleTV

config mdns profile service add default-mdns-profile HP_Photosmart_Printer_1

config mdns profile service add default-mdns-profile HP_Photosmart_Printer_2

config mdns profile service add default-mdns-profile Printer

config mdns profile create default-mdns-profile

config mdns snooping enable

config mobility group domain WLAN_GH

config network mgmt-via-wireless enable

config network rf-network-name WLAN_GH

config network fast-ssid-change enable

config network telnet enable

config network broadcast enable

config network multicast igmp snooping enable

config network multicast l2mcast disable management

config network multicast l2mcast disable service-port

config network multicast l2mcast disable virtual

config network multicast mld snooping enable

config network multicast global enable

If you upgraded the WLC code, the recent code versions require AirTunes enabled as a service for AirPlay to work.

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***

Hi Scott,

Still at version 7.4, tried to enable Airtunes but no change???

Apple TV and clients on the same subnet?

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***

Would you recommend that i upgrade to 7.5?  Don't understand what has changed?

Yes, all on the same subnet.

Content for Community-Ad