Showing results for 
Search instead for 
Did you mean: 

Airprint on Cisco WLC 5508 - Printers found on WLC but not on iPad



Hello guys.. I'm about to freak out cuz I can't solve theis issue..

I've read several guides about how to configure the WLC for make it "speak" Bonjour/Airprint.

My problem is that I can find those printers I've enabled AirPrint on, on the WLC, but the iPad can't find a single printer.

Here is the what the cfg is like:

- global multicast mode: disabled

- added _ipps._tcp.local to mDNS services as the printers (Kyocera) have turned on both features ipp and ipps

- Query status is enabled for ipp and ipps

- the created mDNS profile has only those two services enabled

- the profile is applied to one SSID/WLAN and to three interfaces (management (static)/two others (dynamic))

- Management is my local LAN, the others are on different locations

- If you click mDNS -> General -> Airprint or mDNS -> Domain Names the printers are discovered

- turning on multicasting doesn't change a thing

Any ideas?

Update:   If a add one of the other services like HP or normal printer, I can find printers.. which are obviously no AirPrint devices..

26 Replies 26

I had the same issue, running WLC 5508 The fix was to un-check the "mDNS Global Snooping". I have a single subnet so no need for a gateway. AirPrint and AirPlay both working now.

Hey Rasika.

I have a similar problem. CT2504 controller Several 3700 access points are connected to it through the switch. They are connected to the MacBook, iPhone,HomePod, Sonos, printer-scanner Canon MG7540 with support for airprint. All devices in one VLAN, in one group and in one SSID.
AirPlay works without problems.
Sonos does not work at all (wrote a thread about Sonos, tried the recommended settings but they did not help).
Airprint works only when the printer and the MacBook or iPhone are connected to the same access point (scenario 1 in the labminutes video). It is connect to different access points and does not work (scenario 2 in the video labminutes). The scan doesn't work either. Most likely you need to add profile type scanner.
As recommended in the video I enable IGMP spoofing, Query Status , LSS Status. In the SSID settings also chose mDNS Spoofing Enable.

But it still doesn't work.


What am I doing wrong?

Hi Ruslan,

What type of switch you connect these devices ? is WLC mgt, AP & everything on same vlan ?


Also I would assume APs are local mode (not flexconnect), is that right ?



Hi Rasika

Thank you for taking the time. I use Cisco SB SG350-28P-K9. I confirm that WLC mgt, AP & everything on same VLAN and APs are local mode. Classic case.


Enable Bridge Multicast Filtering on Cisco SB 300 Series Switches.

IGMP Snooping on the SG350 and SG550


Scott Fella
Hall of Fame Guru Hall of Fame Guru
Hall of Fame Guru

I have ran into the same issue at home and it seems like putting the AP’s in FlexConnect fixes the problem. I don’t know why local mode is not working, it hasn’t worked in a while since v7.x code. 

*** Please rate helpful posts ***

Not help. Even worse. Previously, the printer worked within a single access point. After switching stopped working at all.



I still need help




Romain M-R

Are you solved our problem, I've the same trouble on my WLC 5508?


well, yes it is working right now, but not by enabling Airprint. The HP printer option predefined seems the be only one that is working + I added IPPs. 

I have a Cisco support case open right now working on this very issue with the 8.2.x code on 8500 Series controllers. We can see printers from a mac laptop but only a handful on an iPhone or iPad. It used to work fine on 7.6.x on wism2's.

I will post results when we get it working.

The "fix" Cisco gave us was to create more Service Names (named "AirPrintx" where x is a unique number) under the Apple Services mDNS Profile with a Service String specific to each printer we were trying to get working. That worked, but it is certainly a workaround not a fix, and is not a good solution going forward depending on how many more of these requests pop up for us. I left it at that and closed the case for now.

Maxim Bezzubov


I've got 5508 with WLC 8.0.140 code and stucking in the same issue.

Wlc have enabled mdns services ipp, ipps, hp_photosmart_printer

I've got the  the same issue - no one iOS device cannot discovery shared printers... However I can see those shared printers on WLC. 

Did you resolve this issue? 

BTW airprint feature was worked fine on code 8.0.121.

Привет, Максим.
У тебя AirPrint работает нормально? Пробовал обновляться на 8.5? Кстати, могу помочь с обновлением прошивки WLC.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers