cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1028
Views
0
Helpful
7
Replies

AP 1242AG Bridge

Craig Le-Butt
Beginner
Beginner

Hi

I'm looking for some help.  I've created a wireless bridge using WGB at switch end and Root Bridge at remote end.

This worked fine, till  I tried to add vlans to it.

VLAN 20 data/native and VLAN 30 Voice.

I created the VLANs on both ends and assigned to antenna.  Now I'm not able to get the ping.

On the WGB AP Click on ASSOCIATION - it shows the Infrastructure 1 and the corrent OP and MAC as assaciated on vlan 20.

Click on the Root Bridge end, States Association Processing.

Any help would be great

cheers

Craig

Header 1Header 2
WGBRoot Bridge
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname ap
!
logging rate-limit console 9
enable secret 5 $1$SCCZ$laZulA7.ofnaOGc0Kw9vu1
!
no aaa new-model
!
!
dot11 syslog
dot11 vlan-name voice vlan 30
!
dot11 ssid bridge
   vlan 20
   authentication open mac-address mac_methods 
   infrastructure-ssid optional
!
dot11 ssid vbridge
   vlan 30
   authentication open mac-address mac_methods 
!
!
!
username Cisco password 7 01300F175804
!
!
bridge irb
!
!
interface Dot11Radio0
 no ip address
 no ip route-cache
 !
 encryption key 1 size 128bit 7 D364625F7E6C49E6781D082F12A2 transmit-key
 encryption mode wep mandatory 
 !
 ssid bridge
 !
 ssid vbridge
 !
 station-role workgroup-bridge
 world-mode dot11d country-code GB both
!
interface Dot11Radio0.20
 encapsulation dot1Q 20 native
 no ip route-cache
 bridge-group 1
!
interface Dot11Radio0.30
 encapsulation dot1Q 30
 no ip route-cache
 bridge-group 30
!
interface Dot11Radio1
 no ip address
 no ip route-cache
 shutdown
 !
 encryption key 1 size 128bit 7 D364625F7E6C49E6781D082F12A2 transmit-key
 encryption mode wep mandatory 
 !
 ssid bridge
 !
 ssid vbridge
 !
 no dfs band block
 channel dfs
 station-role root
!
interface Dot11Radio1.20
 encapsulation dot1Q 20 native
 no ip route-cache
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
 bridge-group 1 spanning-disabled
!
interface Dot11Radio1.30
 encapsulation dot1Q 30
 no ip route-cache
 bridge-group 30
 bridge-group 30 subscriber-loop-control
 bridge-group 30 block-unknown-source
 no bridge-group 30 source-learning
 no bridge-group 30 unicast-flooding
 bridge-group 30 spanning-disabled
!
interface FastEthernet0
 no ip address
 no ip route-cache
 duplex auto
 speed auto
!
interface FastEthernet0.20
 encapsulation dot1Q 20 native
 no ip route-cache
 bridge-group 1
!
interface FastEthernet0.30
 encapsulation dot1Q 30
 no ip route-cache
 bridge-group 30
!
interface BVI1
 ip address 10.160.10.14 255.255.255.128
 no ip route-cache
!
ip default-gateway 10.160.10.1
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
bridge 1 route ip
!
!
!
line con 0
line vty 0 4
 login local
!
workgroup-bridge client-vlan 20
end

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname ap

!

logging rate-limit console 9

enable secret 5 $1$jZV1$Su/gfThsuQ/Pdd981xL5D0

!

no aaa new-model

!

!

dot11 syslog

!

dot11 ssid bridge

   vlan 20

   authentication open mac-address mac_methods

   infrastructure-ssid

!

dot11 ssid vbridge

   vlan 30

   authentication open mac-address mac_methods

!

!

!

username Cisco password 7 072C285F4D06

!

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption key 1 size 128bit 7 9B10473716A854D41AAC5A3A7C4C transmit-key

encryption mode wep mandatory

!

ssid bridge

!

ssid vbridge

!

station-role root bridge

world-mode dot11d country-code GB both

infrastructure-client

!

interface Dot11Radio0.20

encapsulation dot1Q 20 native

no ip route-cache

bridge-group 1

bridge-group 1 spanning-disabled

!

interface Dot11Radio0.30

encapsulation dot1Q 30

no ip route-cache

bridge-group 30

bridge-group 30 spanning-disabled

!

interface Dot11Radio1

no ip address

no ip route-cache

shutdown

!

encryption key 1 size 128bit 7 C67646529F78224D5205272E0A71 transmit-key

encryption mode wep mandatory

!

ssid bridge

!

ssid vbridge

!

no dfs band block

channel dfs

station-role root

!

interface Dot11Radio1.20

encapsulation dot1Q 20 native

no ip route-cache

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio1.30

encapsulation dot1Q 30

no ip route-cache

bridge-group 30

bridge-group 30 subscriber-loop-control

bridge-group 30 block-unknown-source

no bridge-group 30 source-learning

no bridge-group 30 unicast-flooding

bridge-group 30 spanning-disabled

!

interface FastEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

!

interface FastEthernet0.20

encapsulation dot1Q 20 native

no ip route-cache

bridge-group 1

bridge-group 1 spanning-disabled

!

interface FastEthernet0.30

encapsulation dot1Q 30

no ip route-cache

bridge-group 30

bridge-group 30 spanning-disabled

!

interface BVI1

ip address 10.160.10.16 255.255.255.128

no ip route-cache

!

ip default-gateway 10.160.10.1

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

bridge 1 route ip

!

!

!

line con 0

line vty 0 4

login local

!

end

2 Accepted Solutions

Accepted Solutions

dmantill
Enthusiast
Enthusiast

WGB does not support multiple vlans, therefore just instead of using WGB us bridge (root and non-root)

View solution in original post

Surendra BG
Cisco Employee
Cisco Employee

WGB supports only native VLAN traffic... no multiple vlan support!!

http://www.cisco.com/en/US/products/hw/wireless/ps441/products_qanda_item09186a0080094644.shtml#q49

Lemme know if this answered ur question!!

Regards

Surendra

Regards
Surendra BG

View solution in original post

7 Replies 7

dmantill
Enthusiast
Enthusiast

WGB does not support multiple vlans, therefore just instead of using WGB us bridge (root and non-root)

Surendra BG
Cisco Employee
Cisco Employee

WGB supports only native VLAN traffic... no multiple vlan support!!

http://www.cisco.com/en/US/products/hw/wireless/ps441/products_qanda_item09186a0080094644.shtml#q49

Lemme know if this answered ur question!!

Regards

Surendra

Regards
Surendra BG

Hi

Thanks for your replys.

I've since tried settingu p as a Root and Non Root Bridge.

Still no look.

The Root keeps syaing Processing Accosciation.

They both can see each other, but wont link.

Any help would be appriciated.


Cheers


Craig

Please posts the logs from both Root and Non Root.. Lets see..

Regards

Surendra

Regards
Surendra BG

Hi Surendra

Since sending the last post, I reset the APs again to factory setting and started again.  This time I did get them to link, but they seem to now freeze, can't ping, telnet, web.  LEDS showing as normal.

The config is attached , it's basic at the minute, trying to get them to say up and pass DHCP.

I'm trying to get VLANs 20 as infrasturture and VLAN 30 for Voice.

Cheers


Craig

Configure "infrastructure-ssid" on both the bridges.. and Reboot the bridges and then issue the command "show log" and forward the same here.. i need "show log" from both the bridges..

Regards

Surendra

Regards
Surendra BG

WHat IOS version are you using on both units?

Some 12.4 used to have issues with bridging...

Try to use the latest ones...

Why dont you try it without 802.11d enabled?

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers