cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
4208
Views
5
Helpful
5
Replies
Highlighted
Beginner

AP not associating with controllers

Hi All,

I've two APs not joining a controller although we have several AP runnings correctly on site. To summarize, the APs gets an IP from the dhcp as well as the wlc ip address, they try to attach to the wlc but they get disconnected after a short time. When I look at the message logs window into the wlc I get this message:

*spamReceiveTask: Oct 12 15:31:55.482: %DTLS-3-HANDSHAKE_FAILURE: openssl_dtls.c:629 Failed to complete DTLS handshake with peer

10.232.??.??

I've enabled a debug capwap error/event on the wlc cli but cannot get anything really relevant (for me);

*spamReceiveTask: Oct 12 15:27:25.385: 00:26:99:b9:c3:10 Discovery Request from 10.232.??.??:57595

*spamReceiveTask: Oct 12 15:27:25.385: 00:26:99:b9:c3:10 Join Priority Processing status = 0, Incoming Ap's Priority 1, MaxLrads = 100, joined Aps =25

*spamReceiveTask: Oct 12 15:27:25.385: 00:26:99:b9:c3:10 Discovery Response sent to 10.232.??.??:57595

*spamReceiveTask: Oct 12 15:27:25.385: 00:26:99:b9:c3:10 Received LWAPP DISCOVERY REQUEST to 00:27:0d:de:ab:cb on port '29'

*spamReceiveTask: Oct 12 15:27:25.385: 00:26:99:b9:c3:10 Discarding discovery request in LWAPP from AP supporting CAPWAP

*spamReceiveTask: Oct 12 15:27:35.382: 00:26:99:b9:c3:10 DTLS connection not found, creating new connection for 10.232.??.?? (57595) 10:107:??:?? (5246)

*spamReceiveTask: Oct 12 15:28:35.346: 00:26:99:b9:c3:10 DTLS connection was closed

*spamReceiveTask: Oct 12 15:28:35.346: 00:26:99:b9:c3:10 DTLS connection closed event receivedserver (10:107:??:??/5246) client (

10.232.??.??/57595)

*spamReceiveTask: Oct 12 15:28:35.347: 00:26:99:b9:c3:10 No entry exists for AP (10.232.??.??/57595)

*spamReceiveTask: Oct 12 15:28:35.347: 00:26:99:b9:c3:10 No entry exists in database

The ap model is AIR-LAP1131AG-E-K9 running version 7.0.98.0

I've also tried to fix speed/duplex but this does not help, even with speed/duplex set to auto. I've also checked the stats on the switch port and I've some input error and crc.

Any help really appreciated!

Thanks, best regards

Théophile

5 REPLIES 5
Highlighted

Theophile,

     Take a look at layer2, especailly the AP ports.  check to see if you are getting duplex mismatches.

HTH,

Steve

----------------------------------------------------------------------------------------------------------

Please remember to rate helpful posts or to mark the question as answered so that it can be found later.

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
Highlighted
Hall of Fame Community Legend

Console into the WAP and see if the WAP can ping the management IP address of the WLC.

Highlighted
Beginner

Hi,

Thanks for your quick answers.

I managed to find a solution, although this does not satisfy me. The AP is able to join the controller only if I put the switch's port to autoneg the speed and duplex AND if I force the AP's port to 100fullduplex...

I'm at this time connected to the AP with ssh,is there any command I can type for you, to help troubleshoot this? i had a look at the AP ethernet stat and I've got some input errors (see attached file).

Another thing I can think of, the ap time is correct but on the controller side, the timezone is set (+2hours), is this a problem or not? I did not find the command line on the ap to set the timezone. Last thing, the ntp servers are the same between the AP and the WLC.

Thanks again

Théophile

Highlighted
Beginner

Hi,

I thought the problem was fixed but no... The ap is not stable at all, it connects and disconnects several time an hour. I've done a telnet to it and I think there is a problem with the ethernet interface on the ap side. I issued the command 'test interface fa0' and I've got this result :

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! Failed - reception problem

1 interfaces: 0 passed, 1 failed, 0 skipped, 0 untestable

We manage to change the AP, I'll keep you informed on the result.

Thanks,

Théophile

Highlighted
Beginner

We recently had a similar issue with an AIR-LAP1131G-E-K9 connecting to a WLC module within a 2800 router after an upgrade to 7.0.230.3 code.  We noticed that the WLC date/time was out by several years after the new code was applied and reset the date and time, then power cycled the AP's which then joined successfully.

HTH

David

----------------------------------------------------------------------------------------------------------

Please remember to rate helpful posts or to mark the question as answered so that it can be found later.