cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
691
Views
0
Helpful
3
Replies
travis.schlafke
Beginner

AP3800 Not getting IP/Joining EWC on Cat9300 17.03.03

I'm running into a weird issue when leveraging the switch DHCP server for a EWC on cat9300 setup.  When using the AP Onboarding VLAN my 3800s don't seem to grab an IP. My EWC is on the same 9300 that my APs are connected to.

 

What's really odd is if I do "show IP DHCP Binding", I see the APs with IPs in active state, when I do "show ARP" I see the APs IP &  with MAC but when I do "show CDP Neighbor Details", the APs dont show an IP nor are they pingable.  

 

If I flip them to another VLAN and build a DHCP pool on the switch they grab an IP just fine and are reachable.  Using an external DHCP server works as well.  I have not tested with an external DHCP server for the AP Onboarding VLAN yet, as I need a server spun up.  With that said, do I suspect it has something to do with the AP Onboarding VLAN and some of the underlying SDA config that gets applied to that VLAN.    Curious if anyone has any additional troubleshooting steps or suggestions to figure this one out.

 

I am running 17.03.03 on the 9300UXM and 17.03.03 for the EWC software.

3 REPLIES 3
patoberli
VIP Advisor

Never tested this, so I'm not even sure my idea would work. Can you attach a normal laptop with wireshark running to the onboarding vlan and check if you get an IP assigned or at least offered?

saravlak
Beginner

Working config:

 

ip dhcp excluded-address 192.168.1.0 192.168.1.74
!
ip dhcp pool internal
network 192.168.1.0 255.255.255.0

 

interface GigabitEthernet0
mac-address 0000.5e00.0101
ip dhcp client client-id GigabitEthernet0
ip dhcp client broadcast-flag clear
ip address 192.168.1.22 255.255.255.0

ip helper-address 192.168.1.22
no negotiation auto

!
ip default-gateway 192.168.1.1

 

ip route 0.0.0.0 0.0.0.0 GigabitEthernet0 250

 

wireless management interface GigabitEthernet0

 

 

 

Sadav Ansari
Beginner

Hi
As I can see your configuration ip helper-address pointed to wrong DHCP server ip.

is your dhcp server server IP address 192.168.1.0 ?
ip helper-address 192.168.1.0

Pls provide your DHCP server ip on ip helper-address instead of network address.

If this answered your question pls click “Accept As Solution”
if you find this response helpful pls rate “Helpful”

Content for Community-Ad