cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
734
Views
5
Helpful
2
Replies
stownsend
Explorer

AP541N-K9 and BonJour/AirPrint

We have Three AP541N-K9 APs and all of them have the 'Set Bonjour Status' set to Enabled.

We cannot use Bounjour Services to Locate Printers from Macs and we cannot connect to our AirPrint Enabled Printers.

In a remote part of the Builting with not much traffic we have some cheap D-Link AP, from there I can connect to the AP and use AirPrint just fine.

Besides enabling the 'Set Bonjour Status' is there anything else I need to configure on the AP to allow it to pass Bonjour Traffic?

Thank you,

   Scott<-

2 REPLIES 2
Scott Fella
Hall of Fame Guru

Well not too familiar with the AP541N, but you can try this I found in a post

There are several settings in the AP541N that could cause multicasts to fail, and since Bonjour is built on multicasts, it would make Bonjour fail as well. Here's how to set your settings to give multicast the best chance of working:

  1. Disable "Client Isolation". This setting intentionally keeps wireless devices from being able to talk to each other.
  2. Set the "DTIM Interval" to 1. The DTIM Interval is how often multicasts are delivered to power-save clients. All Apple wireless clients use power-save mode all the time.
  3. Set the "Fixed Multicast Rate" to the lowest rate (1?). In 802.11, multicasts are not ACKed or retransmitted, so you have to make sure to pick the lowest rate that all your devices can receive reliably.
  4. Leave your Supported Rates, Basic Rates, and MCS Indexes at their factory defaults.
  5. Use "Factory Defaults" or "WFA Defaults" for QoS settings.
  6. Disable "Multicast/Broadcast Rate Limiting".
  7. Temporarily turn off all wireless security as a test. If that makes a difference, then you have to start fiddling with security-related parameters to find the most secure settings that don't break multicast. Read on.
  8. Try disabling "Broadcast Key Refresh" by setting it to zero.
  9. Use WPA2-only, AES-CCMP only. Allowing multiple cipher suites causes multicasts to use a different cipher than unicasts, which sometimes causes interoperability problems.

By the way, unless that Time Capsule is the original "1st Generation" model from 2008, its wireless probably gives that AP541N a run for its money. The 2nd generation model from early 2009 added simultaneous dual-band with 2 spacial streams (up to 300 megabit/second performance) like the AP541N has. The 3rd generation model from late 2009 added 3x3:3 for up to 450 megabit per second performance, besting the AP541N. The 4th generation model that just came out in June 2011 is a more modern 3x3:3; it's still 450 megabits per second, but with optimizations that will give you better actual throughput (less overhead). And because Apple products make so much use of Bonjour, which is multicast, Apple does a better job than most at making sure multicast works reliably on their base stations.

http://superuser.com/questions/328205/how-can-i-get-bonjour-to-work-over-my-wireless-network

Thanks,

Scott

Help out other by using the rating system and marking answered questions as "Answered"

-Scott
*** Please rate helpful posts ***

I cannot say for sure that your Suggestions Fixed my Issue, though I was able to get Bonjour working.

Along with Folloing your Suggestions, it looks like that the AP541N was also connected to a SG300 VLAN Tagged Port.  The VLAN that had the Internal SSID and Data Traffic didn't have Bonjour enabled on it.

Once I enabled Bonjour on the SG300, I could see my Printers and othe Bonjour devices.

Thank you!

Scott<-

Content for Community-Ad