cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
21344
Views
25
Helpful
51
Replies

Apple Device iOS 11 connectivity problem.

iPad , iPhone with iOS 11 cannot associate to AP.

 

when i use my ipad and iphone connect to new SSID with authentication OPEN, my devices are disassociate but i use iphone with iOS 10 can connect to SSID normally.

 

anyone here got this problem with iOS 11 ?

51 REPLIES 51

We do use a DHCP server that is Windows 2008 R2. I will have to test configuring a static IP. What happens is that it will connect, grab a IP and then disconnect after 3 seconds.

that’s strange. if you use dhcp server from Switch or Router it will connect but use dhcp server from windows server it got IP and disconnect within 2-3 seconds.

 

what happens about iOS 11 with DHCP server using window server ??

Hey...I'm having the same problem too...I've been receiving numerous complaints about devices not being able to connect to our enterprise wireless network. I noticed that on my iPhone when it's locked and dormant for a while, when I pick it up it will reconnect back to the wireless network. I don't notice this same behavior with my Samsung phone....I'm not sure what all my user's who are complaining have but this was not the case with IOS 10...

I think we may have found the solution for this.  Apple said that in IOS 11 they stopped supporting SHA-1 certs for TLS connections.  I realized that our captive portal uses that cert!  I generated another local cert using SHA-2 512 and clients where able to join to the WLAN profile and actually stick!   We are still having a issue with different locations but I believe they are all related to our firewall.  

I already create dhcp on switch layer 3 but devices IOS 11 not keep connection with wireless on WLC 

I have same problem on my network too, but i am using router for DHCP server and user will disconnect right after joining the ssid. The only way its connecting is to forget all known SSIDs and then it will connect to open SSID. Does TAC respond to your case?

Did you manage to resolve this issue? We are now having a similar issue, we use a cisco wlc-8510 with a software version of 8.2.161.0, its only with apple devices on ios 11 that are having an issue, we see the devices authenticate and pass on our acs but they dont get an ip and doesnt connect. 

It looks like Apple resolved this issue with IOS 11.2.1 for us.

We also noticed IOS 11.1.2 or 11.2.X resolved issue. For IOS devices on 11.X our wireless architect found a setting in the guest anchor configuration that resolved the issue for our 11.0.X & 11.1.1 IOS devices and Androids that were having the issue too.

". For IOS devices on 11.X our wireless architect found a setting in the guest anchor configuration that resolved the issue for our 11.0.X & 11.1.1 IOS devices and Androids that were having the issue too."

 

..... and what was this setting?

The next code update according to Cisco will include update to address the known bug. In the interim our Network Architect found a setting to resolve issue until new code is released. 

Just updated our ios on an ipad and it is now working, how frustrating. Thanks for the heads up.

M-Square
Beginner

Hi There,

 

We have stumbled across the same issue and are actively working on it.

Have had multiple users in multiple environments and different CISCO models AP's encounter the same issue.  Some sites have a single autonomous setup and another is a main office with WLC.  I have tried WEP, WPA/WPA2, 2.4, 5GHz and same result.  It was confusing at first because my Nexus Android and Lap top connects just fine, it so far seems to be Apple related. My latest test was taking an iPhone running 10x that connected to the WLC WITHOUT issue.  I then upgrade the code today to 11.1 and after that....iPhone does the same as other complaints, connects for a couple seconds then drops.

 

Sounds like others are experiencing the same thing.

Update: 

Summary, iPhones running 11x would associate to CISCO AP's for only a few seconds and then drop.  When connected I could see an IP WAS being handed out but of course it would drop immediately after.  If I statically added an IP to the iPhone it would stay connected...odd

 

I decided to test by using a DIFFERENT DHCP server (we are running 2012R2 at multiple locations)  When I used a different DHCP server the phones will now obtain DHCP and stay connected.

The really odd part is, iPhones connect fine when running older version of iOS.  ALSO, the 2012 DHCP servers are in full production supporting hundreds of other devices WITHOUT issue.  Laptops, desktops, android phones....


Getting closer to the answer but still a mystery...

We were able to resolve issue by disabling 802.11K.  Our clients Adroid, Apple, Windows, Chrome, etc.. connected successfully.  I have a open case with Apple and plan to open one with Cisco to get the two to both analyze device and wireless logs to determine why 11K has to be disabled to allow connection.  We want to keep 11K enabled so hopefully an update to Cisco code or Apple IOS, but more likely will be Cisco code, because problem affected multple smart phone manufacturers.  

Content for Community-Ad