cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2972
Views
5
Helpful
5
Replies
mbecton
Beginner

AppleTV and Airplay not working unless I allow P2P

I use WLC 5508's and 1142 and 2602 AP's.  AppleTV and Airplay will not work unless I enable P2P on the WLAN ...  We allow BYOD and people are using P2P inappropriately.  Does anyone have any suggestions on how I can get AppleTV and Airplay to work but also disable P2P? 

1 ACCEPTED SOLUTION

Accepted Solutions
Scott Fella
Hall of Fame Master

P2P blocking can't be enabled if you want bonjour to work as it is peer to peer. I believe this has been documented in the WLC bonjour guide also. I don't think there is a way to get bonjour to work if you do want P2P blocking enabled.

-Scott

-Scott
*** Please rate helpful posts ***

View solution in original post

5 REPLIES 5
Rasika Nayanajith
VIP Mentor

Does AppleTV & clients are on the same WLAN & managed by single WLC ?

Rasika

Yes.. AppleTV and clients are on the same WLAN and managed by a single WLC.  The only way I've been able to get the clients and AppleTV to work is to select the SSID from the WLC then go to ..advanced.. and change P2P Blocking Action from enabled to forward-UpStream.

Scott Fella
Hall of Fame Master

P2P blocking can't be enabled if you want bonjour to work as it is peer to peer. I believe this has been documented in the WLC bonjour guide also. I don't think there is a way to get bonjour to work if you do want P2P blocking enabled.

-Scott

-Scott
*** Please rate helpful posts ***

View solution in original post

Thank you Scott... argh... I agree, but I was still hoping that someone much more knowledgeable than myself could give me a work around.  Take care.

 

Marty

This document help me a lot:

http://www.cisco.com/c/en/us/support/docs/wireless/aironet-1100-series-access-point/113443-cuwn-apple-bonjour-dg-00.html

 

BR

Content for Community-Ad