cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1523
Views
22
Helpful
28
Replies
Highlighted
Beginner

BR1310 Software Upgrade

Hi every budy,

This is my first message in this forum,I hope you can help me to fix my BR problem.

my Aironet 1310 runing now with c1310-k9w7-tar.12.3(2)JA2 and it's restart by itself(for me no problem with restarting but the problem it's return to ROM so I lose all my configurations !) some time every 2 0r 3 days some time it can be up for a week, I heard that the new software version 12.3(7) is more stable but can't find it !! next is the begining of the Tect-Support file :

ROM: Bootstrap program is C1310 boot loader

BOOTLDR: C1310 Boot Loader (C1310-BOOT-M) Version 12.3(2)JA3, RELEASE SOFTWARE (fc2)

bridge uptime is 1 day, 1 hour, 55 minutes

System returned to ROM by unknown reload cause - reason ptr 0xF, PC 0x416EB4, address 0x0

System image file is "flash:/c1310-k9w7-mx./c1310-k9w7-mx."

I read next cisco help file but no solution the file name is (Cisco − Less Common Types of System Crashes).

My Regards

Saher

28 REPLIES 28
Highlighted

Hi,

Thank you andrew, I using ethernet interface, but tftp which I never try before even I read some instructions about downloading image file from TFTP server to AP but can't do it ! can you give me instructions how can I make it with TFTP or FTP server ?

Regards

s.abubasheer

Highlighted

Hi,

Setup a TFTP server on your PC (you can download a really nice one from here:

http://tftpd32.jounin.net/

Very compact, does DHCP and other stuff as well. Get the TFTP server running and pointed at the directory where the image file is and make sure it's listening on the correct wired ethernet IP address of your PC (if you have multiple network cards).

From your web browser, ENABLE POPUPS!!! Very important or the upgrade won't work! Connect to the bridge, go to the System Software > Software Upgrade section. Click the TFTP Upgrade tab. Enter the IP address of your PC and the file name of the image file including the extention (no need to enter a path if you've set the TFTP server to point to the directory containing the image) and click the Upgrade button. You should see activity on the TFTP server as it uploads the image, it's a 2 step process. After the upgrade the bridge will reboot, when it comes back up check the firmware version, should be all done!

Highlighted

Hi,

thank you andrew, but still can't make it maybe something wrong with tftp server setting !please next my tftp server setting:

current directory :D:\Documents and Settings\Saher\Desktop\tftpd32.280

the image file(c1310-k9w7-tar.123-7.JA1) is in root of tftp directory

Server Interface: 192.168.20.99 subnet mask 255.255.255.0 (it's ip of my pc ethernet card)

BVI1 ip : 192.168.20.100 subnet mask 255.255.255.0

dot11radio interface0 no ip

ethernet interface no ip

am I right? is there a special setting for tftp server ? can you give me an example ? please

also I can use hyper terminal if you give me the right cli to use because I used next command but not worked ! ( archive download-sw /overwrite /reload

tftp:[[//location]/directory]/image-name ).

Thank you in advance

s.abubasheer

Highlighted

Hi Mates,

Please, can use hyper terminal to upgrade my BR1310 firmware can you give me the right cli to use because I used next command but not worked ! ( archive download-sw /overwrite /reload

tftp:[[//location]/directory]/image-name ).

Please read here product review from netprow team http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&type=PR&CommCmd=MB%3Fcmd%3Ddisplay_location%26location%3D.1dd9cdfd

I read there " Any specific caveats you’d like to share about the product?

Some earlier versions of IOS software for the 1300s are affected by bugs, so I would advise to first read the release notes available at cisco.com ,before using those versions of software. One such caveat that I came across was for a client who had two 1300 bridges in a point-to-point configuration, the bridges lose connectivity after a power outage or when the bridges are rebooted. This was a bug in the IOS and causes a bridge parameter called CCA (Clear Channel Assessment) which gets set to zero after a reboot of the bridge. This bug has been fixed in IOS versions starting with 12.3.2JA and above."

this is very similar or exactly my problem but my br1310 is runing with 12.3(2)JA2 !!!

Thank you in advance

s.abubasheer

Highlighted

You could also use telnet to get access to the CLI.

(Windows: Start/Run, type cmd or command, telnet 192.168.20.100)

With the IP setup you posted above and assuming you

didn't rename the image you downloaded from cisco.com,

the following should work:

bridge# archive download-sw tftp://192.168.20.99/c1310-k9w7-tar.123-7.JA1.tar

You only need /overwrite if you want to download the same version again, Instead of /reload you can also

enter "reload" on the CLI after the download finished

successfully.

To test your tftp-setup try saving the config to the

tftp-server:

bridge# copy running-config tftp://192.168.20.99/

(Acknowledge IP and filename by hitting return)

There should be a file "running-config" on the

tftp-server in the same directory as the image now.

If this doesn't work, post the output from "show flash"

Highlighted

Hi,

Thank you kka next what did and I got :

bridge# copy running-config tftp://192.168.20.99/

Address or name of remote host [192.168.20.99]?

Destination filename [bridge-confg]?

.!!

2361 bytes copied in 8.173 secs (289 bytes/sec)

bridge# archive download-sw tftp://192.168.20.99/c1310-k9w7-tar.123-7.JA1.tar

examining image...

Loading c1310-k9w7-tar.123-7.JA1.tar from 192.168.20.99 (via BVI1): !

extracting info (274 bytes)

%Error opening flash:/update/info (No space left on device)

ERROR: Failed to open archive file tftp://192.168.20.99/c1310-k9w7-tar.123-7.JA1

.tar

bridge#

and here output of (show flash)

bridge# show flash

Directory of flash:/

2 -rwx 8567 Mar 1 2002 00:08:00 +00:00 crashinfo_20020301-000740

3 -rwx 402116 Aug 14 2005 22:40:32 +00:00 crashinfo_20050814-224027

4 drwx 256 Jan 1 1970 00:05:26 +00:00 c1310-k9w7-mx.

143 -rwx 70 Aug 11 2005 21:32:21 +00:00 env_vars

144 -rwx 409135 Aug 18 2005 23:10:51 +00:00 crashinfo_20050818-231041

145 -rwx 344927 Mar 1 2002 00:58:46 +00:00 crashinfo_20020301-005841

146 -rwx 426917 Aug 14 2005 14:04:07 +00:00 crashinfo_20050814-140401

147 -rwx 453893 Mar 1 2002 04:20:46 +00:00 crashinfo_20020301-042040

148 -rwx 412780 Mar 1 2002 02:39:32 +00:00 crashinfo_20020301-023925

149 -rwx 5 Mar 1 2002 00:26:56 +00:00 private-config

150 -rwx 402286 Mar 1 2002 08:58:27 +00:00 crashinfo_20020301-085820

151 -rwx 76 Mar 1 2002 00:26:59 +00:00 private-multiple-fs

152 -rwx 360092 Mar 1 2002 23:00:28 +00:00 crashinfo_20020301-225948

153 -rwx 386371 Mar 1 2002 17:56:48 +00:00 crashinfo_20020301-175456

154 -rwx 51626 Mar 1 2002 04:39:27 +00:00 crashinfo_20020301-043750

155 -rwx 1536 Mar 5 2002 04:29:44 +00:00 config.txt.new

156 -rwx 1661 Mar 1 2002 00:26:52 +00:00 config.txt

157 -rwx 0 Mar 5 2002 04:29:48 +00:00 private-multiple-fs.new

7741440 bytes total (0 bytes free)

bridge#

Highlighted

The flash file system is completely full from the

crash dumps. Remove those with the following CLI command:

bridge# delete /force flash:crashinfo*

(Confirm by hitting return)

Then try the update again.

Highlighted

Hi kka,

Thank you so so much, you and all guys try to help me, I pass this problem and update my br1310 successfuly

my best wishes for you and all other peopel with a happy new year .

Regards

s.abubasheer

Highlighted

Hi,

you need to free some space on the flash. I would recommend to delete all the "crashinfo_*" files. They are something like a core dump but not needed for normal operation. Be careful however not to delete the other files so far.

(delete flash:// crashinfo_20020301-225948 should do it. repeat for the other crash files).

In case you want to keep them you could still copy them to your TFTP server before.

Then perform a show flash again and check, wether there is enough space available for the new imae before downloading.

Hope this helps

Martin

Highlighted

Hi Martin,

Thank you for your care and more detailes you mention here. Happy new year.

Best Regards

Sahar

Highlighted

Hi,

After upgrading my br1310 it keeps restarting one or two times daily and does not save any new setting I did before !! can you help me what to do ?

Regards

s.abubasheer

Highlighted

Hi,

next is what I get when I try to save entries in the configuration file.

bridge>enable

bridge#copy running-config startup-config

Destination filename [startup-config]?

Building configuration...

nv_done: unable to open "flash:/config.txt.new"

nv_done: unable to open "flash:/config.txt.new"

nv_done: unable to open "flash:/private-multiple-fs.new"[OK]

bridge#

Highlighted

Most likely your flash file-system is full (again).

If you find a lot of crashinfo_* files in the output from "show flash:"

remove them with "delete /force flash:crashinfo*".

Then you should be able to save your config with "copy run start".

Every "crash" writes a file crashinfo_* after the reboot to flash:

Unless you can open a SR with the TAC they are useless.

You can disable the writing of the crashinfo files with the

following command:

no exception crashinfo

Highlighted

Hi,

Thank you kka, but what cause my br1310 to keep restarting 2 or 3 times a day ?! also with every reset I lose SNTP setting , see next please :

bridge uptime is 2 hours, 2 minutes

System returned to ROM by unknown reload cause - reason ptr 0xF, PC 0x6392F8, ad

dress 0x0

System image file is "flash:/c1310-k9w7-mx.123-7.JA2/c1310-k9w7-mx.123-7.JA2"

bridge uptime is 35 minutes

System returned to ROM by unknown reload cause - reason ptr 0xF, PC 0x6393B0, ad

dress 0x0

System image file is "flash:/c1310-k9w7-mx.123-7.JA2/c1310-k9w7-mx.123-7.JA2"

Regards

Saher

Content for Community-Ad