cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
560
Views
10
Helpful
5
Replies
dal
Participant
Participant

C9800-L-F redundancy setup - IP address confusion

Hi

I'm trying to set up my two C9800-L-F controllers with redundancy using RMI+RP, but I find the use of IP addresses confusing.

 

I have given each box 2 IP addresses so far:

Management:

Controller1:

interface GigabitEthernet0
vrf forwarding Mgmt-intf
ip address 172.30.255.253 255.255.255.0

 

Controller2:

interface GigabitEthernet0
vrf forwarding Mgmt-intf
ip address 172.30.255.254 255.255.255.0

 

WLAN Management interface:

Controller1:

interface Vlan252
ip address 172.30.252.253 255.255.255.0

 

Controller2:

interface Vlan252
ip address 172.30.252.254 255.255.255.0

 

So far so good.

But when entering Administration -> Device -> Redundancy, it asks for another set of IP addresses (RMI IP for Chassis 1/2)

Do I need another set of IP addresses here? Or should the already configured addresses be used?

Does this affect the management IP addresses on interface GigabitEthernet0?
Or does it affect the WLAN Management interface?
Or something else?

Will I still be able to manage the controllers through the 172.30.255.253 and 254 adresses?

 

Thanks

5 REPLIES 5
Scott Fella
Hall of Fame Master

Yes you will... you just need to allocate two ip address for the RP.  Example:

9800-01:

RP-172.30.255.251

Management-172.30.255.253

 

9800-02:

RP-172.30.255.252

Management-172.30.255.254

You will be able to manage the 9800 using the primary controller ip which I'm assuming is 172.30.255.253.  The 172.30.255.254 will go away once you configure SSO.  The RP address will allow for connection, but not through TACACS if you are using that.

-Scott
*** Please rate helpful posts ***
Grendizer
Cisco Employee

As Scott explained, this is similar to AireOS WLCs HA SSO config, you need to allocate 4 IP addresses from the same subnet, two of them to the Wireless Management Interface for each WLC and the other two IPs for the RMI for each WLC, you don’t have to specify any IPs for the RP this is will be generated automatically based on the above IPs.

RMI was introduced in 17.1 code so you can have gateway reachability check, so it is better than just RP HA SSO that was available on prior releases, for now, use the latest code from 17.3 train.

 

dal
Participant
Participant

Thank you both for your answers, and sorry for the late reply.

But you are stating different things here;

@Scott Fellasays I can use addresses from the Management subnet on the SP.

@Grendizersays I can use addresses from the Wireless Management on SVI 252.

 

The confusion continues.

What I want in the end is to manage the cluster from 172.30.255.254 on the SP port.

and I want the accesspoints to communicate with the cluster with 172.30.252.254 in VLAN 252

Does it really matter what addresses I use on the RMI setup? 1.1.1.1 and 1.1.1.2 for example? I have a direct cable between the chassises in the RP port.
Or will the RMI address become the address that the access points communicate with?

 

Thanks

 

Scott Fella
Hall of Fame Master

The RMI you need an IP address on the management. Direct connect, or connected to a switch on the same vlan or on its own vlan id. SP... well you need to follow the guides for the service port. That port is for out of band purposes. Read the SSO guide, look at some blogs and videos on how other setup SSO on the 9800’s. Follow that as a guide, this has nothing to do with the SP (service port), only the RP (redundancy port)
-Scott
*** Please rate helpful posts ***

I gave the RMI setup an address in the Wireless Management subnet, and it show like this in CLI::

interface Vlan252
ip address 172.30.252.251 255.255.255.0 secondary <--- this is the IP I gave in the RMI setup
ip address 172.30.252.254 255.255.255.0

 

But after the reboot, I'm thrown back into the Web GUI Configuration Setup Wizard, where I am forced to set it ip all again.. is there a way to cancel this wizard?

Thanks.

 

EDIT: It turns out that after the reboot, the controller somehow deleted the bootvar configuration, and in that process, booted up the oldest image in bootflash.

So I'm upgrading it again and starts over.

Content for Community-Ad