cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
27765
Views
20
Helpful
33
Replies

Cisco 9120AXI-EWC-E deployment not working

as00001111
Level 1
Level 1

Hi all!

I bought a C9210AXI-EWC for a small location.

I configured an ip address on Gigabit Ethernet 0.

 

My switchport is configured as a trunk and native vlan.

I'm not able to ping the EWC.

cdp neighbor detail on the switch is showing the ap, but no management ip address.

AP is flashing green and red in turn.

 

Can you tell me what's happening?

 

Thank you!

33 Replies 33

This should be marked at the solution.

I rebooted, configured GigabitEthernet0 IP, default gateway, http server and set wireless management interface GigabitEthernet 0

Now it's working!

 

Thanks

You saved my day also.

 

Bobby Roberts
Level 1
Level 1

Hi - So I just spent a day trying to figure out how I got to this same spot.   Guess what?  You forgot to wr mem after your first setup, and rebooted.  Things get weird if you don't wr mem after the setup of the 'ip http server' - 'ip http secure-server'.    Go ahead and 

wireless ewc-ap factory-reset

 after this is done, it will reload and you just need to start the simple setup over again here - https://www.cisco.com/c/en/us/support/docs/wireless/embedded-wireless-controller-on-catalyst-access-points/215303-embedded-wireless-controller-conversion.html

jose palacios
Level 1
Level 1

For anyone that tried every step in this guide and still cannot ping and log in to the EWC, here is what worked for me:

Scenario:

- No DHCP server, EWC uses static IP address. 

- Tried to access GUI with AP directly connected to a PC with Power Injector, and with AP and PC connected to a switch using the recommended port configurations of this thread.

1- log in to the AP shell from EWC command line with this command: 

wireless ewc-ap ap shell username <username>

Where <username> is the one configured in the AP profile (if you don't have an AP profile configured, default user and password is "Cisco").

 

2- When logged in, execute command "show capwap ip config", in my case it showed the message "System not ready, waiting for uplink iP address". The IP address expected to be obtained is for the virtual AP that runs along with the EWC. 

show capwap ip config.png

3- Assign the IP address, Gateway and DNS for the virtual AP with the command: "capwap ap ip <ip_address> <subnet_mask> <gateway> <DNS Server 1> <DNS Server 2>". 

Note: It has to be a different IP address than the one assigned to the EWC. You cannot use the same.

If you do it this way, you will see in the console log this messages, and the management IP address for the EWC will become active and you will be able to log in via HTTP/HTTPS.

Logs AP join.png

If you use DHCP in your management VLAN for APs and EWC you probably won't suffer this issue.

Hope this helps.

Review Cisco Networking for a $25 gift card