cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1619
Views
0
Helpful
3
Replies
paul amaral
Participant

cisco VZ LTE on Cisco ISR 1111 connects then disconnects

Hoping someone can help me as I having no luck getting a VZ 4G LTE connection to stay up.  Im using a Cisco 1111 -4PLTEEA

Cisco IOS XE Software, Version 16.09.03

Cisco IOS Software [Fuji], ISR Software (ARMV8EB_LINUX_IOSD-UNIVERSALK9_IAS-M), Version 16.9.3, RELEASE SOFTWARE (fc2)

 

This is the configuration I’m using,

 

access-list 1 permit any

dialer-list 1 protocol ip permit

 

controller Cellular 0/2/0

lte sim data-profile 3 attach-profile 3 slot 0

 

interface Cellular0/2/0

ip address negotiated ! only seems to support hdlc

load-interval 30

dialer in-band

dialer watch-group 1

dialer-group 1

ipv6 enable

pulse-time 1

dialer idle-timeout 0

 

ip route 0.0.0.0 0.0.0.0 Cellular0/2/0 254

 

 

The config above gets me an ip from VZ and bounds it to the cell0/2/0 interface as the dialer works and brings up the connection etc.

I can pass traffic in and out but the connection goes down at about 4:30/5 min of being up. This happens while I have constant traffic to and from the Cisco 1111.

I can’t understand why cell0/2/0 goes down. I have tried different IOS’ but that didn’t seem to help.

 

Ce0/2/0 - dialer type = DIALER CWAN

Idle timer (120 secs), Fast idle timer (20 secs)

Wait for carrier (30 secs), Re-enable (15 secs)

Dialer state is enabling

Time until interface enabled 14 secs

 

Dial String      Successes   Failures    Last DNIS   Last status

lte                      1          0    00:04:50       successful   Default

BCM-Plymouth-ISR1K-GW#

000082: *Jul 23 11:42:30.561 summer_: %LINK-3-UPDOWN: Interface Cellular0/2/0, changed state to down

000083: *Jul 23 11:42:31.561 summer_: %LINEPROTO-5-UPDOWN: Line protocol on Interface Cellular0/2/0, changed state to down

 

 

 

I seem to be attached to the correct profile

 

 

Profile 3, Packet Session Status = ACTIVE

        Cellular0/2/0:

        Data Packets Transmitted = 5 ,  Received = 80

        Data Transmitted = 296 bytes, Received = 4640 bytes

        IP address = 166.252.xx.xx

        Primary DNS address = 198.224.188.236

        Secondary DNS address = 198.224.189.236

        Primary DNS address = 198.224.188.236

        Secondary DNS address = 198.224.189.236

 

 

Also verify the APN type, it looks like I’m using the correct APN which is profile 3

 

PDP Type = IPv4v6

Access Point Name (APN) = ne01.VZWSTATIC

Authentication = None

 

 

Signal on this LTE device is perfect

 

LTE Bandwidth = 20 MHz

Current RSSI = -60 dBm

Current RSRP = -96 dBm

Current RSRQ = -13 dB

Current SNR = 0.7  dB

Physical Cell Id = 304

Number of nearby cells =

 

SIM/LTE gets ip encaps on cellular is HDLC

sh cellular 0/2/0 connection

Profile 1, Packet Session Status = INACTIVE

Profile 2, Packet Session Status = INACTIVE

Profile 3, Packet Session Status = ACTIVE

        Cellular0/2/0:

        Data Packets Transmitted = 5 ,  Received = 80

        Data Transmitted = 296 bytes, Received = 4640 bytes

        IP address = 166.252.xx.xx

        Primary DNS address = 198.224.188.236

        Secondary DNS address = 198.224.189.236

        Primary DNS address = 198.224.188.236

        Secondary DNS address = 198.224.189.236

Profile 4, Packet Session Status = INACTIVE

Profile 5, Packet Session Status = INACTIVE

Profile 6, Packet Session Status = INACTIVE

Profile 7, Packet Session Status = INACTIVE

Profile 8, Packet Session Status = INACTIVE

Profile 9, Packet Session Status = INACTIVE

Profile 10, Packet Session Status = INACTIVE

Profile 11, Packet Session Status = INACTIVE

Profile 12, Packet Session Status = INACTIVE

Profile 13, Packet Session Status = INACTIVE

Profile 14, Packet Session Status = INACTIVE

 

sh cellular 0/2/0 radio

Radio power mode = online

LTE Rx Channel Number =  2050

LTE Tx Channel Number =  20050

LTE Band =  4

LTE Bandwidth = 20 MHz

Current RSSI = -60 dBm

Current RSRP = -96 dBm

Current RSRQ = -13 dB

Current SNR = 0.7  dB

Physical Cell Id = 304

Number of nearby cells = 3

Idx      PCI (Physical Cell Id)

--------------------------------

1              304

2              303

3              54

Radio Access Technology(RAT) Preference = AUTO

Radio Access Technology(RAT) Selected = LTE

 

 

Im at a real loss as to why the LTE connection bounces especially when it initially connects with no issues and has a strong RSSI.

There isn’t many examples of LTE configuration for an ISR 1100 and the commands/config are different than the 1800 series.

One thing I notice is that somehow if I reboot the router with the sim in 0/2/1 instead of 0/2/0 the want ip is pingable but not bound to any cell interface.

Not sure at this point if my config is not right or it’s a VZ issue!!?

 

 

If anyone has experience with this and can help me I would appreciate it.

 

Thanks, Paul

 

Below are the debugs

 

 

000236: *Jul 23 10:32:16.872 summer_: cellwan_api_pkt_session_notify: instance id:0 profile:2 status:0

000237: *Jul 23 10:32:16.873 summer_: cellwan_api_pkt_session_notify: Cellular0/2/0 instance_id 0 profile_id 2

000238: *Jul 23 10:32:16.873 summer_: cellwan_api_pkt_session_notify: active_status[0],ipfamily[4]

000239: *Jul 23 10:32:16.873 summer_: cellwan_api_pkt_session_notify: active_status[0],ipfamily[4]ipv4status[0],ipv6status[0]

000240: *Jul 23 10:32:16.873 summer_: irrelevant error code 36

000241: *Jul 23 10:32:16.873 summer_: cellular_update_profile_id_for_latest_call_setup: Cellular0/2/0 profile_id 3, active_status 0, pdn 0

000242: *Jul 23 10:32:16.873 summer_: cellwan_api_pkt_session_notify: session status 0

000243: *Jul 23 10:32:16.873 summer_: Cellular0/2/0 DirectIP: Remove negotiated IP interface address

000244: *Jul 23 10:32:16.876 summer_: Cellular0/2/0 DirectIP: Remove negotiated IP interface address

000245: *Jul 23 10:32:16.876 summer_: Cellular0/2/0 DirectIP: Primary DNS address 198.224.188.236 removed

000246: *Jul 23 10:32:16.876 summer_: Cellular0/2/0 DirectIP: Secondary DNS address 198.224.189.236 removed

000247: *Jul 23 10:32:16.842 summer_: %IOSXE-3-PLATFORM: R0/0: ngiolite: SrvStatusCallback:ipfamily 4 bearer ID 255

000248: *Jul 23 10:32:16.842 summer_: %IOSXE-3-PLATFORM: R0/0: ngiolite: Session State: Disconnected

000249: *Jul 23 10:32:16.842 summer_: %IOSXE-3-PLATFORM: R0/0: ngiolite: Session disconnected

000250: *Jul 23 10:32:16.842 summer_: %IOSXE-3-PLATFORM: R0/0: ngiolite: EndReason 1008

000251: *Jul 23 10:32:16.842 summer_: %IOSXE-3-PLATFORM: R0/0: ngiolite: verboseEndReasonType 6

000252: *Jul 23 10:32:16.842 summer_: %IOSXE-3-PLATFORM: R0/0: ngiolite: verboseEndReason 36

000253: *Jul 23 10:32:18.877 summer_: %LINK-3-UPDOWN: Interface Cellular0/2/0, changed state to down

000254: *Jul 23 10:32:18.877 summer_: cwan_hwif_state_change: Cellular0/2/0

000255: *Jul 23 10:32:19.878 summer_: %LINEPROTO-5-UPDOWN: Line protocol on Interface Cellular0/2/0, changed state to down

000256: *Jul 23 10:32:33.877 summer_: Ce0/2/0 DDR: re-enable timeout

000257: *Jul 23 10:32:33.877 summer_: Ce0/2/0 DDR: Dialer Watch: resetting call in progress

000258: *Jul 23 10:32:33.877 summer_: Ce0/2/0 DDR: Dialer Watch: Check reconnection needed

000259: *Jul 23 10:32:46.644 summer_: Ce0/2/0 DDR: place call

000260: *Jul 23 10:32:46.644 summer_: Ce0/2/0 DDR: Dialing cause ip (s=50.208.173.33, d=50.204.173.105)

000261: *Jul 23 10:32:46.644 summer_: Ce0/2/0 DDR: Attempting to dial lte

000262: *Jul 23 10:32:46.644 summer_: back off timer is not running for PDN 0

000263: *Jul 23 10:32:46.644 summer_: api_manage_packet_session: Cellular0/2/0 profile 255 activate 1

000264: *Jul 23 10:32:46.655 summer_: %IOSXE-3-PLATFORM: R0/0: ngiolite: Starting IPv4 session for PDN 0 with profile ID 3

000265: *Jul 23 10:32:47.122 summer_: Cellular0/2/0: pdn:0 status:3

000266: *Jul 23 10:32:47.114 summer_: %IOSXE-3-PLATFORM: R0/0: ngiolite: IPv4 data session established for PDN 0, session ID 63504912, ipfamily (7)

000267: *Jul 23 10:32:47.114 summer_: %IOSXE-3-PLATFORM: R0/0: ngiolite: IPv4 session established, session Id : 63504912

000268: *Jul 23 10:32:47.114 summer_: %IOSXE-3-PLATFORM: R0/0: ngiolite: Starting IPv6 session for PDN 0 with profile ID 3

000269: *Jul 23 10:32:47.178 summer_: %IOSXE-3-PLATFORM: R0/0: ngiolite: SrvStatusCallback:ipfamily 4 bearer ID 5

000270: *Jul 23 10:32:47.178 summer_: %IOSXE-3-PLATFORM: R0/0: ngiolite: Session State: Connected

000271: *Jul 23 10:32:47.434 summer_: %IOSXE-3-PLATFORM: R0/0: ngiolite: Sesstion start failed : 1014

000272: *Jul 23 10:32:49.123 summer_: cellwan_api_pkt_session_notify: instance id:0 profile:2 status:1

000273: *Jul 23 10:32:49.123 summer_: cellwan_api_pkt_session_notify: Cellular0/2/0 instance_id 0 profile_id 2

000274: *Jul 23 10:32:49.123 summer_: cellwan_api_pkt_session_notify: active_status[1],ipfamily[4]

000275: *Jul 23 10:32:49.123 summer_: cellwan_api_pkt_session_notify: active_status[1],ipfamily[4]ipv4status[1],ipv6status[0]

000276: *Jul 23 10:32:49.124 summer_: cellular_update_profile_id_for_latest_call_setup: Cellular0/2/0 profile_id 3, active_status 1, pdn 0

000277: *Jul 23 10:32:49.124 summer_: cellular_update_profile_id_for_latest_call_setup: pending_idb: Cellular0/2/0

000278: *Jul 23 10:32:49.124 summer_: subuint 0 profile_id 3

000279: *Jul 23 10:32:49.125 summer_: cellwan_api_pkt_session_notify: session status 1

000280: *Jul 23 10:32:49.237 summer_: irrelevant error code 210

000281: *Jul 23 10:32:49.293 summer_:  cellwan_api_handle_profile_ip_addr_get_resp pdn 0 valid 1 ipv4 length 4 ipv6 prefix length 0, session active 1, profile:2

000282: *Jul 23 10:32:49.293 summer_:   IPV4 Address = /0

  ipv4 state[1],ipv6 state[0]

000283: *Jul 23 10:32:49.293 summer_: cellwan_api_handle_profile_ip_addr_get_resp:IPV4 session state[1] IPV6 session state[0]

000284: *Jul 23 10:32:49.293 summer_: cellwan_api_handle_profile_ip_addr_get_resp: Lineaction Cellular0/2/0

000285: *Jul 23 10:32:49.293 summer_: cellular_dip_ip_address_negotiated: Found profile ID 3 for Cellular0/2/0

000286: *Jul 23 10:32:49.293 summer_: Cellular0/2/0 DirectIP: Install negotiated IP interface address 166.252.xx.xx

000287: *Jul 23 10:32:49.304 summer_: cellular_line_protocol_up: Cellular0/2/0

000288: *Jul 23 10:32:49.305 summer_: Reset back off for PDN 0

000289: *Jul 23 10:32:49.305 summer_: Ce0/2/0 DDR: dialer protocol up

000290: *Jul 23 10:32:49.306 summer_: Cellular0/2/0 DirectIP: Primary DNS address 198.224.188.236 added

000291: *Jul 23 10:32:49.307 summer_: Cellular0/2/0 DirectIP: Secondary DNS 198.224.189.236 added

000292: *Jul 23 10:32:47.434 summer_: %IOSXE-3-PLATFORM: R0/0: ngiolite: Fail to start IPv6 session

000293: *Jul 23 10:32:49.226 summer_: %IOSXE-3-PLATFORM: R0/0: ngiolite: ipfamilty at pdn_info (pdn=0) is 7

000294: *Jul 23 10:32:49.226 summer_: %IOSXE-3-PLATFORM: R0/0: ngiolite: Session info from unpack: MTU: 1428, profile type: 0,profile index: 3, Tech: 0

000295: *Jul 23 10:32:49.226 summer_: %IOSXE-3-PLATFORM: R0/0: ngiolite: ipv4 166.252.xx.xx

000296: *Jul 23 10:32:49.226 summer_: %IOSXE-3-PLATFORM: R0/0: ngiolite: gateway addr 166.252.101.154

000297: *Jul 23 10:32:49.226 summer_: %IOSXE-3-PLATFORM: R0/0: ngiolite: subnet mask 255.255.255.252

000298: *Jul 23 10:32:49.226 summer_: %IOSXE-3-PLATFORM: R0/0: ngiolite: profile name

000299: *Jul 23 10:32:49.226 summer_: %IOSXE-3-PLATFORM: R0/0: ngiolite: pdp type 0(PDP-IPv4)

000300: *Jul 23 10:32:49.226 summer_: %IOSXE-3-PLATFORM: R0/0: ngiolite: apn name ne01.VZWSTATIC

000301: *Jul 23 10:32:49.226 summer_: %IOSXE-3-PLATFORM: R0/0: ngiolite: IP Address = 166.252.xx.xx

000302: *Jul 23 10:32:51.300 summer_: %LINK-3-UPDOWN: Interface Cellular0/2/0, changed state to up

000303: *Jul 23 10:32:51.300 summer_: Ce0/2/0 DDR: Dialer statechange to up

000304: *Jul 23 10:32:51.300 summer_: cwan_hwif_state_change: Cellular0/2/0

000305: *Jul 23 10:32:51.300 summer_: cellular_dip_ip_address_negotiated: Found profile ID 3 for Cellular0/2/0

000306: *Jul 23 10:32:51.300 summer_: Cellular0/2/0 DirectIP: Install negotiated IP interface address 166.252.xx.xx

000307: *Jul 23 10:32:51.307 summer_: cellular_line_protocol_up: Cellular0/2/0

000308: *Jul 23 10:32:51.308 summer_: Ce0/2/0 DDR: dialer protocol up

000309: *Jul 23 10:32:52.302 summer_: %LINEPROTO-5-UPDOWN: Line protocol on Interface Cellular0/2/0, changed state to up

1 ACCEPTED SOLUTION

Accepted Solutions
paul amaral
Participant

The following is the solution to this problem. VZ will not pass any non VZ sourced IPs through their cellular network and when it see this violation it will take down the cell interface/connection. Why don't they just drop the traffic Im not sure. 

 

The problem for me start when I pre-configured the router to go on site initially using the VZ connection. I had a ip SLA testing what was to be the primary connection, which was not yet active. When the test probes from the SLA were going out it would source from the non VZ and it would take the only available connection to the internet which was the VZ connection. When this non VZ ip was going over the VZ network, VZ would drop the connection.

 

 

The solution is just to not pass traffic sourced from non VZ ips through VZ or you can NAT non VZ ips from the cellular interface which is what I ended up doing and it fixed my issue. 

 

interface Cellular0/2/0
ip flow monitor NETFLOW_MONITOR input
ip flow monitor NETFLOW_MONITOR output
ip address negotiated
ip nat outside
ip access-group internet_to_us_acl in
ip access-group VZ_ip_ACL_only out
zone-member security WAN
dialer in-band
dialer idle-timeout 0
dialer watch-group 1
pulse-time 1
service-policy output voice_policy

 

thanks Paul

 

View solution in original post

3 REPLIES 3
eduardo.ramirez
Beginner

Hi Paul inhave exactly same issue with IR1101 SERIES  did you figure out ?  I was told about Verizon ip source violation so I have tried with NAT workaround but still bouncing only way to get it back up is resetting LTE module

 

Thanks 

just updated with solution, good luck. 

 

Paul 

paul amaral
Participant

The following is the solution to this problem. VZ will not pass any non VZ sourced IPs through their cellular network and when it see this violation it will take down the cell interface/connection. Why don't they just drop the traffic Im not sure. 

 

The problem for me start when I pre-configured the router to go on site initially using the VZ connection. I had a ip SLA testing what was to be the primary connection, which was not yet active. When the test probes from the SLA were going out it would source from the non VZ and it would take the only available connection to the internet which was the VZ connection. When this non VZ ip was going over the VZ network, VZ would drop the connection.

 

 

The solution is just to not pass traffic sourced from non VZ ips through VZ or you can NAT non VZ ips from the cellular interface which is what I ended up doing and it fixed my issue. 

 

interface Cellular0/2/0
ip flow monitor NETFLOW_MONITOR input
ip flow monitor NETFLOW_MONITOR output
ip address negotiated
ip nat outside
ip access-group internet_to_us_acl in
ip access-group VZ_ip_ACL_only out
zone-member security WAN
dialer in-band
dialer idle-timeout 0
dialer watch-group 1
pulse-time 1
service-policy output voice_policy

 

thanks Paul

 

View solution in original post

Content for Community-Ad