cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
7674
Views
0
Helpful
13
Replies
fredrikcarlen
Beginner

iOS issue with Airprint and Bonjour gateway

Hello,

I have a weird issue. The wireless iOS clients (iPad/iPhone) running at 6.1.3 and 7.0 cant discover the wired Airprint-printers. The OSX clients connected to the same SSID/dynamic interface can see all the Airprint-printers and connect to them without issues.

WLC 5508 is on 7.4.110

Client SSID(iOS and OSX) on VLAN 10

Printers on VLAN 20 and that VLAN have a dynamic interface in the WLC

mDNS enabled globally and the default mdns profile for the client SSID and wired printer VLAN.

Multicast and IGMP snooping disabled.

Do I face an issue with how the (Swedish) iOS-devices interprete the proxied service announcements from the WLC?

TIA /Fredrik

13 REPLIES 13
Saurav Lodh
Rising star

To debug,

Debug Commands

To display events related to mDNS

WLC>debug mdns message { enable | disable }

To display mDNS details of the events

WLC>debug mdns detail { enable | disable }

To display errors related to mDNS processing

WLC>debug mdns error { enable | disable }

To enable all debugs

WLC>debug mdns all { enable | disable }

All the debugs can be filtered based on the MAC address.

Check the printer services :

http://www.cisco.com/en/US/docs/wireless/technology/bonjour/Printer_Services.html

I had the same issue with CM4540, and the X585 printers from HP, it only happened after updating firmware on the them, to fix just uncheck the option of verifying Certificate for IPP/IPPS pull printing, you will find it under networking, other settings.

 

Not applicable

I'm having the same issue.  ios devices can airplay to the apple tvs.  But the ios devices do not see any airprinters.

I'm running vWLC 7.5...

fredrikcarlen
Beginner

We actually found the problem today and solved it. The issue was that the wireless clients and printers got a xyz.local as a DNS suffix from DHCP and this apparently does not work well with iOS devices. Have a look at
http://support.apple.com/kb/TS3389

After changing the suffix given to the clients it worked immidiately. Sometimes it is not a WLC caveat ;-)

Sent from Cisco Technical Support Android App

our internal dns is xyz.k12.mn.us

Any other ideas? :-)

I'm thinking its a bug in the code since air play is working great.

Not applicable

I can airprint from a Mac Mini, but not from a ios device.  Tried it on ios 6 and 7, and I get no printers showing up.

Jukka Kosonen
Beginner

I discovered that only printers that advertise _universal._sub._ipp._tcp.local -service string show up in iPad's printers list. So check that you have HP Photosmart Printer 1 -service snooped.

Br. Jukka

Adding both the hp photosmart 1 and 2 to the profile did make some of the airpint capable printers show up!  But after a while the printers disappeared again....  Turning mdns snooping off then back on makes the printers show up again for awhile untill they fall off again.

We have HP Laserjet 500 color M551 which is does excatly the same thing. It will remain in controllers mdns database for 4500 seconds and then disappears. Our HP LaserJet 400 M401dn is working fine and also a Lexmark CS410dn.

Br. Jukka

Interesting!  I'm experiencing the same thing with hp m551n and 602n also!  Same behavior!  Updated the firmware on both models, and get the same thing.

Not applicable

I just watched very closely and I'm seeing after 4600 (78 mins) the printers disappear.

Please open a TAC case.

Jukka Kosonen
Beginner

We moved the laserjet 500 printer to a new vlan and now it stays in the mdns database. We also disabled all other protocols than 9100, LPD, bonjour, airprint and mdns.

Content for Community-Ad