cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
22010
Views
70
Helpful
63
Replies
dovla091
Beginner

Issues connecting Android 10 to Cisco ME

Hi, I had one problem which I found bypass solution, but I would like to share with someone, as I don't want that someone is wasting time as I did troubleshooting the issue.

My case was that I have 15 APs AP1832i set to Cisco ME, so 1 acts as a call it a  "controller", while others are getting the instruction. I have set latest version of firmware for APs - 8.10.105.0

Now I have Nokia 7.1 running Android 10 December 2019 patch, and what I found out that after upgrading Android to version 10 and patching Cisco AP1832i from 8.5 to 8.10, android phone cannot connect anymore.

After 1 hour of troubleshooting I found a bypass. By enabling WPA3 (along with WPA2), android 10 started to connect again.

My guess is either Google completely ditched support for WPA2 (for some reason), in favor for WPA3 or there is some mismatch between Cisco 8.10.105.0 for ME and Google Android 10. By enabling WPA3, phone can successfully connect to our network.

 

I hope I helped someone, and saved him/her some time in dealing with tedious troubleshooting

 

Best regards

63 REPLIES 63

For greater stability, I would also disable load balancing. That actually kicks the clients out of the network if they don't roam when the WLC thinks they should roam. It has its positives and negatives sides, I generally leave it disabled in a mixed environment with many clients that I don't manage.


Hi

We had this issue with Android v12 release few days ago.

I confimred we fixed this issue by disabling the FAST TRANSITION feature in our WLANs properties (located in SECURITY/LAYER2 tabs).

We are using Wireless Cisco Catalyst 9800 and AP1840.

 

Thanks for this discussion thread. 

Svetlin Simeonov
Beginner

Hi,

I have similar Problem with Nokia and Huawei.

Wireless deployment is with 9800-40 and 9115ax - Amsterdam - 17.3.x.

My success workarround is by disabling FT future in WLAN and Device Analyrics.

Disable FT

Configuration > Tags&Profiles > WLAN > Open Problem SSID > Security - Fast Transition (Disabled)

Disable Device Analytics

Configuration > Tags&Profiles > WLAN > Open Problem SSID > Advanced > Advertise Support (Unchecked).

Good Luck !

 

MartinButlers
Beginner

In my case enabling WPA3 on 1832i/1852e with ME 8.10.142.0 wasn't enough. I did also change in WLAN Settings/Advanced 802.11r to "enabled" from default "adaptive". Thanks for this post. It saved me lots of time.

Content for Community-Ad