Showing results for 
Search instead for 
Did you mean: 

Prime NCS not starting


Since this morning, we cannot access to our NCS login page despite no change has been made on the vm. I tried to restart it but this did not correct the problem. here are the two commands I tried:

ncs reload

ncs start

You will find below the output in the attached files. Moreover, the system asks me to have a look on a launchout.log file  but I cannot find it in the NCS directories (crash, defaultRepo, lost+found, tftp....).

Do you know some commands I can type to help me fix that issue?

Many thanks to all of you!



Accepted Solutions
Jacob Snyder

Glad it helped!

Sent from Cisco Technical Support Android App

View solution in original post



You can find the launchout.log file in the root shell. Are you handy with Linux?

Anyway do the following:

1. SSH login to the Prime with admin account

2. At the admin prompt, Type root and enter password

3. Enter cd /opt/CSCOlumos

4. Type ls and enter to list files. You will see the directory called logs

5. Type cd logs and enter

6. ls again to list files. You should see launchout.log.

7. To view the file. type cat launchout.log

8. Type exit and enter to leave the shell


First of all thanks for your kind help.

I tried the commands and results are in the attached files.No more luck, there is nothing special I can get out of this launchout.log, so i tried to read the file named Startup.log but could not find it!

I also tried the commands found here because my first thought was a database error:


If you have the Prime ISO image, I would suggest that you reinstall. I can't recall where the startup file is, but if you list the files under each directory you should find it. The problem is that the NMS is not starting not the database.

Instead of NCS reload. Do a NCS stop and start.

Sent from Cisco Technical Support Android App

Hi Osita N, this could be an option but I do not want to loose all of the NCS old database and history. Is there a procedure to follow to backup/reinstall/import the old DB  and history without doing a clean installation?

Many thanks for your help and time helping me




You can schedule an auto backup. I would suggest that you set up a remote repository instead of using the default repository on the appliance. Since the NMS won't start, you can use the CLI to create a backup store. Please note that Backup is done through FTP.

To create a Backup store:

Enter  server configuration mode:
#config t
Enter the following commands to configure a symbolic link to the remote FTP server:
#repository repositoryName
#url ftp://serverIP or Host
#user name password plain userPassword
• repositoryName is the repository alias as entered in the Name field when creating the new backup
repository in the Prime Infrastructure user interface (for example: RemoteFTP).
• serverIP or Host is the IP address or hostname of the remote FTP server ((for example:
• name is the name of a user with write privileges to the repository on the FTP server.
• userPassword is the corresponding password for that user.

To restore from Backup:#

#restore filename repository repositoryName application NCS


• filename is the name of the backup file (for example: backup-20120801.tar.gpg).

• repositoryName is the repository alias as entered in the Name field when creating the new backup

repository in the Prime Infrastructure user interface (for example: RemoteFTP).

Please consult the Prime Infrastructure User Guide for more information and assistance.

Hello Osita,

Thanks for your help. I tried to do a backup but it did not work because the free space available is not enough on the virtual machine. Another point, as the FTP server service is not running, I do not know how to copy the backup file to a remote destination.

Hi Theophile,

The only other way you can apply the update patch is through CLI and that still requires an FTP transfer. Irrespective of the fact that FTP server isn't running, I would suggest that you still try and set up a remote FTP server and see if Prime can reach it. If you get the config right as I described earlier and enter show repository (username), the contents (if any) of the remote FTP server folder will show.

In the IT world things sometime work by trying the unusual, so ignore that the FTP server is not running. At worst case, you get an error message that you can't configure the remote repository because of the FTP server not running.

You know what, I'm the happiest guy in the world right now ! I found the solution to my problem; i was facing the bug number CSCud39395. Many thanks to Jake Snyder for his helpful post posted here:
You can also read the Bug details here:

I hope this will help people facing the same issue.

Have a nice day



I know it sounds simple, but have you tried rebooting the VM with the "reload" command?  NCS was notoriously fill of bugs where processing threads like XMP or decap would stick and not shut down, even though "ncs status" might show that everything was shut down.  The easiest way to reset all processing threads is to simply reboot--everything gets shut down completely, then only the things NCS needs this time get started back up. 

Those bugs have been fixed by the current Prime Infrastructure with Update 1 release.

Clarifying the upgrade path to Prime Infrastructure Update 1

Hello, I already tried the reboot without success

I will test the patch but how can I copy it on the NCS vm? as the NCS cannot start, the FTP server is stopped and I do not find any command to start it manually!


Hello theophile,

I totally agree with Rollin Kibbe on this point regaridng the NCS reboot issue, as I have also faced the same issue in my lab scenario.


Logging into Cisco Prime Infrastructure for the First Time

Once the Cisco Prime Infrastructure server has been installed and configured, it is now ready to be accessed from the web. The server URL would be https://server_hostname or In Cisco Prime Infrastructure 1.3, login using the following credential for the very first time:

Username: root


After the server has been configured, it is advisable to log in with a non-root user to keep the root user for system level configurations as and when needed. More updated information can be found at Prime Infrastructure 1.3 Quick Start Guide at Logging into the Prime Infrastructure User Interface

Jacob Snyder

Glad it helped!

Sent from Cisco Technical Support Android App

Recognize Your Peers
Content for Community-Ad