cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2464
Views
0
Helpful
9
Replies

Slow connection with Cisco Aironet 1040

justinregan
Beginner
Beginner

I have been racking my brain for a while and cannot figure out why I am not getting 144Mbps out of my Aironet 1040. I was reading a previous thread (

https://supportforums.cisco.com/thread/2141961) and set it up exactly like it said. I have set the encryption to Cipher AES CCMP and set the SSID to open authentication. I also set the SSID's key management to enable WPA (WPAv2).

I was reading that WMM has to be set. I have 3 options: Disabled, Legacy, and dot11d. If i chose dot11d I have to put in a coutry code. Problem is there are no options in the country code pull down. I cannot even manually type it in.

Another problem is that cell phones cannot connect. It keeps saying authentication fails in the log.

Any reason why I am having such slow speeds?

9 Replies 9

Stephen Rodriguez
Cisco Employee
Cisco Employee

WMM is enabled by default, or at least it should be.

What type of client are you using?  Check the specs of the WNIC, and see how many spatial streams that it supports.

HTH,
Steve

------------------------------------------------------------------------------------------------
Please remember to rate useful posts, and mark questions as answered

HTH,
Steve

------------------------------------------------------------------------------------------------
Please remember to rate useful posts, and mark questions as answered

Thank you for the fast reply! I have an Intel Wifi Link 1000 bgn card in my laptop (Lenovo T410)

http://download.intel.com/support/wireless/wlan/1000/sb/intelrwifilink1000productbrief1.pdf

If i send a copy of my config file can you look at it quick?

sure, pull a show run and feel free to attach to this thread.

HTH,
Steve

------------------------------------------------------------------------------------------------
Please remember to rate useful posts, and mark questions as answered

HTH,
Steve

------------------------------------------------------------------------------------------------
Please remember to rate useful posts, and mark questions as answered

attached is my config.

try this:

int dot 0

no payload-encapsulation dot1h

HTH,
Steve

------------------------------------------------------------------------------------------------
Please remember to rate useful posts, and mark questions as answered

HTH,
Steve

------------------------------------------------------------------------------------------------
Please remember to rate useful posts, and mark questions as answered

That seems to have done it. Right now I am about 50 feet away from the AP and I am getting 58Mpbs. When I get closer to it it increases and does go up to 144.

Now my last question is why cant my wireless device connect? I haven a iPhone 5. I took a screen shot of my wireless interface. Do I have something selected wrong?

have you tried after removing the dot1h command?  Some devices can't connect when that is enabled.

HTH,
Steve

------------------------------------------------------------------------------------------------
Please remember to rate useful posts, and mark questions as answered

HTH,
Steve

------------------------------------------------------------------------------------------------
Please remember to rate useful posts, and mark questions as answered

It tries to connect. I dont get the error anymore since we made that change, it just doesnt pull an address. It just keeps spinning.

I've had that happen with my phone as well.  A few pops in and out of the WiFi and it usually picks up.

HTH,
Steve

------------------------------------------------------------------------------------------------
Please remember to rate useful posts, and mark questions as answered

HTH,
Steve

------------------------------------------------------------------------------------------------
Please remember to rate useful posts, and mark questions as answered
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers