cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

[Solved] Catalyst 9120: EWC-AP in Recovery Mode...

wma
Beginner
Beginner

Hi everyone,

 

I've just purchased a 9120 to replace a 1262 in autonomous mode - my home wireless network. The 9120 purchased was a bit old (2019), but brand new (no, it wasn't from an official store since it is intended for home use )

 

I've upgraded it from version 8.9.150 to latest version, using CLI, with command:

 

ap-type ewc-ap tftp://192.168.x.x/ap1g7 tftp://192.168.x.x/C9800-AP-iosxe-wlc.bin

 

No luck ... After reload, I had that common infamous error: EWC-AP in Recovery Mode...

What happens: it seems that there is garbage where image is stored (I have someting like 96% used when I perform a 'sh flash'). Downgrading down to version 16.12.2s is a bit better, since it takes less space. but still out ok luck ... Sftp gives no improvement. When downloading again the image, it stops at c.a. 80 - 90%.

 

Solution: given by Cisco themselves here: Repair C9120/C9115 Access Points from U-boot 

 

You have to download that special image from Cisco (you don't find it when browsing on software page, since post is hidden). Follow steps carefully, and you're okay! While image was applied, I saw that image deleted a bunch of space - which was obviously the issue.

 

What I did beside that procedure:

  • All was configured using console port (pretty obvious ...), using Tftpd64 - sftp was useless.
  • Port where the AP is connected is set on 'mode access', and not on trunk.
  • Just after I applied the special image upgrade (more a downgrade, since it is 8.9.130), I immediately upgraded to 16.12.2s, by unzipping first C9800-AP-universalk9.16.12.02s.zip to tftp folder, and I used these commands to upgrade:

 

capwapap ip 192.168.x.x 255.255.255.0 192.168.0.x
ap-type mobility-express tftp://192.168.x.x/ap1g7 tftp://192.168.x.x/C9800-AP-iosxe-wlc.bin

 

 I had then access through web, without any issue. I used then web to upgrade to 17.7.1 - actual version. The only remaining issue to solve is why WLC does not get an IP through DHCP, but that should be a piece of cake to solve (setting IP address through CLI solved the issue).

0 REPLIES 0
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: