cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3602
Views
0
Helpful
7
Replies

Unable to connect Cisco 7921 wifi IP Phone to cisco Access point

Vikrant Ambhore
Beginner
Beginner

Hi All,

I'm trying to connect Cisco 7921 wi-fi IP Phone to cisco Access point  but cisco IP phone getting authantication fail error can anyone suggest me, What could be the problem there,

I have attached Snap of configuration of my IP phone & below is my configuration of Wi-fi Access Point

Current configuration : 2353 bytes

!

version 12.3

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname CiscoAPWiFI

!

enable secret 5 XXXXXXXXXXXXXXXXXXXX

!

ip subnet-zero

!

!

no aaa new-model

dot11 vlan-name Data vlan 1

dot11 vlan-name VOIP vlan 100

!

dot11 ssid Coinop

   vlan 1

   max-associations 25

   authentication open

   authentication key-management wpa

   guest-mode

   mbssid guest-mode dtim-period 1

   wpa-psk ascii 7 XXXXXXXXXXXXXXXXXXXX

!

dot11 ssid VoiceCoinop

   vlan 100

   authentication open

   authentication key-management wpa

   wpa-psk ascii 7 XXXXXXXXXXXXXXXXXXXX

!

dot11 network-map

!

!

username XXXXXXXXXXXXXXXXXXXX password 7 XXXXXXXXXXXXXXXXXXXX

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption mode ciphers tkip

!

encryption vlan 1 mode ciphers tkip

!

encryption vlan 100 mode ciphers tkip

!

ssid Coinop

!

ssid VoiceCoinop

!

mbssid

speed basic-1.0 2.0 5.5 6.0 9.0 11.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role root access-point

!

interface Dot11Radio0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio0.100

encapsulation dot1Q 100

no ip route-cache

bridge-group 100

bridge-group 100 subscriber-loop-control

bridge-group 100 block-unknown-source

no bridge-group 100 source-learning

no bridge-group 100 unicast-flooding

bridge-group 100 spanning-disabled

!

interface FastEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

hold-queue 160 in

!

interface FastEthernet0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface FastEthernet0.100

encapsulation dot1Q 100

no ip route-cache

bridge-group 100

no bridge-group 100 source-learning

bridge-group 100 spanning-disabled

!

interface BVI1

ip address 192.168.8.254 255.255.255.0

no ip route-cache

!

ip default-gateway 192.168.8.1

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

!

!

control-plane

!

bridge 1 route ip

!

!

!

1 ACCEPTED SOLUTION

Accepted Solutions

migilles
Cisco Employee
Cisco Employee

Which country are you located in?

Did you add the world mode (802.11d) command I mentioned?

Can also try using an open SSID without encryption.

Sent from Cisco Technical Support iPhone App

View solution in original post

7 REPLIES 7

First, did you enter the correct PSK?

I always like to dumb things down. If you added an open wide network and connect the phone and it works. Then start to apply your security and see where it breaks. Also, can you connect a laptop to the Voice SSID ?

"Satisfaction does not come from knowing the solution, it comes from knowing why." - Rosalind Franklin
___________________________________________________________

migilles
Cisco Employee
Cisco Employee

The config looks good, but if you have a -W model then you need to add the 802.11d / country code info.

The supported country codes are in the 7921G Deployment Guide.

http://www.cisco.com/en/US/docs/voice_ip_comm/cuipph/7921g/6_0/english/deployment/guide/7921dply.pdf

Assume you have set the phone to AKM security mode, which is the mode you would need to set in order to use WPA/WPA2-PSK.

Sent from Cisco Technical Support iPhone App

Hi Migilles,

Thanks for your reply


I got your document, looks like is good Thanks for post it, Now I am trying to configure Phone through GUI as per attached document (Page no. 71), but phone is not showing in device manager i think some drivers required for it,

I searched on net but didn't get anything for supported driver, can you help me for that, as per my think my issue will fix if I get driver 7 will try through GUI

migilles
Cisco Employee
Cisco Employee

Do you have a -W model phone?

Can see that under the battery on the phone.

If so you need to enable 802.11d / world-mode.

Below is an example that you would need added to each radio interface in the AP config.

Below is for US, replace with your country code as necessary.

world-mode dot11d country US both

For configuring the 7921 phone via USB, you do need the USB driver which is on Cisco.com. The driver is for Windows XP and 2000.

For Windows 7, you can set the device for XP compatibility mode.

Sent from Cisco Technical Support iPhone App

Hello migilles,

I installed USB driver & Now I am able to access Phone by GUI, but still having same issue, I think  something wrong on Access point, Please help me,

migilles
Cisco Employee
Cisco Employee

Which country are you located in?

Did you add the world mode (802.11d) command I mentioned?

Can also try using an open SSID without encryption.

Sent from Cisco Technical Support iPhone App

Thanks it's fix

I played with it more time, & got success

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: