Showing results for 
Search instead for 
Did you mean: 

vWLC DHCP not working across VLANs

Level 1
Level 1

Having an issue with clients connecting to various WLANs getting DHCP leases from a scope configured for another VLAN. It was previously working for a couple days, but seemed to all of a sudden change to incorrect DHCP leases. Ex. a client connecting to WLAN99, configured for interface vlan99 on the vWLC, will get a dhcp lease of 10.2.0.X. The same event occurs when connecting to WLAN11, configured for interface vlan11 on the vWLC, getting 10.2.0.X. Intermittently, the WLAN99 wlan will get assigned 10.99.0.X. 

This setup was previously working correctly, but seemingly started occurring randomly yesterday afternoon.

I have tried removing IP helper config off the routers sub-if for each vlan, doing so prevents any DHCP leases. 



Segregate traffic based on vlan. Router has ACL's to filter traffic based on vlan, (vlan 2,10,11 have access to other vlans, 99 is traffic leaving the network)



VLANS- 10-10.0.0.X - internal wired

              11-10.0.1.X - internal wireless

                2-10.2.0.x - management

              99-10.99.0.x - guest internet

vWLC- Port 1-VLAN 2

            Port 2-Trunk

Switch(2960x)-All vlans configured on switch. vWLC connected to vSwitch with Trunk and VLAN 2, two vnics. Port channel to vSwitch configured as trunk, all vlans permitted. 

AP x3 (2702i)-connected to switch on gig2/0/1-3, switchport trunk, native vlan 2.

Router x2 - gig0/0/2.2 , 0/0/2.10 , 0/0/2.11 and 0/0/2.99 -  all have "ip helper address (dhcpserver1 on vlan10), ip helper address (dhcpserver2 on vlan10)".  Router is configured for HSRP (if that matters.)

DHCP server (, Scopes configured for 10.0.0.X, 10.0.1.X, 10.2.0.X and 10.99.0.X.


Not sure where the issue in the config is, hopefully its a simple oversight on config. Im new to the wlc setup.


1 Accepted Solution

Accepted Solutions

@KMX762 wrote:
Not sure, what you're referring to.

You need to configure the WLAN-VLAN mappings on the FlexConnect Group. Not the interface setting on the WLANs.

View solution in original post

6 Replies 6

Level 1
Level 1
Also, AP's are configured for FlexConnect. Perhaps this would be best kept in local mode?

Vengatesa Prasath
Cisco Employee
Cisco Employee

Vwlc support only FLexconnect local switching..


So globally mapping interface on wlan will not take effect, you should check in wlan-vlan on flex groups or flex Tab on individual Ap's config. 


Hope this helps.. 






Not sure, what you're referring to.

@KMX762 wrote:
Not sure, what you're referring to.

You need to configure the WLAN-VLAN mappings on the FlexConnect Group. Not the interface setting on the WLANs.

Yeah that was it, was missing the WLAN-VLAN mappings in flex connect groups. 

For me it did not work WLAN-VLAN, vWLC version is 8.5.161 and CAP2600

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card