Showing results for 
Search instead for 
Did you mean: 

Wireless client does not obtain DHCP IP address


Hi all,


I have a basic wireless lab configured (diagram attached), yet the Windows 7 wireless client doesn't not obtain an IP address. If I attach a wired Windows 7 PC to VLAN 95, it obtains an IP without a problem.


 I have the LWAP statically configured with an IP address ( at this point. It connects to the WLC (2502).   I have no authentication on the GuestNet SSID that I created. 


The DHCP pool for VLAN 95  is configured on the L3 switch. I have run DHCP debug on the L3 switch while I try to connect the wireless client to the lab ssid , but there doesn't seem to be any DHCP traffic coming from the WLC.


I've tried DHCP proxy enabled and disabled for the GuestNet WLAN.  Any ideas why the Windows 7 PC client doesn't obtain IP address?


Ultimately, I want to test a Guest Sponsored portal, but this is as far as I've gotten thus far.


I'll attach some logs when I spin up the environment tonight. I've run 'debug client <mac-addr> on the WLC. There are a few DHCP log entries, but not a lot.



I attached a PDF of the lab diagram.






8 Replies 8

Flavio Miranda


Let´s try to resolve DHCP first.  Put the WLC as proxy and on the Dynamic interface you created for Guest wlan you need to put the ip address as the DHCP server.

 On the guest WLAN General Tab, "Interface/Interface Group(G)" point to the dynamic interface you just created.



-If I helped you somehow, please, rate it as useful.-

Thanks for the response, Flavio. I tried the steps above , but no luck.


I was able to get the AP to use DHCP (VLAN 96) from the L3 switch (SW2) though


I attached a debug from the WifI PC attempt to access the ssid GuestNet-Lab.



One thing I didn´t see from the log is the message:

DHCP option: message type = DHCP OFFER 

Looks like the DHCP send several DHCP REQ message without response.


Can you show the output of:


show dhcp proxy



-If I helped you somehow, please, rate it as useful.- 

i am currently having similar issue. my client cannot obtain ip address from the dhcp server. surprisingly the same dynamic interface is allocated to another ssid which is doing webauth and gets ip address. the dhcp option in my case is set to global under the wlan config. i have a guest anchor scenerio and on both anchor and guest controllers i have the same settings.


show dhcp proxy

DHCP Proxy Behaviour: enabled

(WLC) >show dhcp proxy DHCP Proxy Behaviour: disabled Bootp-Broadcast:disabled I have this config disabled, I still have same issues. what I have is below. this is 5500 WLC Manufacturer's Name.............................. Cisco Systems Inc. Product Name..................................... Cisco Controller Product Version.................................. Bootloader Version............................... 1.0.20 Field Recovery Image Version.....................


I see mostly windows 10 machines on intel AC-8265 adapters driver version


Check once again:

1. Proxy is enabled globally and DHCP Proxy mode must be set to global on Guest interface !!

2. Is Guest VLAN allowed between WLC and Switch !!

If still fails then paste theoutput of these commands:


debug dhcp packet enable



Dontf orget to rate helpful posts


Sorry for the delay.


Did you try connecting to the SSID via Cisco AnyConnect or Windows native wireless?  I couldn't get it to connect via native, but I finally tried from Cisco Anyconnect client and it worked! I didn't think about using the client. I also noticed the the dhcp debug output looked much better with REQ/OFFER/ACK details



Well, i had some issue in the mobility configuration and the mobility was down some how. when i fixed it, it started working. Yes the anyconnect client works better with the wireless setup.


Thanks for your help!

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers