cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1739
Views
20
Helpful
18
Replies
Highlighted
Beginner

WLAN Client Roaming

I have a WLAN deployment with around 40 APs and dual WLC4400's. For some reason the clients seem too "sticky" to their first associated AP and don't roam. How can the system be tuned to make them roam to other AP's better?

2 ACCEPTED SOLUTIONS

Accepted Solutions
Highlighted
Enthusiast

Turn the power down on the AP's and clients. Smaller cell sizes will force the client to look for another AP sooner.

This however, might mean you need more AP's, but there should be a happy medium somewhere since your AP power settings are too high as it is.

You can also restrict the data rates to go no lower than 11Mbps.

You should be careful with this to ensure that the clients still function (voice in particular) but it is still a viable method to create aggregate bandwidth and physically load balance the network.

View solution in original post

Highlighted

You're quite welcome. Also, gather any information about the chipset in the m100s. I need to know if it is Intel or Summitt. This will help in tweaking the network. What chipset was in your laptop?

View solution in original post

18 REPLIES 18
Highlighted
Enthusiast

Turn the power down on the AP's and clients. Smaller cell sizes will force the client to look for another AP sooner.

This however, might mean you need more AP's, but there should be a happy medium somewhere since your AP power settings are too high as it is.

You can also restrict the data rates to go no lower than 11Mbps.

You should be careful with this to ensure that the clients still function (voice in particular) but it is still a viable method to create aggregate bandwidth and physically load balance the network.

View solution in original post

Highlighted

Send more information. Particulary on the environment, client device, and power settings.

Highlighted

You need to give more info. If users still have a good connection to a particular AP, there is no reason why that device should roam. Changing the power settings and or changing the data rates will help, but if the survey was done using the setting you currently have, then you will affect coverage overall. Not know how the survey was done and looking at AP locations, it is kind of hard to tell you what you should do. i know the Intel cards, has a configuration on roaming aggressiveness, but that might make the device roam way too much. You are better off picking a location and tweaking the ap's and the client until you are satisfied with the results.

-Scott
*** Please rate helpful posts ***
Highlighted
Beginner

The AP's were all configured in their default state (Power 1 - Max) with dynamic power adjustment enabled. The default speeds are also in place.

The clients machines they are using are Neoware M100 tablets running XP Embeded.

I don't think they are maintaining a good connection as they loose connectivity even though another AP is within site. It's almost like they attach to the first one they are near when they boot and they stay on that one unless you disconnect and reconnect while near another one.

With respect to the survey, I am not sure how the APs were configured in terms of power. I'll have to check on that one.

Highlighted

Ok Rick,

I have seen similar problems before when utilizing client server applications such as Citrix or SAP. I do need to know if the APs are actually providing good coverage so I am assuming you had a good survey done here. There are several client sticky conditions that have been found to be caused by 11mb beacons and eap issues. Try these settings:

Security => Credentials cashing enabled (eap credentials)

Improves roaming performance

Wireless => Global RF 802.11b/g

changed 11Mbit from mandatory to supported

Apparently there is a known issue with 11Mbit beacons,

disabling them also assists in better roaming.

If you would like me to look over your physical network of APs and coverage, send me a copy of your current survey. One other thing, which APs are you using and what antenna configuration. Noise and multipath can also contribute to longer roam times but I am betting on the thin client being the problem here.

Highlighted

First...thank you to all for helping me with this.

The coverage does appear to be fine based on the maping and from what I saw in the site survey. I never noticed this with my laptop while onsite.

The APs are 1130's with integrated antennas. The APs are mounted on a drop ceiling and are visible.

I will adjust those settings and see if they help or resolve. I won't be onsite until Tues. so I won't have any testing feedback until then.

Thanks!

Highlighted

You're quite welcome. Also, gather any information about the chipset in the m100s. I need to know if it is Intel or Summitt. This will help in tweaking the network. What chipset was in your laptop?

View solution in original post

Highlighted

I tested with the Intel in my laptop and I also have the Cisco PCMCIA ABG card.

Highlighted

That's kind of what I expected. We need to find out the chipset in this m100 device. Are you using Citrix? There are some known bugs with Citrix. Hopefully your devices are CCX 4 compliant. If so you can use CCKM. If not, it's going to get a little hairy.

Highlighted

They are using Citrix. Presentation Server 4.5.

Not sure on the CCX4 compliancy. I'll have to check on manufacturer's site.

Highlighted

After testing today they appear to be roaming and working as they should. This post is the one re: disabling the rates below 11mb/s are what I believe to have fixed the issue.

Further review of the M100 revealed that they are CCX v1 compliant...not v4 :( Seems that devices that did not support CCX worked bettern than these which were CCX v1.

The drivers / wireless card didn't not typically display the configuration that they were operating in (ie stating an 18mb/s connection when they were configured for 802.11b only). While the M100 does appear to a nice machine, I would recommend to anyone using them to disable the internal wireless and use a PCMCIA adapter from Cisco, etc.

Highlighted
Hall of Fame Master

Be carefull with the Cisco cards as there is an open caveat with the cards still connecting to data rates that have been disabled.

-Scott
*** Please rate helpful posts ***
Highlighted
Beginner

The clients are using a Ralink Wireless LAN Card V2 for their wireless adapter. They don't have any form of roaming settings like the Intel drivers do.

Highlighted

This is NOT a good thing. Have you contacted the manufacturer to see if there is a new driver? Let me know if those setting above help your problem.

Content for Community-Ad