cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
5640
Views
10
Helpful
13
Replies
Highlighted

WLC 2504 - Ap join fails with "Unknown AP type. Using Controller Version!!!"

Hi,

 

I haven't encountered this problem before. On my WLC 2504 I've tried now software versions 8.0.100.0, 7.6.130.0 and 7.4.121.0 (as per recommendation from other supportforum-posts), but still get this debug error when I'm trying to join ap models 1142 and 2602:

 

(Cisco Controller) >debug capwap errors enable 

(Cisco Controller) >*spamApTask5: Jan 02 02:11:46.549: Unknown AP type. Using Controller Version!!!

*spamApTask0: Jan 02 02:11:46.550: 88:43:e1:78:10:08 Join Priority Processing status = 0, Incoming Ap's Priority 1, MaxLrads = 5,joined Aps =0
*spamApTask5: Jan 02 02:11:56.670: f8:66:f2:14:4e:c1 Deleting AP 10.68.254.101 which has not been plumbed
*spamApTask5: Jan 02 02:11:56.673: f8:66:f2:14:4e:c1 DTLS connection was closed

(Cisco Controller) >

 

Does anyone know what is failing here? Surely the ap's should be "known" in these software versions? 

 

 

Best

Bent Eskil

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Hall of Fame Master

Make sure the time is set properly on the WLC and also make sure the country code for the APs are set on the WLC. 

-Scott

-Scott
*** Please rate helpful posts ***

View solution in original post

13 REPLIES 13
Highlighted
Hall of Fame Master

Make sure the time is set properly on the WLC and also make sure the country code for the APs are set on the WLC. 

-Scott

-Scott
*** Please rate helpful posts ***

View solution in original post

Highlighted

Setting the correct time was it. Embarrassing to overlook this on my part. Thanks for a very quick reply!

Highlighted

No problem, glad to help.

-Scott

-Scott
*** Please rate helpful posts ***
Highlighted

I have the same issue ,  but unfortunately fixing the time did not help.

Unknown AP type. Using Controller Version AIR-AP2802E-E-K9

My WLC is 5508 ,  System info :

Manufacturer's Name.............................. Cisco Systems Inc.
Product Name..................................... Cisco Controller
Product Version.................................. 8.0.135.0

The LAP is getting an IP but not joing the WLC .  I am using the internal DHCP with the management IP interface as DHCP.

Below is the CAPWAP debug output.

sco Controller) >*spamApTask5: Apr 12 19:16:43.992: 2c:5a:0f:1a:6c:e0 Discovery Request from 10.32.1.101:5272

*spamApTask5: Apr 12 19:16:43.992: 2c:5a:0f:1a:6c:e0 ApModel: AIR-AP2802E-E-K9

*spamApTask5: Apr 12 19:16:43.993: 2c:5a:0f:1a:6c:e0 Join Priority Processing status = 0, Incoming Ap's Priority 1, MaxLrads = 12, joined Aps =0
*spamApTask5: Apr 12 19:16:43.993: apModel: AIR-AP2802E-E-K9

*spamApTask5: Apr 12 19:16:43.993: apType = 46 apModel: AIR-AP2802E-E-K9

*spamApTask5: Apr 12 19:16:43.993: Unknown AP type. Using Controller Version!!!

*spamApTask5: Apr 12 19:16:43.993: 2c:5a:0f:1a:6c:e0 Discovery Response sent to 10.32.1.101 port 5272

*spamApTask5: Apr 12 19:16:43.993: 2c:5a:0f:1a:6c:e0 Discovery Response sent to 10.32.1.101:5272


Highlighted

Based on the Compatibility Matrix I think you need to upgrade the code on your WLC to support the 2802E. You have also have an E regulatory domain AP which means your AP is designed to be used in one of the countries below. 

E Algeria Austria Bahrain Belgium Bosia & Herzegovina Bulgaria
  Croatia Czech Republic Denmark Estonia Finland France
  Germany Ghana Gibraltar Greece Hungary Iceland
  Iraq Ireland Italy Jamaica Kenya Latvia
  Lebanon Libya Lichtenstein Lithuania Luxemborg Malta
  Monaco Mongolia Montenegro Netherlands Nigeria Norway
  Oman poland Portugal Romania Russian Federation Saudi Arabia
  Serbia Slovakia Slovenia South Africa Spain Sri Lanka
  Sweden Switzerland Thailand Tunisia Turkey Ukraine
  United Arab Emirates United Kingdom Vietnam

8.0.140.0

15.3(3)JA10/
12.4(25e)JAP10

Lightweight APs: 1040, 1130, 1140, 1240, 1250, 1260, 1600, 1700, 2600, 2700, 3500e, 3500i, 3500p, 3600e, 3600i, 3600p, 3702e, 3702i, 3702p, 600 OEAP, 700, 700W, AP801, and AP802

Note Cisco MSE Release 8.0.140.0 includes wIPS support for the Cisco Aironet 1800, 2800, and 3800 series. However, CAS is not supported for these APs.

Outdoor and Industrial APs: 1522, 1524PS, 1524SB, 1532E, 1532I, 1552E, 1552H, 1552I, 1552C, 1552EU, 1552CU, 1552S, 1570, and IW3702

Note The Cisco Wireless Release 8.0.135.0 is a repost of the Cisco Wireless Release 8.0.132.0 and 8.0.133.0. This release impacts only the Cisco Aironet 1570 Series APs with -B regulatory domain and meet the following criteria:

a. The Cisco 1570 APs that are made available on or after June 2, 2016, for the USA region

b. The Cisco 1570 APs that are identified with version ID 02 (V02)

This release ensures that Cisco 1570 APs that are made available to customers in the USA are in compliance with the new FCC rules that come into effect on June 2, 2016.

8.0.135.0

15.3(3)JA9/
12.4(25e)JAP9

http://www.cisco.com/c/en/us/td/docs/wireless/compatibility/matrix/compatibility-matrix.html#pgfId-147162

http://www.wificert.org/regulatory-domains/

William Kuczmera 

Highlighted

I have upgraded the WLC to 8.2.110.0 , but still having the same issue.

Do I need to configure anything on the APs ?

Highlighted

Hi, looks like I have the problem also.
WLC-5520 8.2.151.0 With regulatory Domain DE and apModel AIR-AP2802I-E-K9.

Until now I do not know what the problem is. Time is in synch and MIC authorization is enabled.

Unknown AP type. Using Controller Version!!!

any suggestions ?

Highlighted
Beginner

Hi I have the same issue, today i rebooted the controller after that no Access Point is joining the controller.  While debug i can see same logs as given above. I have configured option 43 and 60 as well on cisco switch. Pool commands are:

 

ip dhcp pool Room-1
 host 192.168.30.113 255.255.255.0
 client-identifier 0188.1dfc.f7cb.30
 default-router 192.168.30.3
 domain-name mina.local
 option 43 hex f108.aca8.1e68
 dns-server 192.168.30.1 4.2.2.2
 option 60 ascii "Cisco AP c3702

 

I have checked the time and country code all fine but still Access point are not joining. Can you help me out to figure out the issue.

 

Thanks

Highlighted

What code is your controller on ? 

"Satisfaction does not come from knowing the solution, it comes from knowing why." - Rosalind Franklin
___________________________________________________________
Highlighted

Thanks for response, i am running Software Version 8.0.110.0 on controller

Highlighted

If you just rebooted the WLC and nothing was changed, then that's not normal. All access points were up and running and the code wasn't uograded correct?

-Scott

-Scott
*** Please rate helpful posts ***
Highlighted

Thanks for response. Yes all the APs  were running and now I am getting this massage. The code was update 20 days ago. Everything was working fine but now I am facing this issue.. what I can do to resolve

 

Highlighted

Hi All,

 

These settingwork for me:

 

  • from GUI > Security > AP Policies > SSC and MIC certificates are checked
  • from GUI > Controller tab > Advanced > Master Controller option is enabled

But i don't got the point, i never use to check this even all other controllers they don't have these settings. Can anyone explain whether it is necessary. I have one more controller in LAN should i change for that as well.

Content for Community-Ad