Showing results for 
Search instead for 
Did you mean: 

WLC 5508 and Motorola Symbol Handheld issue


Hi everyone, i have a weird problem and i hope you can help me guys!!

   I have just migrate a Symbol-based autonomous wireless network to a Cisco Controller-based environment and everything apparently was working fine. However a few weeks later the installation was over, my customer reported they can't access to a server's shared folder.

   This WLAN environment is installed in a warehouse and it is meant to support two different types of users: Regular Lap Top users and Motorola-Symbol Handhels. There are two SSIDs with static security methods (one with WPA+PSK and the other with static WEP key), Handhelds are joined to the SSID with static WEP key. So, here's the deal, this handhelds can join the network without any connectivity issues, roaming, signal strenght, etc. They can also ping everywhere. The problem is that when they need to access a server's shared folder and download files, handhelds displays a bad network path error message. If you do the same with a lap top, you can access the server´s folder with no problems. The handheld model is a Motorola-Symbol 9090 with Windows CE operating system version 5.0. Cisco infraestructure is as follows: WLC5508 running OS version and AIR-LAP1142N-N-K9 series Access Points. In adition, i made a lab back in the office, and reproduce the problem. I tested with an autonomous AP same model and I can actually access a server's folder with no issue but int the very moment i test with a controller-based network i get the same result. I have made several changes in both, handheld and controller, based on a Cisco document for Motorola-Symbol and Cisco best practices. I also have placed a sniffer on my network but I can´t see any traffic when joined throught controller's WLAN. I placed it in the link between WLC and switch and between the switch and the Cisco AP.

Thank you all in advance


1 Accepted Solution

Accepted Solutions

Amjad Abdullah

You need to enablemulticast on the controller. It is disabled by default.

Sent from Cisco Technical Support iPad App

Rating useful replies is more useful than saying "Thank you"

View solution in original post

6 Replies 6

Amjad Abdullah

You need to enablemulticast on the controller. It is disabled by default.

Sent from Cisco Technical Support iPad App

Rating useful replies is more useful than saying "Thank you"

Thanks for the prompt answer Amjad, i will try this and let you know how it goes

Hi Amjad, I issued the command config network broadcast enable and this apparently solved the problem, I don't know if this will have further consecuences, please let me know if there's something and thank you very much for your assistance


By default, the WLC's do not forward broadcast or

multicast traffic to the wireless networks from the

wired network.

Broadcasts on the same VLAN on the wireless network is

only blocked at the controller from reaching other subnets

unless you specifically turn on broadcast forwarding.

If the devices are on the same wireless subnet, the

broadcasts are not blocked.

I am glad that it worked.

well, enabling boradcast/multicast is not recommended if it is not bieng used. It saves bandwidth if it is disabled. However, if it is needed you can enabled it.

BTW, what I know with old versions (before that enabling broadcast only does not work unless you enable multicast as well.

enabling multicast:

# config network multicast global enable.

I worked with one customer before where enabling the broadcast does not work until multicast is also enabled. Do you have the multicast config globally enabled already?

Rating useful replies is more useful than saying "Thank you"

No, I don't Amjad. When I was troubleshooting I discovered that, when with an autonomous AP, the only traffic was Netbios and I had access to server's  folder. On the other hand, when I was testing with lightweight infraestructure, I didn't see any traffic at all. So, I know Netbios is broadcast traffic and -after your answer- when I was reviewing a document for multicast I saw that broadcast must be enabled before enabling Multicast. So I decide to just enable broadcast and see how it works. by the way, I think this is a weird behavior because both, Handheld and Server are on the same subnet...

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers