cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
5679
Views
20
Helpful
13
Replies
igalang1093
Beginner

WLC 9800 DOESN´T CONNECT WITH SOME ANDROID DEVICES

Hello,

 

I have a problem with some android devices, some of them can´t be connected to the wireless network through PSK, they only can connect to one of the SSID's which is using  Web authentication. I have a Catalyst 9800 WLC and 9115 AP.

I hope you can help me.

1 ACCEPTED SOLUTION

Accepted Solutions
frost_michael
Beginner

It’s might be the bug on 9100 series APs and Android 10 devices with Qualcomm chipsets - Moto,Nokia, Xiaomi, etc.

 

Try enabling FT (Not adaptive) and enable security for PSK, and PSK + FT. This worked for our dot1x network.

View solution in original post

13 REPLIES 13
Scott Fella
Hall of Fame Guru

Test with wpa2 and then with wpa3 and see if you still have the issue. You can also search the forum as I know others have been asking the same question.
-Scott
*** Please rate helpful posts ***

Thanks for your help, I will test.

patoberli
VIP Advisor

What software release is running on the WLC?

Hello,

 

WLC is running Version 16.12.1, RELEASE SOFTWARE

Why don't you try another code version? You mentioned some, not all, so its kind of hard to say what will fix it. My suggestion is to upgrade to a few different and see if that fixes it or not. If not, open a tac cas and see what they say.... I'm assuming these Android devices are new not old? Do the devices that don't connect, connect fine with an open SSID?
-Scott
*** Please rate helpful posts ***
frost_michael
Beginner

It’s might be the bug on 9100 series APs and Android 10 devices with Qualcomm chipsets - Moto,Nokia, Xiaomi, etc.

 

Try enabling FT (Not adaptive) and enable security for PSK, and PSK + FT. This worked for our dot1x network.

View solution in original post

this is a know BUG: https://bst.cloudapps.cisco.com/bugsearch/bug/CSCvu24770

Fix will be included in 17.3 and 16.12.4 - they are planned for next week. (time might change based on internal testing)

Saludos,
Rafael - TAC

Thanks for your help. I have tried and it works.

one note - this caused issues for iOS devices running version 12 and earlier, and Android 6 and earlier devices. They were unable to connect to the FT-enabled SSID. We have FT enabled on one SSID, and adaptive on another, until there is a permanent fix for both WLC and Android.

It's not working, we are using 9800 controller with software version 17.3.3

We are currently facing similar issue. We are migrating to WLC 9800 and AP model C9120AXI-D. IOS-XE version 17.3.3

Android of version 11 and iPhone is able to connect but android of version 10 is unable to connect. 

Do we have any fix for this so far ? 

henrik.stoklund
Beginner

Same issue also.. WLC9800 - 17.3.3 and 9120/9130 access points. 

Any fix ?

AronUrban
Beginner

We are facing the same issues.
WLC Version 17.3.4 on C9800-80 WLCs

We have Nokia 4.2 and OnePlus devices and also iPad Gen 7 with iOS15.x with those Problems. We will try to disable FT and AES Password Encryption today and test the devices again. I will update you with the results

Create
Recognize Your Peers
Content for Community-Ad