cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
configure & troubleshoot anyconnect
1613
Views
5
Helpful
11
Replies
Beginner

ASR 9k Upgrade 5.1.3 to 5.3.3

Dear All

I have to upgrade cisco ASR 9K from IOS XR version 5.1.3 to 5.3.3.The current version details and package details are below.


Default Profile:
  SDRs:
    Owner
  Active Packages:
    disk0:asr9k-services-infra-5.1.3
    disk0:asr9k-optic-px-5.1.3
    disk0:asr9k-doc-px-5.1.3
    disk0:asr9k-9000v-nV-px-5.1.3
    disk0:asr9k-bng-px-5.1.3
    disk0:asr9k-fpd-px-5.1.3
    disk0:asr9k-mpls-px-5.1.3
    disk0:asr9k-video-px-5.1.3
    disk0:asr9k-mcast-px-5.1.3
    disk0:asr9k-mgbl-px-5.1.3
    disk0:asr9k-asr903-nV-px-5.1.3
    disk0:asr9k-services-px-5.1.3
    disk0:asr9k-mini-px-5.1.3
    disk0:asr9k-li-px-5.1.3
    disk0:asr9k-asr901-nV-px-5.1.3
    disk0:asr9k-k9sec-px-5.1.3
    disk0:asr9k-px-5.1.3.sp4-1.0.0

RP/0/RSP1/CPU0:ASR01#

The Service Pack i have downloaded have the details as follows.

Name:                    asr9k-px-5.3.3.sp2.pie

Package(s):              asr9k-fwding-5.3.3.sp2-1.0.0
                         iosxr-common-pd-fib-5.3.3.sp2-1.0.0
                         iosxr-gcp-fwding-5.3.3.sp2-1.0.0
                         iosxr-fwding-5.3.3.sp2-1.0.0
                         iosxr-routing-5.3.3.sp2-1.0.0
                         asr9k-os-mbi-5.3.3.sp2-1.0.0
                         iosxr-infra-5.3.3.sp2-1.0.0
                         iosxr-mpls-5.3.3.sp2-1.0.0
                         asr9k-services-infra-5.3.3.sp2-1.0.0
                         asr9k-service-supp-5.3.3.sp2-1.0.0
                         iosxr-service-5.3.3.sp2-1.0.0
                         asr9k-base-5.3.3.sp2-1.0.0
                         asr9k-fpd-5.3.3.sp2-1.0.0
                         iosxr-bng-5.3.3.sp2-1.0.0
                         asr9k-cpp-5.3.3.sp2-1.0.0
                         iosxr-ce-5.3.3.sp2-1.0.0
                         iosxr-mcast-5.3.3.sp2-1.0.0

On-the-Box Name:         asr9k-px-5.3.3.sp2

The box comes with RS440 card

Am i good to upgrade the box with standard method i.e add/activate/commit  or do i need anything else to activate in order to make a successful transition to 5.3.3

Thanks

Bilal

2 ACCEPTED SOLUTIONS

Accepted Solutions
Cisco Employee

Hi Bilal,

Hi Bilal,

I think you have not added the 5.3.3 pies to the node. The 5.3.3 pies needs to be added inorder to move to 5.3.3.

Also, the current node is missing the SMU for CSCut52232 on 5.1.3 release. Without this SMU the install add for 5.3.3 pies will fail.

Please check following links for the SMU installation:

http://www.cisco.com/c/en/us/td/docs/routers/technotes/MOP-CSS-to-Abraxas.html

http://www.cisco.com/c/en/us/support/docs/field-notices/639/fn63979.html

Thanks
Santosh

.

Cisco Employee

Hi Bilal,I think you have

Hi Bilal,

I think you have "disk0:asr9k-asr903-nV-px-5.1.3” pie active on the node:
Default Profile:
  SDRs:
    Owner
  Active Packages:
    disk0:asr9k-services-infra-5.1.3
    disk0:asr9k-optic-px-5.1.3
    disk0:asr9k-doc-px-5.1.3
    disk0:asr9k-9000v-nV-px-5.1.3
    disk0:asr9k-bng-px-5.1.3
    disk0:asr9k-fpd-px-5.1.3
    disk0:asr9k-mpls-px-5.1.3
    disk0:asr9k-video-px-5.1.3
    disk0:asr9k-mcast-px-5.1.3
    disk0:asr9k-mgbl-px-5.1.3
    disk0:asr9k-asr903-nV-px-5.1.3
    disk0:asr9k-services-px-5.1.3
    disk0:asr9k-mini-px-5.1.3
    disk0:asr9k-li-px-5.1.3
    disk0:asr9k-asr901-nV-px-5.1.3
    disk0:asr9k-k9sec-px-5.1.3
    disk0:asr9k-px-5.1.3.sp4-1.0.0

Please try following steps:
1. Deactivate the 903 pie from active pie list, incase it is activated.
2. Install commit
3. Try 5.3.3 activated. This should work.


Thanks,
Santosh

11 REPLIES 11
Cisco Employee

Hi Bilal,

Hi Bilal,

I think you have not added the 5.3.3 pies to the node. The 5.3.3 pies needs to be added inorder to move to 5.3.3.

Also, the current node is missing the SMU for CSCut52232 on 5.1.3 release. Without this SMU the install add for 5.3.3 pies will fail.

Please check following links for the SMU installation:

http://www.cisco.com/c/en/us/td/docs/routers/technotes/MOP-CSS-to-Abraxas.html

http://www.cisco.com/c/en/us/support/docs/field-notices/639/fn63979.html

Thanks
Santosh

.

Beginner

Hi Santosh

Hi Santosh

I am new to XOR environment.

This is how i summaries .

1. I need to download a certificate and add it to device.check

2. I need to download SMU for CSCut52232 so that i can upgrade.check

3. if I am going for 5.3.3(asr9k-px-5.3.3.sp2.tar) SP2 release .Do i still need to add the PIES.The SP will not include all the PIE files ???.How this works ?

Thanks for the help

Regards

Bilal

Cisco Employee

Hi Bilal,

Hi Bilal,

Here are the steps:

1. download 5.1.3 SMU for CSCut52232. The tar file for SMU has the certificate as well.

2. Add the certificate on the node:

RP/0/RSP0/CPU0:ASR-9K# copy tftp://10.10.1.1/tftpboot-location/css-root.cer disk0:
Wed Dec 21 06:01:16.464 UTC
Destination filename [/disk0:/css-root.cer]?
Accessing tftp://10.10.1.1/tftpboot-location/css-root.cer
C
1217 bytes copied in      0 sec
 
RP/0/RSP0/CPU0:ROUTER# sam add certificate /disk0:/css-root.cer root trust
Wed Dec 21 06:09:43.207 UTC
SAM: Successful adding certificate /disk0:/css-root.cer
 
3. Copy the SMU for CSCut52232(5.1.3) to harddisk:
4. add the SMU: admin install add harddisk:<SMU name>
5. Activate the SMU for CSCut52232: admin install activate <SMU name from "show install inavtive summ">. This is hitless operation and will not cause any service impact.
6. Download the 5.3.3 image tar file from Cisco.com. SP2 will not have all the pies.
7. Download SP2 from Cisco.com
8. Untar the 5.3.3 image tar file. It will show all the pies now.
9. Untar the 5.3.3 SP2 file as well
10. Copy the required pies and SP2 to harddisk:
11. add the pies and SP2 using install add command: admin install add harddisk:*5.3.3*
12. Activate the 5.3.3 pies and SP2: admin install activate disk0:*5.3.3*
13. After this the router will go for a reload. Once router comes up perform: admin install commit
After this the router will be up with 5.3.3 image.
Thanks,
Santosh
Beginner

i tried to install but i got

i tried to install but i got this error

Info: disk0:asr9k-services-infra-5.3.3
Error: Cannot proceed with the activation because of the following package incompatibilities:
Error: asr9k-asr903-supp-5.1.3 needs asr9k-os-supp-5.1.3, or equivalent, to be active on the same nodes.
Error: asr9k-asr903-supp-5.1.3 needs iosxr-infra-5.1.3, or equivalent, to be active on the same nodes.
Error: asr9k-asr903-supp-5.1.3 needs iosxr-os-5.1.3, or equivalent, to be active on the same nodes.
Error: Suggested steps to resolve this:
Error: - check the installation instructions.
Error: - activate or deactivate the specified packages on the specified nodes.
Install operation 49 failed at 04:17:49 QAT Mon Jul 18 2016.

asr9k-asr903-supp-5.3.3 is not present anywhere in the cisco website

Beginner

To be exact these are the

To be exact these are the output of various useful commands

Install operation 49 started by user 'braziq' via CLI
(admin) install activate disk0:*5.3.3*
Install operation 49 failed .

Install logs:
    Install operation 49 '(admin) install activate disk0:*5.3.3*' started by user 'braziq'
    Info:     This operation will activate the following packages:
    Info:         disk0:asr9k-video-px-5.3.3
    Info:         disk0:asr9k-services-px-5.3.3
    Info:         disk0:asr9k-px-5.3.3.sp2-1.0.0
    Info:         disk0:asr9k-optic-px-5.3.3
    Info:         disk0:asr9k-mpls-px-5.3.3
    Info:         disk0:asr9k-mini-px-5.3.3
    Info:         disk0:asr9k-mgbl-px-5.3.3
    Info:         disk0:asr9k-mcast-px-5.3.3
    Info:         disk0:asr9k-li-px-5.3.3
    Info:         disk0:asr9k-k9sec-px-5.3.3
    Info:         disk0:asr9k-fpd-px-5.3.3
    Info:         disk0:asr9k-doc-px-5.3.3
    Info:         disk0:asr9k-bng-px-5.3.3
    Info:         disk0:asr9k-9000v-nV-px-5.3.3
    Info:         disk0:asr9k-asr901-nV-px-5.3.3
    Info:         disk0:asr9k-services-infra-5.3.3
    Error:    Cannot proceed with the activation because of the following package incompatibilities:
    Error:      asr9k-asr903-supp-5.1.3 needs asr9k-os-supp-5.1.3, or equivalent, to be active on the same nodes.
    Error:      asr9k-asr903-supp-5.1.3 needs iosxr-infra-5.1.3, or equivalent, to be active on the same nodes.
    Error:      asr9k-asr903-supp-5.1.3 needs iosxr-os-5.1.3, or equivalent, to be active on the same nodes.
    Error:    Suggested steps to resolve this:
    Error:     - check the installation instructions.
    Error:     - activate or deactivate the specified packages on the specified nodes.
    Install operation 49 failed

--------------------------------------------------------------------------------


50 entries shown
RP/0/RSP1/CPU0:ASR01#
RP/0/RSP1/CPU0:ASR01#
RP/0/RSP1/CPU0:ASR01#sh install active summary

Default Profile:
  SDRs:
    Owner
  Active Packages:
    disk0:asr9k-services-infra-5.1.3
    disk0:asr9k-optic-px-5.1.3
    disk0:asr9k-doc-px-5.1.3
    disk0:asr9k-9000v-nV-px-5.1.3
    disk0:asr9k-bng-px-5.1.3
    disk0:asr9k-fpd-px-5.1.3
    disk0:asr9k-mpls-px-5.1.3
    disk0:asr9k-video-px-5.1.3
    disk0:asr9k-mcast-px-5.1.3
    disk0:asr9k-mgbl-px-5.1.3
    disk0:asr9k-services-px-5.1.3
    disk0:asr9k-mini-px-5.1.3
    disk0:asr9k-li-px-5.1.3
    disk0:asr9k-asr901-nV-px-5.1.3
    disk0:asr9k-k9sec-px-5.1.3
    disk0:asr9k-px-5.1.3.sp4-1.0.0
    disk0:asr9k-px-5.1.3.CSCut52232-1.0.0

RP/0/RSP1/CPU0:ASR01#sh install inactive summary | in 5.3.3

    disk0:asr9k-services-infra-5.3.3
    disk0:asr9k-asr901-nV-px-5.3.3
    disk0:asr9k-9000v-nV-px-5.3.3
    disk0:asr9k-bng-px-5.3.3
    disk0:asr9k-doc-px-5.3.3
    disk0:asr9k-fpd-px-5.3.3
    disk0:asr9k-k9sec-px-5.3.3
    disk0:asr9k-li-px-5.3.3
    disk0:asr9k-mcast-px-5.3.3
    disk0:asr9k-mgbl-px-5.3.3
    disk0:asr9k-mini-px-5.3.3
    disk0:asr9k-mpls-px-5.3.3
    disk0:asr9k-optic-px-5.3.3
    disk0:asr9k-px-5.3.3.sp2-1.0.0
    disk0:asr9k-services-px-5.3.3
    disk0:asr9k-video-px-5.3.3
RP/0/RSP1/CPU0:ASR01#

Cisco Employee

Hi Bilal,I think you have

Hi Bilal,

I think you have "disk0:asr9k-asr903-nV-px-5.1.3” pie active on the node:
Default Profile:
  SDRs:
    Owner
  Active Packages:
    disk0:asr9k-services-infra-5.1.3
    disk0:asr9k-optic-px-5.1.3
    disk0:asr9k-doc-px-5.1.3
    disk0:asr9k-9000v-nV-px-5.1.3
    disk0:asr9k-bng-px-5.1.3
    disk0:asr9k-fpd-px-5.1.3
    disk0:asr9k-mpls-px-5.1.3
    disk0:asr9k-video-px-5.1.3
    disk0:asr9k-mcast-px-5.1.3
    disk0:asr9k-mgbl-px-5.1.3
    disk0:asr9k-asr903-nV-px-5.1.3
    disk0:asr9k-services-px-5.1.3
    disk0:asr9k-mini-px-5.1.3
    disk0:asr9k-li-px-5.1.3
    disk0:asr9k-asr901-nV-px-5.1.3
    disk0:asr9k-k9sec-px-5.1.3
    disk0:asr9k-px-5.1.3.sp4-1.0.0

Please try following steps:
1. Deactivate the 903 pie from active pie list, incase it is activated.
2. Install commit
3. Try 5.3.3 activated. This should work.


Thanks,
Santosh

Beginner

Hi Santosh

Hi Santosh

Actually this is live system.If we want to remove anything .It should be properly justified what this PIE is doing here what features it offers and what will go down if deactivate the PIE.I couldn't find any literature on this particular PIE from Cisco.

Can you refer me to any link.

Thank you so much for the support.

Regards

Bilal

Cisco Employee

This pie is for 903 satellite

This pie is for 903 satellite. I dont think the node has any satellite based on 903. This can be deactivated without any production impact.

Can you share o/p for:

show install active summar

show install committed summary

show install summary

-Santosh

Beginner

HI Santosh

HI Santosh

I removed 903 satellite pie for 5.1.3 before upgrading to 5.3.3 .This time the Upgrade was successful turned out after 5.3.0 the support for 903 satellite has been removed .Thats why 5.3.3 doesnt have any PIE related to satellite 903 and led to the failure of upgrade.

Thanks for the great help though

Regards

Bilal

Beginner

Re: HI Santosh

Hi team,

 

I came acroos the similar issue with 6.1.4. When I try installing using "install add "c command , it install files and even show up in "sh install inactive" but when I try to install activate it gives me the following error: any help here?

 

Install operation 23 failed at 23:53:34 UTC Sun Jun 24 2018.
RP/0/RSP1/CPU0:ios(admin)#sh install inac
Sun Jun 24 23:53:50.124 UTC
Secure Domain Router: Owner
  Node 0/RSP0/CPU0 [RP] [SDR: Owner]
    Boot Device: disk0:
    Inactive Packages:
      disk0:asr9k-services-infra-6.1.4
      disk0:asr9k-px-6.1.4.sp4-1.0.0
      disk0:asr9k-9000v-nV-px-6.1.4
      disk0:asr9k-bng-px-6.1.4
      disk0:asr9k-doc-px-6.1.4
      disk0:asr9k-fpd-px-6.1.4
      disk0:asr9k-k9sec-px-6.1.4
      disk0:asr9k-li-px-6.1.4
      disk0:asr9k-mcast-px-6.1.4
      disk0:asr9k-mgbl-px-6.1.4
      disk0:asr9k-mini-px-6.1.4
      disk0:asr9k-mpls-px-6.1.4
      disk0:asr9k-optic-px-6.1.4
      disk0:asr9k-services-px-6.1.4
      disk0:asr9k-video-px-6.1.4
  Node 0/RSP1/CPU0 [RP] [SDR: Owner]
    Boot Device: disk0:
RP/0/RSP1/CPU0:ios(admin)#install activate  disk0:asr9k-services-infra-6.1.4
Sun Jun 24 23:54:11.969 UTC
Install operation 24 '(admin) install activate
disk0:asr9k-services-infra-6.1.4' started by user 'admin' via CLI at 23:54:12
UTC Sun Jun 24 2018.
| 1% complete: The operation can still be aborted (ctrl-c for options)RP/0/RSP1/CPU0:Jun 24 23:54:21.315 : instdir[248]: %INSTALL-INSTMGR-3-INSTALL_OPERATION_USER_ERROR : User error occurred during install operation 24. See 'show install log 24 dormation.  more inf
Error:    Cannot proceed with the activation because of the following package
Error:    incompatibilities:
Error:      asr9k-services-infra-6.1.4 needs asr9k-os-supp-6.1.4, or
Error:    equivalent, to be active on the same nodes.
Error:      asr9k-services-infra-6.1.4 needs iosxr-infra-6.1.4, or equivalent,
Error:    to be active on the same nodes.
Error:      asr9k-services-infra-6.1.4 needs iosxr-os-6.1.4, or equivalent, to
Error:    be active on the same nodes.
Error:    Suggested steps to resolve this:
Error:     - check the installation instructions.
Error:     - activate or deactivate the specified packages on the specified
Error:       nodes.
Install operation 24 failed at 23:54:21 UTC Sun Jun 24 2018.
Highlighted
Cisco Employee

Re: HI Santosh

Hi,

 

You need the service infra package in 6.1.4 as well, you have to upgrade all active packages from release A to B, you cannot do a sub-set.

 

Sam

CreatePlease to create content