cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
157
Views
0
Helpful
5
Replies
Beginner

ASR upgrade from 5.3.3 to 6.3.3

Hi,

 

I'm working on upgrading ASR from 5.3.3 to 6.3.3. I've tested this upgrade in the lab and it was very straight forward upgrade. However in production i'm getting some errors.

I did install add with the tar file that went ok and now the activation itself gives error about following package incompatibilities. Any hints whats missing? I've checked the bridge SMU package and don't see anything thats needed for 5.3.3-6.3.3 upgrade.

 

    Info:     This operation will activate the following packages:

    Info:         disk0:asr9k-9000v-nV-px-6.3.3

    Info:         disk0:asr9k-bng-px-6.3.3

    Info:         disk0:asr9k-doc-px-6.3.3

    Info:         disk0:asr9k-fpd-px-6.3.3

    Info:         disk0:asr9k-k9sec-px-6.3.3

    Info:         disk0:asr9k-li-px-6.3.3

    Info:         disk0:asr9k-mcast-px-6.3.3

    Info:         disk0:asr9k-mgbl-px-6.3.3

    Info:         disk0:asr9k-mini-px-6.3.3

    Info:         disk0:asr9k-mpls-px-6.3.3

    Info:         disk0:asr9k-optic-px-6.3.3

    Info:         disk0:asr9k-services-infra-6.3.3

    Info:         disk0:asr9k-services-px-6.3.3

    Info:         disk0:asr9k-video-px-6.3.3

    Error:    Cannot proceed with the activation because of the following

    Error:    package incompatibilities:

    Error:      asr9k-asr901-supp-5.3.3 needs asr9k-os-supp-5.3.3, or

    Error:    equivalent, to be active on the same nodes.

    Error:      asr9k-asr901-supp-5.3.3 needs iosxr-infra-5.3.3, or equivalent,

    Error:    to be active on the same nodes.

    Error:      asr9k-asr901-supp-5.3.3 needs iosxr-os-5.3.3, or equivalent, to

    Error:    be active on the same nodes.

    Error:    Suggested steps to resolve this:

    Error:     - check the installation instructions.

    Error:     - activate or deactivate the specified packages on the specified

    Error:       nodes.

 

Thank you

5 REPLIES 5
Highlighted

Re: ASR upgrade from 5.3.3 to 6.3.3

You probably have the asr9k-asr901-nV-5.3.3 package active? When upgrading you need to upgrade to the exact same combination of packages or a superset of them.

Highlighted
Cisco Employee

Re: ASR upgrade from 5.3.3 to 6.3.3

That's what it looks like from the error messages, that package was removed as support for the 901 as a satellite was removed.

 

Sam

Highlighted
Beginner

Re: ASR upgrade from 5.3.3 to 6.3.3

Hi

 

Yep I have both of those you mentioned:

 

disk0:asr9k-asr901-nV-px-5.3.3
disk0:asr9k-9000v-nV-px-5.3.3

 

 

Node 0/RSP0/CPU0 [RP] [SDR: Owner]
Boot Device: disk0:
Boot Image: /disk0/asr9k-os-mbi-5.3.3/0x100000/mbiasr9k-rp.vm
Active Packages:
disk0:asr9k-services-infra-5.3.3
disk0:asr9k-services-px-5.3.3
disk0:asr9k-optic-px-5.3.3
disk0:asr9k-mpls-px-5.3.3
disk0:asr9k-mini-px-5.3.3
disk0:asr9k-mcast-px-5.3.3
disk0:asr9k-li-px-5.3.3
disk0:asr9k-fpd-px-5.3.3
disk0:asr9k-bng-px-5.3.3
disk0:asr9k-asr901-nV-px-5.3.3
disk0:asr9k-9000v-nV-px-5.3.3
disk0:asr9k-k9sec-px-5.3.3

 

As I understand I need to remove disk0:asr9k-asr901-nV-px-5.3.3 and then go with the upgrade?

Highlighted

Re: ASR upgrade from 5.3.3 to 6.3.3

Yes exactly. Compare your 6.3.3 packages with the current 5.3.3 packages with "admin show install summary", if you have a 5.3.3 package that does not exist for 6.3.3 you have to deactivate it before upgrading.
Highlighted
Beginner

Re: ASR upgrade from 5.3.3 to 6.3.3

Got it, makes sense. 

 

Thank you

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here