cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
5708
Views
0
Helpful
6
Replies
Stanislav Zaikin
Beginner

ASR9000 - xconnect to 7600

Hello.

Trying to establish xconnect between ASR9010 and 7600. xconnect is up and traffic flow, but traffic left from 7600 with 2 dot1Q tags and from ASR without tags (captured with Wireshark).

ASR config:

RP/0/RSP1/CPU0:zip#sh running-config l2vpn

Tue Jan 15 19:25:25.616 UTC

l2vpn

xconnect group xgroup

  p2p test1

   interface TenGigE0/0/0/0.40

   neighbor 10.1.1.2 pw-id 1234

RP/0/RSP1/CPU0:zip#sh running-config interface tenGigE 0/0/0/0.40

Tue Jan 15 19:25:33.604 UTC

interface TenGigE0/0/0/0.40 l2transport

encapsulation dot1q 40

mtu 1514

7600 config:

Router#sh running-config interface g3/1.40

Building configuration...

Current configuration : 106 bytes

!

interface GigabitEthernet3/1.40

encapsulation dot1Q 40

xconnect 10.1.1.1 1234 encapsulation mpls

end

xconnect status:

ASR

RP/0/RSP1/CPU0:zip#sh l2vpn xconnect detail

Tue Jan 15 19:29:52.892 UTC

Group xgroup, XC test1, state is up; Interworking none

  AC: TenGigE0/0/0/0.40, state is up

    Type VLAN; Num Ranges: 1

    VLAN ranges: [40, 40]

    MTU 1500; XC ID 0x40001; interworking none

    Statistics:

      packets: received 5679, sent 5679

      bytes: received 363456, sent 340740

      drops: illegal VLAN 0, illegal length 0

  PW: neighbor 10.1.1.2, PW ID 1234, state is up ( established )

    PW class not set, XC ID 0xc0000001

    Encapsulation MPLS, protocol LDP

    Source address 10.1.1.1

    PW type Ethernet, control word disabled, interworking none

    PW backup disable delay 0 sec

    Sequencing not set

    PW Status TLV in use

      MPLS         Local                          Remote

      ------------ ------------------------------ -----------------------------

      Label        289988                         23

      Group ID     0x140                          0x0

      Interface    TenGigE0/0/0/0.40              unknown

      MTU          1500                           1500

      Control word disabled                       disabled

      PW type      Ethernet                       Ethernet

      VCCV CV type 0x2                            0x2

                   (LSP ping verification)        (LSP ping verification)

      VCCV CC type 0x6                            0x6

                   (router alert label)           (router alert label)

                   (TTL expiry)                   (TTL expiry)

      ------------ ------------------------------ -----------------------------

    Incoming Status (PW Status TLV):

      Status code: 0x0 (Up) in Notification message

    Outgoing Status (PW Status TLV):

      Status code: 0x0 (Up) in Notification message

    MIB cpwVcIndex: 3221225473

    Create time: 15/01/2013 01:03:18 (18:26:34 ago)

    Last time status changed: 15/01/2013 14:14:18 (05:15:33 ago)

    Statistics:

      packets: received 5679, sent 5679

      bytes: received 340740, sent 363456

7600

Router#sh mpls l2transport vc 1234 detail

Local interface: Gi3/1.40 up, line protocol up, Eth VLAN 40 up

  Interworking type is Ethernet

  Destination address: 10.1.1.1, VC ID: 1234, VC status: up

    Output interface: Vl20, imposed label stack {289988}

    Preferred path: not configured

    Default path: active

    Next hop: 10.0.0.1

  Create time: 18:25:30, last status change time: 05:16:18

  Signaling protocol: LDP, peer 10.1.1.1:0 up

    Targeted Hello: 10.1.1.2(LDP Id) -> 10.1.1.1, LDP is UP

    Status TLV support (local/remote)   : enabled/supported

      LDP route watch                   : enabled

      Label/status state machine        : established, LruRru

      Last local dataplane   status rcvd: No fault

      Last local SSS circuit status rcvd: No fault

      Last local SSS circuit status sent: No fault

      Last local  LDP TLV    status sent: No fault

      Last remote LDP TLV    status rcvd: No fault

      Last remote LDP ADJ    status rcvd: No fault

    MPLS VC labels: local 23, remote 289988

    Group ID: local 0, remote 320

    MTU: local 1500, remote 1500

    Remote interface description: TenGigE0_0_0_0.40

  Sequencing: receive disabled, send disabled

  Control Word: Off (configured: autosense)

  VC statistics:

    transit packet totals: receive 6004, send 6645

    transit byte totals:   receive 408288, send 425280

    transit packet drops:  receive 0, seq error 0, send 0

1 ACCEPTED SOLUTION

Accepted Solutions
xthuijs
Cisco Employee

Remember that the 7600 does implicit pops, which the asr9000 doesn't do because of the EVC model.

In order for this to work you need to use the rewrite ingress tag pop 1 symmetric under the 9k l2transport interface.

Which may require you to adjust the MTU then also properly to maintain the PW up status.

Both items are discussed in technotes for ASR9000 MTU and ASR9000 flexible vlan model that you can find on the support forums.

regards

xander

-----

Xander Thuijs CCIE #6775

Principal Engineer ASR9000

View solution in original post

6 REPLIES 6
xthuijs
Cisco Employee

Remember that the 7600 does implicit pops, which the asr9000 doesn't do because of the EVC model.

In order for this to work you need to use the rewrite ingress tag pop 1 symmetric under the 9k l2transport interface.

Which may require you to adjust the MTU then also properly to maintain the PW up status.

Both items are discussed in technotes for ASR9000 MTU and ASR9000 flexible vlan model that you can find on the support forums.

regards

xander

-----

Xander Thuijs CCIE #6775

Principal Engineer ASR9000

View solution in original post

Thanks, this work.

I've add "rewrite ingress tag pop 1 symmetric", but forgot to change mtu (and not seen that xconnect went down).

Change mtu and xconnect works.

Hi,

I'm trying this configrations. But I cant access both site. Could you assist please?

!

interface TenGigE0/0/0/0.211 l2transport

encapsulation dot1q 211

rewrite ingress tag pop 1 symmetric

!

interface TenGigE0/1/0/0.212 l2transport

encapsulation dot1q 212

rewrite ingress tag pop 1 symmetric

!

l2vpn

xconnect group p2p

  p2p test1

   interface TenGigE0/0/0/0.211

   interface TenGigE0/0/0/0.212

  !

!

!

RP/0/RSP0/CPU0:zap#sh l2vpn xconnect brief

Thu Jan 24 12:58:56.160 GMT

Locally Switching

  Like-to-Like                        UP       DOWN        UNR

    EFP                                1          0          0

    Total                              1          0          0

  Total                                1          0          0

Total: 1 UP, 0 DOWN, 0 UNRESOLVED

Umit, if this is the exact configuration you are using I think I see a typo?

the 212 vlan interface is ten 0/ONE/0/0 and in your l2pvn config you used ten 0/ZERO/0/0

xander

Thank you xander. I fixed. But still not runing.

I want to connect 2 diffrent vlan on the ASR router. My topology and configrations are below.

Mexico (Cisco VXRG2) --> fiber line Vlan 612 --> LA (ASR9006) --> fiber line Vlan 611 -->Newark (Cisco VXRG1)

First point is Mexico city. I 'm using ( CiscoVXRG2)

interface configs are:

!

interface GigabitEthernet0/3.612

encapsulation dot1Q 612

ip address 172.17.1.1 255.255.255.252

no cdp enable

end

!

#ping 172.17.1.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.17.1.2, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

#

LA (ASR9006)

!

interface TenGigE0/1/0/0.611 l2transport

encapsulation dot1q 611

rewrite ingress tag pop 1 symmetric

!

interface TenGigE0/1/0/0.612 l2transport

encapsulation dot1q 612

rewrite ingress tag pop 1 symmetric

!

l2vpn

xconnect group mex2nw

  p2p mex2nwfiber

   interface TenGigE0/1/0/0.611

   interface TenGigE0/1/0/0.612

  !

!

!

Newark(VXRG1)

!

interface GigabitEthernet0/2.611

encapsulation dot1Q 611

ip address 172.17.1.2 255.255.255.252

no cdp enable

end

!

#ping 172.17.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.17.1.1, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

#

RP/0/RSP0/CPU0:zap#sh l2vpn xconnect state up

Thu Jan 24 15:03:48.999 GMT

Legend: ST = State, UP = Up, DN = Down, AD = Admin Down, UR = Unresolved,

        SB = Standby, SR = Standby Ready

XConnect                   Segment 1                   Segment 2

Group      Name       ST   Description            ST   Description            ST

------------------------   -------------------------   -------------------------

mex2nw     mex2nwfiber

                      UP   Te0/1/0/0.611          UP   Te0/1/0/0.612          UP

--------------------------------------------------------------------------------

RP/0/RSP0/CPU0:zap#sh l2vpn xconnect summary

Thu Jan 24 15:03:36.233 GMT

Number of groups: 1

Number of xconnects: 1

  Up: 1  Down: 0  Unresolved: 0

  AC-PW: 0  AC-AC: 1  PW-PW: 0 Monitor-Session-PW: 0

Number of Admin Down segments: 0

Number of MP2MP xconnects: 0

  Up 0 Down 0

  Advertised: 0 Non-Advertised: 0

Number of CE Connections: 0

  Advertised: 0 Non-Advertised: 0

Backup PW:

  Configured   : 0

  UP           : 0

  Down         : 0

  Admin Down   : 0

  Unresolved   : 0

  Standby      : 0

  Standby Ready: 0

RP/0/RSP0/CPU0:zap#sh l2vpn xconnect brief

Thu Jan 24 15:03:29.766 GMT

Locally Switching

  Like-to-Like                        UP       DOWN        UNR

    EFP                                1          0          0

    Total                              1          0          0

  Total                                1          0          0

Total: 1 UP, 0 DOWN, 0 UNRESOLVED

Message was edited by: Umit AYDINLI Because copy paste errors.

your configs and 9k outputs look fine Umit.

considering that you are talking a Gig to a tengig there must be something in the middle and that device may be affecting your forwarding.

eg the switch between the 7200 and the 9k may not know the vlan in its trunk etc.

best way to triage this further is to use the asr9000 packet troubleshooting reference (that you can find under my profile, documents) to get the right commands and see if the 9k is at all seeing them and potentially dropping and for what reason.

but if I were to guess, it may be a switch/trunk issue .

xander

Content for Community-Ad