cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1342
Views
0
Helpful
5
Replies
Beginner

BFD not working logical bundle-ethernet

I was wondering what could be wrong if i'm trying to configure BGP BFD under logical bundle-ethernet.

here's the scenario in short words

i'm establishing a B2B VRF between 2 GSR routers with IOS-XR 4.2.3 . BGP peering is established over B2B vrfs between the two GSRs over bundle-ethernet subinterfaces.

the problem is that BFD isn't coming up.

BFD over logical bundles is supported and i managed to configure it a few months ago. but now it won't.

any help is appreciated

Everyone's tags (7)
5 REPLIES 5

BFD not working logical bundle-ethernet

Hi

I am fighting with the same case: CRS-2-Nexus via bundle + BGP and still no success

I have got 4.2.4 on CRS-3 - I am goint to open the case for this issue. It looks for me like a bug in 4.2.0 software.

Check the output form sho bfd session.

Do you have the same ADMIN DOWN  status ?

CRS:

interface Bundle-Ether1000

bfd address-family ipv4 destination 1.1.1.2

ipv4 address 1.1.1.1 255.255.255.252

bfd

!

interface Bundle-Ether1000

echo disable

!

router bgp 65000

neighbor 1.1.1.2

remote-as 65400

bfd fast-detect

bfd multiplier 3

bfd minimum-interval 500

!

!

!

NEXUS:

feature bfd

interface port-channel1000

bfd interval 500 min_rx 500 multiplier 3

no bfd echo

router bgp 65400

neighbor 1.1.1.1 remote-as 65000

   bfd

And still I see on CSR:

RP/0/RP0/CPU0:#sho bfd session

Mon Nov 25 13:34:11.755 CET

Interface           Dest Addr           Local det time(int*mult)      State

                                   Echo             Async

------------------- --------------- ---------------- ---------------- ----------

BE1000             1.1.1.2    0s               0s               ADMIN DOWN

Participant

BFD not working logical bundle-ethernet

I believe BFD over logical interfaces is not needed

So:

interface Bundle-Ether1000

no bfd address-family ipv4 destination 1.1.1.2

no bfd

Registring BFD with BGP as you did already should be enough:

router bgp 65000

neighbor 1.1.1.2

remote-as 65400

  bfd fast-detect

    !

!

bfd multiplier 3

bfd minimum-interval 500

adam

adam
Highlighted
Contributor

Re: BFD not working logical bundle-ethernet

 
Beginner

Re: BFD not working logical bundle-ethernet

BoB and BLB shouldn't be compared in terms of which one is better or worse because they serve a different purpose. It's all a matter of what you need. BoB protects the bundle itself and on top that applications that decide to run BFD with the same peer inherit the BFD state from BoB. But it only works with directly attached L3 peer.

BLB is a multi-path BFD by definition. You can use it to run BFD with peers that are multiple hops away.

/Aleks

Beginner

Re: BFD not working logical bundle-ethernet

in my case, just put this simple command and BFD over Bundle-ether is work:

 

RP/0/RSP0/CPU0:RC11#conf t
RP/0/RSP0/CPU0:RC11(config)#bfd
RP/0/RSP0/CPU0:RC11(config-bfd)#multipath include location 0/0/CPU0
RP/0/RSP0/CPU0:RC11(config-bfd)#commit
RP/0/RSP0/CPU0:RC11(config-bfd)#end
RP/0/RSP0/CPU0:RC11#

 

Here is the BFD session detail when problem / before put above config:

RP/0/RSP0/CPU0:RC11#sho bfd sum
Node All PPS usage MP PPS usage Session number
% Used Max % Used Max Total MP Max
---------- --------------- --------------- ------------------
0/0/CPU0 0 0 28000 0 0 9600 0 0 8000
RP/0/RSP0/CPU0:RC11#

 

RP/0/RSP0/CPU0:RC11#sho bfd session det
I/f: Bundle-Ether4.3210, Location: 0/RSP0/CPU0
Dest: 10.210.0.50
Src: 10.210.0.2
State: DOWN for 3d:21h:47m:24s, number of times UP: 0
Session type: SW/V4/SH/BL
Received parameters:
Version: 0, desired tx interval: 0 ms, required rx interval: 0 ms
Required echo rx interval: 0 ms, multiplier: 0, diag: None
My discr: 0, your discr: 0, H/D/F/P/C/A: 0/0/0/0/0/0
Transmitted parameters:
Version: 0, desired tx interval: 0 ms, required rx interval: 0 ms
Required echo rx interval: 0 ms, multiplier: 0, diag: None
My discr: 0, your discr: 0, H/D/F/P/C/A: 0/0/0/0/0/0
Timer Values:
Local negotiated async tx interval: 0 ms
Remote negotiated async tx interval: 0 s
Desired echo tx interval: 0 s, local negotiated echo tx interval: 0 ms
Echo detection time: 0 ms, async detection time: 0 ms
Label:
Internal label: 43913/0xab89
Local Stats:
Intervals between async packets:
Tx: Number of intervals=0, min=0 s, max=0 s, avg=0 s
Last packet transmitted 0 s ago
Rx: Number of intervals=0, min=0 s, max=0 s, avg=0 s
Last packet received 0 s ago
Intervals between echo packets:
Tx: Number of intervals=0, min=0 s, max=0 s, avg=0 s
Last packet transmitted 0 s ago
Rx: Number of intervals=0, min=0 s, max=0 s, avg=0 s
Last packet received 0 s ago
Latency of echo packets (time between tx and rx):
Number of packets: 0, min=0 ms, max=0 ms, avg=0 ms
MP download state: BFD_MP_DOWNLOAD_NO_LC
State change time: Dec 11 02:29:02.432
Session owner information:
Desired Adjusted
Client Interval Multiplier Interval Multiplier
-------------------- --------------------- ---------------------
bgp-default 500 ms 3 500 ms 3

 

Here is the BFD session after :

RP/0/RSP0/CPU0:RC11#sh bfd sum
Node All PPS usage MP PPS usage Session number
% Used Max % Used Max Total MP Max
---------- --------------- --------------- ------------------
0/0/CPU0 0 18 28000 0 18 9600 9 9 8000
RP/0/RSP0/CPU0:RC11#

 

RP/0/RSP0/CPU0:RC11#sh bfd session det
I/f: Bundle-Ether4.3210, Location: 0/0/CPU0
Dest: 10.210.0.50
Src: 10.210.0.2
State: UP for 0d:0h:1m:0s, number of times UP: 1
Session type: SW/V4/SH/BL
Received parameters:
Version: 1, desired tx interval: 500 ms, required rx interval: 500 ms
Required echo rx interval: 0 ms, multiplier: 3, diag: None
My discr: 65538, your discr: 65537, state UP, D/F/P/C/A: 0/0/0/1/0
Transmitted parameters:
Version: 1, desired tx interval: 500 ms, required rx interval: 500 ms
Required echo rx interval: 0 ms, multiplier: 3, diag: None
My discr: 65537, your discr: 65538, state UP, D/F/P/C/A: 0/0/0/1/0
Timer Values:
Local negotiated async tx interval: 500 ms
Remote negotiated async tx interval: 500 ms
Desired echo tx interval: 0 s, local negotiated echo tx interval: 0 ms
Echo detection time: 0 ms(0 ms*3), async detection time: 1500 ms(500 ms*3)
Label:
Internal label: 43913/0xab89
Local Stats:
Intervals between async packets:
Tx: Number of intervals=100, min=418 ms, max=502 ms, avg=458 ms
Last packet transmitted 246 ms ago
Rx: Number of intervals=100, min=420 ms, max=500 ms, avg=462 ms
Last packet received 423 ms ago
Intervals between echo packets:
Tx: Number of intervals=0, min=0 s, max=0 s, avg=0 s
Last packet transmitted 0 s ago
Rx: Number of intervals=0, min=0 s, max=0 s, avg=0 s
Last packet received 0 s ago
Latency of echo packets (time between tx and rx):
Number of packets: 0, min=0 ms, max=0 ms, avg=0 ms
MP download state: BFD_MP_DOWNLOAD_ACK
State change time: Aug 28 01:08:47.866
Session owner information:
Desired Adjusted
Client Interval Multiplier Interval Multiplier
-------------------- --------------------- ---------------------
bgp-default 500 ms 3 500 ms 3

 

Regards,

 

 

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards
This widget could not be displayed.