cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
640
Views
5
Helpful
4
Replies
WalidAmer36586
Beginner

Cisco BGP L2VPN EVPN advertise VPNV4 is not working, No EVPN type 5 routes generated.

I am trying to generate BGP EVPN type 5 routes from IOSXR platform, ASR9K or NCS, in order to implement DCI. However, I got the below error.

IOSXR version: Cisco IOS XR Software, Version 7.0.1

router bgp 1
neighbor 192.168.0.2
address-family l2vpn evpn
advertise vpnv4 unicast
!!% 'BGP' detected the 'warning' condition 'The address family is not supported'
!
!
!
end

1 ACCEPTED SOLUTION

Accepted Solutions
smilstea
Cisco Employee

I see that you opened a TAC SR as well and below is your configuration:

 

neighbor 192.168.0.2
<edit>
address-family ipv4 unicast
!
address-family vpnv4 unicast
next-hop-self
!
address-family ipv6 unicast
!
address-family vpnv6 unicast
!
address-family l2vpn evpn
!
!

 

 

You are trying to add:

address-family l2vpn evpn
advertise vpnv4 unicast

 

You already have the vpnv4 unicast address-family configured, you cannot have the l2vpn evpn and vpnv4 address families activated for the same neighbor at the same time if you are then going to advertise vpnv4 within l2vpn evpn (stitching).

 

See below config guide for how to enable stitching:

https://www.cisco.com/c/en/us/td/docs/routers/asr9000/software/asr9k-r6-3/lxvpn/configuration/guide/b-l3vpn-cg-asr9000-63x/b-l3vpn-cg-asr9000-63x_chapter_0111.html#task_6B3D13C152BB4614A62374AB5F9EE181

 

Sam

View solution in original post

4 REPLIES 4
smilstea
Cisco Employee

I see that you opened a TAC SR as well and below is your configuration:

 

neighbor 192.168.0.2
<edit>
address-family ipv4 unicast
!
address-family vpnv4 unicast
next-hop-self
!
address-family ipv6 unicast
!
address-family vpnv6 unicast
!
address-family l2vpn evpn
!
!

 

 

You are trying to add:

address-family l2vpn evpn
advertise vpnv4 unicast

 

You already have the vpnv4 unicast address-family configured, you cannot have the l2vpn evpn and vpnv4 address families activated for the same neighbor at the same time if you are then going to advertise vpnv4 within l2vpn evpn (stitching).

 

See below config guide for how to enable stitching:

https://www.cisco.com/c/en/us/td/docs/routers/asr9000/software/asr9k-r6-3/lxvpn/configuration/guide/b-l3vpn-cg-asr9000-63x/b-l3vpn-cg-asr9000-63x_chapter_0111.html#task_6B3D13C152BB4614A62374AB5F9EE181

 

Sam

View solution in original post

Thanks Sam.

I have removed the VPNV4 address-family between the the leaf and the DCI and I am able now to advertise VPNV4 routes through L2VPN EVPN address-family.

I can see now BGP EVPN route type 5 on the DCI routers advertised from the leaf.

 

sh bgp l2vpn evpn
Mon Mar 30 17:43:29.575 UTC
BGP router identifier 192.168.0.7, local AS number 21723
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0x0 RD version: 0
BGP main routing table version 177
BGP NSR Initial initsync version 1 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 1:1
*>i[5][0][24][192.168.1.0]/80 192.168.0.6 0 100 0 ?

Now, I can proceed with the DCI stitching configuration.

Thanks

Walid

Hi Sam,

I am having a similar issue here - i am seeing incoming T5 evpn prefixes but no local prefixes are being advertised, the command advertise vpvn4 unicast local doesn't seem to exist on the CLI. ?

 

Here is my BGP config (nve peers are up and learnt routes are being imported into the vrf blue).. neighbor 172.31.79.3 is where the T5 prefixes are coming from

 

Also i'm running XR 6.4.2 (not sure if this version is good?)

 

router bgp 1234
bgp router-id 62.20.236.3
bgp graceful-restart
bgp log neighbor changes detail
bgp bestpath compare-routerid
address-family ipv4 unicast
bgp attribute-download
network 10.230.112.20/31
network 62.20.236.3/32
redistribute connected
!
address-family vpnv4 unicast
!
address-family vpnv6 unicast
!
address-family ipv4 mdt
!
address-family l2vpn evpn
retain route-target all
!
neighbor 172.31.79.3
remote-as 65001
ebgp-multihop 5
update-source Loopback10
address-family l2vpn evpn
import stitching-rt re-originate
route-policy ACCEPT in
route-policy ACCEPT out
advertise vpnv4 unicast re-originated stitching-rt
default-originate
soft-reconfiguration inbound always
!
!
!
vrf blue
rd 3301:65120
address-family ipv4 unicast
redistribute connected route-policy ACCEPT
!


RP/0/RSP0/CPU0:hdn-5g-r3#show bgp l2vpn evpn
Wed Apr 15 14:43:40.725 CET
BGP router identifier 62.20.236.3, local AS number 3301
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0x0 RD version: 0
BGP main routing table version 71
BGP NSR Initial initsync version 4 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 65001:120
*> [5][0][29][20.20.20.0]/80
172.31.79.3 0 0 65001 ?
*> [5][0][32][120.120.120.1]/80
172.31.79.3 0 0 65001 65100 i

Processed 2 prefixes, 2 paths
RP/0/RSP0/CPU0:hdn-5g-r3#

 


RP/0/RSP0/CPU0:hdn-5g-r3#show run int lo 99
Wed Apr 15 14:43:55.747 CET
interface Loopback99
vrf blue
ipv4 address 99.99.99.1/32
!

RP/0/RSP0/CPU0:hdn-5g-r3#

 

 

 

It should be there, are you configuring it under the right AFI and under the neighbor?

https://www.cisco.com/c/en/us/td/docs/routers/asr9000/software/asr9k-r6-2/lxvpn/configuration/guide/b-l3vpn-cg-asr9000-62x/b-l3vpn-cg-asr9000-62x_chapter_0111.html

You have one version of the command on this neighbor:
neighbor 172.31.79.3
remote-as 65001
ebgp-multihop 5
update-source Loopback10
address-family l2vpn evpn
import stitching-rt re-originate
route-policy ACCEPT in
route-policy ACCEPT out
advertise vpnv4 unicast re-originated stitching-rt


Sam
Content for Community-Ad