cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
416
Views
0
Helpful
7
Replies
Amos Kafwembe
Beginner

Clustering ASR9001 BNG over Xconnect (Two sites)

Hi all,

We am trying to cluster two ASR9001. so, what we did was set up the cluster back to back and have it working, after it worked we are trying to deploy the devices over a PW between two different sites. However, the device on one side keeps rebooting and has the error "This (D)RP Node is not ready or active for login /configuration" any ideas anyone?

my config is based on this -  http://www.cisco.com/c/en/us/td/docs/routers/asr9000/software/asr9k_r4-3/interfaces/configuration/guide/hc43xasr9kbook/hc43clst.pdf

7 REPLIES 7
Aleksandar Vidakovic
Cisco Employee

Hi Amos,

the message you have seen is expected when the RP is not up yet. There must have been some other messages reported on the console that would give you a better lead as to why is the RP on this rack continuously reloading.

Can I ask you what solution are you trying to deploy? If it's BNG, have you considered deploying BNG Geo-Redundancy instead of a cluster?

Regards,

Aleksandar

Hi Aleksander,

yes, we are trying to deploy BNG. I haven't tried the Geo-redundancy but am willing to give it a shot. do u have any links to this set up? below is the console output;

  Node  (     Seq)     Role       Serial State
---------------------------------------------------------
    0/RSP0/CPU0  (       0)   ACTIVE  FOC1832N47P PRIMARY-DSC
    1/RSP0/CPU0  (   30450)   ACTIVE  FOC1832N485 NON-DSC

rib/card_state': 'sysdb' detected the 'warning' condition 'Failed to send a request to a remote node, node doesn't exist or isn't available yet'
RP/1/RSP0/CPU0:2015 Dec  3 09:15:19.062 UTC: cluster_clm_rp[171]: %PLATFORM-CLUSTER_CLM-6-UPDN : Interface 14 (Clustering Port0) is Up
RP/1/RSP0/CPU0:2015 Dec  3 09:15:19.065 UTC: cluster_clm_rp[171]: %PLATFORM-CLUSTER_CLM-6-UPDN : Interface 15 (Clustering Port1) is Up

RP/0/RSP0/CPU0:Bng1#RP/1/RSP0/CPU0:2015 Dec  3 09:15:29.000 UTC: rdsfs_svr[379]: %OS-NRS_LIB-7-ERROR : nrs_register_lib_internal: info 0x40000009(/etc/onepk_cli_rdsfs) error: 82ce5600('NRS' detected the 'try again' condition 'NRS server did not respond within the timeout period')  : pkg/bin/rdsfs_svr : (PID=204886) :  -Traceback= 4c353f8c 4bde0f28 40018fe8 400071f4 400017f0 4b314cb4 4b319118 4b2f5920 4b2f4adc 4b2f3888 4b2f6e38 4b2e33cc

hi Amos,

rack 1 is apparenty hitting a SW bug. To investigate that further it would be the best to open a TAC SR.

With regards to BNG Geo-Redudancy, please refer to the config guide:

http://www.cisco.com/c/en/us/td/docs/routers/asr9000/software/asr9k_r5-3/bng/configuration/guide/b-bng-cg53xasr9k/b-bng-cg53xasr9k_chapter_0101.html#concept_6EEDD157BA0340DCAE483FCBBA839EA2

Recommended release for Geo-R is the next Extended Maintenance Release 5.3.3. We can already share an EFT image if you would like to start the SW validation early.

For more info on early validaton of 5.3.3, please refer to: https://supportforums.cisco.com/discussion/12697761/do-you-want-test-xr-533-pre-release-asr9000

Regards,

Aleksandar

Hi Aleksandar,

On behalf of Amos below is something worthy mentioning;

The cluster was forming in without problems when it cluster was setup back to back before being deployed on L2 port mode connection when we started encountering this problem.

Best regards,

My apologues, but I couldn't follow all that you wanted to say. I'm sure we can resolve the issue, it's just that for the kind interaction required for further troubleshooting it would be better to proceed through a TAC SR.

regards,

Aleksandar

Hi aleksander,

The cluster formed when the two devices were connected back to back, however, after deploying one device to another site and linking the two VIA Xconnect we are getting that error.

Do you still feel we have to open a TAC?

hi Amos,

have you followed the guidelines and restrictions from this CCO document:

http://www.cisco.com/c/en/us/td/docs/routers/asr9000/software/asr9k_r5-3/nV/configuration/guide/b_nv_cg53xasr9k/b_nv_cg53xasr9k_chapter_0110.html#concept_2EF56A47E77F4CAAA0B362CE06D23FAD

Regards,

Aleksandar